Jump to content

HEVC MKV Playback Issues


notla49285

Recommended Posts

Hi, I've attempted to play a HEVC-encoded MKV video via the Emby web app on PS4's browser, however the video never loads, I only see the TV show's backdrop whilst the video is attempting to play.

 

It is on the local network and attempts to direct play. I have also tried the Emby Android app (v3.0.15), this also direct plays but the video loads fine. I've tried remotely using the web app (desktop PC) and this also works though it does transcode. Attached is the media info.

post-255194-0-24462200-1537777630_thumb.jpg

Edited by notla49285
Link to post
Share on other sites
  • 3 weeks later...

I am having the same issue, its all HEVC files that do it, if you turn on the subtitles it will play but it looks like thats because its forcing a transcode.

Here is the ffmpeg log as well.

Edited by Jrod696
Link to post
Share on other sites

The same as above, on the PS4 if you play an HEVC file it just shows the background image and doesnt do anything past that. The dashboard on the server says is playing and its direct streaming but on the tv nothing is happening. If you do anything to force it to transcode like turn on subtitles or lower the playback resolution below the original it will play but otherwise its a no go. Basically the server is trying to direct stream an HEVC format which the PS4 browser using tv.emby.media cannot stream, it doesnt know it needs to transcode.

Link to post
Share on other sites

Strange that it detected hevc as supported, almost as if the PS4 browser is lying about it. We'll look into it. Thanks.

Link to post
Share on other sites
  • 3 months later...

Guys, I'm having the same issue here with HEVC files, every time I try to play a video on (PC, Mobile) it works! But when trying to play it on PS4 it freezes on the show's backdrop and never plays

 

how can I fix this??? or there is no fix for it other than replacing the file with 264 file?

 

Please help 

Link to post
Share on other sites

Guys, I'm having the same issue here with HEVC files, every time I try to play a video on (PC, Mobile) it works! But when trying to play it on PS4 it freezes on the show's backdrop and never plays

 

how can I fix this??? or there is no fix for it other than replacing the file with 264 file?

 

Please help 

 

Hi there, let's look at an example. Please attach the information requested in how to report a media playback issue. thanks !

Link to post
Share on other sites

In this log hardware acceleration was still enabled. Can you please try disabling that in the emby server dashboard transcoding section, then try again? Also  please try installing the latest nvidia graphics drivers and then reboot your server machine. Thanks.

Link to post
Share on other sites

In this log hardware acceleration was still enabled. Can you please try disabling that in the emby server dashboard transcoding section, then try again? Also  please try installing the latest nvidia graphics drivers and then reboot your server machine. Thanks.

 

I did everything you said and still, nothing changed!!

 

FFmpeg: https://paste2.org/9vLtMJjb 

Link to post
Share on other sites

So its not a fix but I did end up finding a work around for what I needed, since it was only certain files I need the PS4 to play, mainly kids stuff, I just created a subtitle file with the phrase Hi! at the 1 second mark and put eng.forced.srt in the file name.

That causes emby to assume there are forced subtitles and then forces it to trans-code and then it will play, I did that a couple times and then just shelled out 20 bucks for a Fire Stick and never worried about it again.

Edited by Jrod696
Link to post
Share on other sites

So its not a fix but I did end up finding a work around for what I needed, since it was only certain files I need the PS4 to play, mainly kids stuff, I just created a subtitle file with the phrase Hi! at the 1 second mark and put eng.forced.srt in the file name.

That causes emby to assume there are forced subtitles and then forces it to trans-code and then it will play, I did that a couple times and then just shelled out 20 bucks for a Fire Stick and never worried about it again.

 

Thank you so much!! It worked!!!

Edited by iD7eeM
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...