Jump to content

Emby not syncing movies


Noel Grassy
 Share

Go to solution Solved by Noel Grassy,

Recommended Posts

Noel Grassy

Should i be able to see the update/sync process? I can't tell if it's running or not. I reset the database and if I restart it asks me if I want to resume but I can't tell if it's running.

Link to comment
Share on other sites

aenima99x

Should i be able to see the update/sync process? I can't tell if it's running or not. I reset the database and if I restart it asks me if I want to resume but I can't tell if it's running.

Same issue here.....when I tail the kodi.log I see the following error

 

20:15:06.418 T:139712967677696  NOTICE: EMBY.library -> --->[ library ]

20:15:06.463 T:139712967677696  NOTICE: EMBY.database -> [emby] 1 rows updated.

20:15:52.379 T:139712967677696  NOTICE: Previous line repeats 4 times.

20:15:52.379 T:139712967677696  NOTICE: EMBY.library -> ERROR:: global name 'settings' is not defined

                                            Traceback (most recent call last):

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/library.py", line 216, in startup

                                                FullSync(self)

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 45, in __init__

                                                if not xmls.advanced_settings():

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/helper/xmls.py", line 88, in advanced_settings

                                                if settings('useDirectPaths') != "0":

                                            NameError: global name 'settings' is not defined

20:15:52.379 T:139712967677696  NOTICE: EMBY.library -> ---<[ library ]

  • Like 1
Link to comment
Share on other sites

Noel Grassy

At least I'm not alone. :D In the emby addon when I click the tv shows listing I get all my shows and they are playable. Nothing in any of the others though. And nothing in the actual library. And i'm using kodi companion and using the beta plug-in.

Edited by Noel Grassy
  • Like 1
Link to comment
Share on other sites

aenima99x

Yeah same here.....I guess we suffer for running bleeding edge. I'm on the latest Milhouse build, with the latest Emby beta along with this. I may have to revert the addon back to the last version cuz the family is getting antsy

  • Like 1
Link to comment
Share on other sites

Angelblue05

Looking into it right now. I stated in the post it's alpha/beta... please don't use on your main yet.

 

Edit: Posting the fix in a few minutes. Thanks. 

Edit 2: Should be available shortly (available now via sideloading) 3.1.01a

Edited by Angelblue05
  • Like 2
Link to comment
Share on other sites

Noel Grassy

At this point I think I like using the latest versions rather than watching anything. I try to make sure the rest of the household doesn't lose functionality. I try. 

  • Like 2
Link to comment
Share on other sites

Angelblue05

Thanks for helping test. Last minute addition and I forgot a line of code to ensure clean on update is disabled. Threw the whole thing. But it should work now.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

aenima99x

Just pulled your changes and now get this....

 

21:15:01.833 T:139972653258496  NOTICE: EMBY.full_sync -> generate full sync
21:15:09.697 T:139972653258496  NOTICE: EMBY.library -> ERROR:: global name 'root' is not defined
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/library.py", line 216, in startup
                                                FullSync(self)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 45, in __init__
                                                if not xmls.advanced_settings():
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/helper/xmls.py", line 99, in advanced_settings
                                                video = root.find('videolibrary')
                                            NameError: global name 'root' is not defined
21:15:09.697 T:139972653258496  NOTICE: EMBY.library -> ---<[ library ]
 

  • Like 1
Link to comment
Share on other sites

aenima99x

Thanks 3.1.02a is working perfect and the sync is really fast now!

Appreciate all your work Angelgblue.....several drinks on the way :)

Edited by aenima99x
  • Like 1
Link to comment
Share on other sites

aenima99x

Glad to hear it's working. Thank you!

quick question.....I initially chose to just sync movies. How do I add the rest of the libraries after? Update libraries only does Movies even if I choose all. Do I need to do a reset?

 

nm....I just did a reset and choose them all

Edited by aenima99x
  • Like 1
Link to comment
Share on other sites

Angelblue05

You don't need to do a reset anymore (last resort). A lot of options are accessible via context menu when you launch the addon itself.

Edited by Angelblue05
Link to comment
Share on other sites

Hi Angelblue05,

I'm still having issues with 3.1.02a. If I sync views (I selected "All") during setup, the initial synchronization completes and all seems well, however...

On restarting Kodi, I get "Emby error" on startup, and I am also unable to open the Emby plugin either, also throwing an "Emby error".

 

Win 10 (17751)

Kodi 18 Beta 1 (And also Nightlies)

 

Log

https://pastebin.com/VzzieP1E

 

Hope this helps.

 

Drexyl

  • Like 1
Link to comment
Share on other sites

Sorry for the slow response again, took forever to download the plugin..
 

Good news is though, looks good.  No more errors on loading Kodi, or Plugin. Awesome work.

 

And don't thank me, big thanks to you for your effort.

 

Drexyl

  • Like 1
Link to comment
Share on other sites

Noel Grassy

Wow this is fast! Everything syncs except music and music videos. I also keep getting "Library needs to rescan tags from files" every time I try open the music library in kodi. I can't add music videos because everytime I try it restarts the old music library scan and throws an error. Aside from that this is very nice. 

 

https://paste.kodi.tv/ecadupexek

Edited by Noel Grassy
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...