Jump to content

Scan media library failed


Recommended Posts




Hoping someone can point me in the right direction for an error "Scan medial library failed" that has shown up on  on my dashboard and recurring "Debug App: Running FFProbeProvider" errors I'm seeing in my log file.


My setup is fresh.  Emby v3.5.2.0 (portable) installed on a newly minted Windows Server 2016 server and launched using task scheduler at Windows Startup (like being able to restart Emby from dashboard).  The install went smoothly.  Prior to importing my movies and tv shows I stripped them to just the containing folder (movie name (20??) and tv show name\season ?) and the base video file.  No images, nfo, etc.  Then they were added to Emby and Emby built everything.  I did chose to have Emby store everything with the video file and had it pre-fetch everything during the initial build out.  When all was finished library update appeared to run cleanly and I don't recall seeing any alerts.  Yesterday when I came in the alerts panel said the library scan failed.  Every scan now reports the same thing.  Odd thing is the scans appear to be successful.  My library is large but I'm not seeing any gaps.


As a diagnostic I've attempted a number of things including;

* Pulling source folder from the library, scan, and re-add the source folder.  Did that 1 by 1 for each library.

* Pulling the source folder from the library, delete the library, scan, re-create the library (same name).  Did that 1 by 1 for each library.

* Moving all movies out of the movie folder, scan the library, move the movies back and scan again.

* Moving all tv shows out of the tv shows folder, scan the library, move the tv shows back and scan again.


Ran a few other scenarios that I won't bore with here.  I was hesitant to clear clear caches or dbs as I'm not versed with the app yet.  That and spent a LOT of time creating the collections and marking what was/wasn't watched (gotta keep my wife happy).


Anyway, below is a screenshot of my dashboard and I've attached a copy of my logs (debug on).  Hoping someone can point me to where I need to go to clear this up. 


Also, in looking at the logs I see a recurring scan (Debug App: Running FFProbeProvider/MovieDbTrailerProvider/OmdbItemProvider) for a series of movies (primarily).  There are 15 of them at the moment.  Look at them in the meta data browser they look correct with provider information populated.  Rescanning them with replace doesn't help nor does pulling the videos, scanning, and re-introducing them.  I realize it likely isn't hurting anything but the OCD in me would like to correct this.  Any suggestions would be appreciated.



embyserver - scanning issue.txt

Edited by accarshop
Link to comment
Share on other sites

HI, this has been reported by a couple people but i haven't tracked it down yet. Since this is a fresh install, if you'd like to try the beta and let us know if the issue remains, that would be helpful. thanks.

Link to comment
Share on other sites


The title of the series will come from your first priority tv series metadata provider, which by default is Tvdb. If you want the plain folder name to be used then you'd have to disable internet metadata.


Okay, 2 steps forward, a nice step forward, and a shuffle to the side.  Too early to be tipsy.


Downloaded beta and dropped it in.  It took a bit to redo the library but based in what I read in the changelog and size of my library it wasn't unexpected.  After it finished I gave it a bit, bounced Emby, forced a library scan, and restarted Emby one more time to see if anything happened.  Here is what I can report after an initial look through the system (see bolded pls).


  • Library update failure alerts - Alerts are gone.  Additionally, the Debug App: Running FFProbeProvider/MovieDbTrailerProvider/OmdbItemProvider entries are cleared up too.
  • General GUI - See little tweaks and peeks here and there.  Everything looks good.
  • Logs - See a quite a bit more detail, particularly around the library update, in the logs.  Kudos and Thanks!
  • LiveTV - Live TV isn't recognizing my Premier id.  I can bring up the guide and play tv but get the "Get Emby Premier" banner for setting recordings.

    [update] Went back and tested this on the IOS app, Android app, Android TV (nVidia Shield TV) app, and the web app.  Only place I get the "Get Emby Premier" banner is the web app. 

  • Main Movies Screen - Really like that it is the full list of movies again.  I like the collections a LOT but my wife wanted to still be able to see the full library.
  • Plugins - On my previous install I don't believe some of the plugins worked correctly.  Can see a LOT more plugin data in the logs and before Collections didn't seem to work.  I had to manually create collections and move movies in.  Since moving to beta they are cleaned up nicely.  Did end up with a couple duplicates.  Will work on those in a bit.

Thank you for the recommendation on going to beta.  I'll try to run it through it's paces and report if I find anything.  And hopefully the record tv is an easy fix.  Let me know if you need a log on it or for me to try anything.


Thanks again for the fast response and all the nice work.

Edited by accarshop
Link to comment
Share on other sites


Had some time to go back and do more testing.  The "Get Emby Premier" was limited to the Firefox browser (my default) on my primary system.  Clearing the cache/history in Firefox had no effect nor did a number of other things I tried.  When I got to my add-ons I found success.  It appears that somehow the EFF Privacy Badger add-on was causing it.  As soon as I disabled it the Emby Web Client could initiate recordings.  Interestingly enough, the record buttons continued to work in the web client after re-enabling Privacy Badger.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...