Jump to content
silverfox292

FireTV Live HD channels playback error.

Recommended Posts

silverfox292

Hi All,

 

New to Emby after switching from Plex and liking it so far.

 

I am having an issue with playing live HD channels. When selected the player loads, I get the popup asking if there is an issue and this will repeat until it gives up.

 

I can get the channel to play by switching to a lower quality and then switching back however.

 

Setup:

Fire TV (Pendant) connected to LAN with Ethernet adapter

Emby App v1.6.15a

Emby Server v3.5.2.0 Running on Ubuntu 16.04.4 LTS

HDHomeRun CONNECT Quatro 1250DF7C v20180817

 

Settings:

 

Client playback set to auto. (Auto sets quality to 30 Mb/s)

Direct TV checked.

 

Steps:

 

- Select HD channel (BBC One HD)

- Spinning circle

- Select lower quality (1 Mb/s)

- Channel plays at low quality

- Select original / higher quality (30 Mb/s)

- Channel plays at this quality.

 

Log sent by this Emby connect account on 03/09/2018 17:15 UTC+1

 

Is there anything I can do to have the channel play at the higher quality without going through these steps?

 

Thanks

 

ffmpeg log 2018-03-09 1715(2).txt

ffmpeg log 2018-03-09 1715.txt

ffmpeg log 2018-03-09 1714(2).txt

ffmpeg log 2018-03-09 1714.txt

Emby server log.txt

Share this post


Link to post
Share on other sites
ebr

Hi.

 

Since you appear to be in the UK, try selecting the option to use MPV for Live TV playback.

 

Thanks.

Share this post


Link to post
Share on other sites
maegibbons

@@silverfox292

 

Welcome to Emby from the rest of the UK Users!!

 

To explain further.  Generally the inbuilt exoplayer which is the default player used in the F/ATV app has issues with UK HD Channels which means that you have to go "through" playback correction or the steps you worked out to get the channels to play.

 

The alternative MPV player actually plays UK HD content very well however its has other issues especially with other Android TV hardware.

 

On Fire TV the app works pretty well as the components are from an older android version and are relatively stable.

 

So under settings/Live TV select "Prefer MPV Player"

 

Krs

 

Mark

Edited by maegibbons

Share this post


Link to post
Share on other sites
silverfox292

Thanks for all the help guys.

 

Tried out the MPV player, but playback is just too choppy and often loses sync.

 

Comparing same steps to Plex, the channel takes longer to load but then plays with no problems.

Whats the difference between Emby's and Plex's Exoplayer?

 

Think I have managed to get round this issue by setting the maximum playback bitrate to 10 Mbps.

This loads the channel fairly fast and in comparison still looks better than my Virgin tv package.

 

Will this negatively effect the quality of streaming local videos?

 

Thanks again.

Share this post


Link to post
Share on other sites
ebr

Did you try un-checking "Attempt to direct stream Live TV"?

Share this post


Link to post
Share on other sites
silverfox292

Did you try un-checking "Attempt to direct stream Live TV"?

 

 Tried MPV and Exoplayer with and without this option, same issues unfortunately.

Share this post


Link to post
Share on other sites
Luke

How did it differ exactly after unchecking that?

Share this post


Link to post
Share on other sites
silverfox292

MPV with Direct Play - Smooth audio, video stutters then jumps to catch up.

MPV without Direct Play - Smooth audio, video slows down and speeds up to try and keep sync. Leads to moving mouths and disembodied voices.

 

Thanks again for all your help. For now I will be moving to a freeview recorder and sticking with plex for local streaming.

I think Emby is a great product and will definitely be keeping an eye on it.

Share this post


Link to post
Share on other sites
maegibbons

@@silverfox292

 

I am surprised by that result as I have not seen any issues using MPV on the Fire TV.

 

Have you tried the Fire TV beta app?  Whilst I cannot think of a recent change specific to your problem it may help.

 

I am unavalable fot the next 10 days, But if you would like to trouble shoot your setup after that I would be willing to try and help.

 

Krs

 

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...