Jump to content

Question about my 32-bit upgrade


loomes
 Share

Go to solution Solved by Luke,

Recommended Posts

loomes

With version 3.3.1.0 all is working fine.

After update to newest version CoverArt wont work.

Log Snippets:

2018-05-05 00:46:05.341 Info Main: Emby
	Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
	Operating system: Unix 4.12.0.2
	64-Bit OS: False
	64-Bit Process: False
	User Interactive: False
	Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Fri Jan 12 03:39:06 UTC 2018)
	Processor count: 4
	Program data path: /var/lib/emby-server
	Application directory: /usr/lib/emby-server/bin
2018-05-05 00:46:05.758 Info App: Application version: 3.4.0.0
2018-05-05 00:46:05.759 Info App: Loading assemblies
2018-05-05 00:46:05.792 Info App: Loading AutoBoxSets, Version=1.1.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/AutoBoxSets.dll
2018-05-05 00:46:05.792 Info App: Loading CoverArt, Version=4.0.69.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/CoverArt.dll
2018-05-05 00:46:05.792 Info App: Loading Emby.Kodi.SyncQueue, Version=2.0.3.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Emby.Kodi.SyncQueue.dll
2018-05-05 00:46:05.792 Info App: Loading MBBackup, Version=1.2.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/MBBackup.dll
2018-05-05 00:46:05.792 Info App: Loading MediaBrowser.Plugins.VuPlus, Version=3.1.7.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/MediaBrowser.Plugins.VuPlus.dll
2018-05-05 00:46:05.792 Info App: Loading statistics, Version=2.0.4.2, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Statistics.dll
2018-05-05 00:46:05.792 Info App: Loading Trakt, Version=3.1.7.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Trakt.dll
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Api, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.WebDashboard, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Model, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Common, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Controller, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Providers, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Photos, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Server.Implementations, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Server.MediaEncoding, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Dlna, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.LocalMetadata, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.XbmcMetadata, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading MediaBrowser.Server.Mono, Version=3.4.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Server.Connect, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.793 Info App: Loading Emby.Server.Sync, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-05 00:46:05.858 Info SqliteUserRepository: Sqlite version: 3.23.1
2018-05-05 00:46:05.859 Info SqliteUserRepository: Sqlite compiler options: COMPILER=gcc-7.3.0,ENABLE_COLUMN_METADATA,ENABLE_DBSTAT_VTAB,ENABLE_FTS3,ENABLE_FTS3_PARENTHESIS,ENABLE_FTS3_TOKENIZER,ENABLE_FTS4,ENABLE_FTS5,ENABLE_JSON1,ENABLE_LOAD_EXTENSION,ENABLE_PREUPDATE_HOOK,ENABLE_RTREE,ENABLE_SESSION,ENABLE_STMTVTAB,ENABLE_UNLOCK_NOTIFY,ENABLE_UPDATE_DELETE_LIMIT,HAVE_ISNAN,LIKE_DOESNT_MATCH_BLOBS,MAX_SCHEMA_RETRY=25,MAX_VARIABLE_NUMBER=250000,OMIT_LOOKASIDE,SECURE_DELETE,SOUNDEX,TEMP_STORE=1,THREADSAFE=1
2018-05-05 00:46:08.540 Info App: Starting entry point CoverArt.ServerEntryPoint
2018-05-05 00:46:08.543 Info CoverArt: CoverArt plugin not supported on this system.
2018-05-05 00:46:08.585 Info App: Entry point completed: CoverArt.ServerEntryPoint. Duration: 0.045185 seconds
2018-05-05 00:47:40.387 Error App: ServerEntryPoint.Instance.CoverArtImageProcessor should not be null
2018-05-05 00:47:40.389 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.4.0.0
	Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
	Operating system: Unix 4.12.0.2
	64-Bit OS: False
	64-Bit Process: False
	User Interactive: False
	Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Fri Jan 12 03:39:06 UTC 2018)
	Processor count: 4
	Program data path: /var/lib/emby-server
	Application directory: /usr/lib/emby-server/bin
	System.NullReferenceException: Object reference not set to an instance of an object
	  at CoverArt.API.ImageHandler.Get (CoverArt.API.ImageRequest request) [0x00054] in <ecb23a74c2084ff283e50b055faa0177>:0 
	  at (wrapper dynamic-method) System.Object:lambda_method (System.Runtime.CompilerServices.Closure,object,object)
	  at Emby.Server.Implementations.Services.ServiceExecGeneral.Execute (System.Type serviceType, MediaBrowser.Model.Services.IRequest request, System.Object instance, System.Object requestDto, System.String requestName) [0x00076] in <5dcc71ee105a46ae808df98663db5dea>:0 
	  at Emby.Server.Implementations.Services.ServiceController.Execute (Emby.Server.Implementations.HttpServer.HttpListenerHost appHost, System.Object requestDto, MediaBrowser.Model.Services.IRequest req) [0x00054] in <5dcc71ee105a46ae808df98663db5dea>:0 
	  at Emby.Server.Implementations.Services.ServiceHandler+<ProcessRequestAsync>d__13.MoveNext () [0x00161] in <5dcc71ee105a46ae808df98663db5dea>:0 
	--- End of stack trace from previous location where exception was thrown ---
	  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at Emby.Server.Implementations.HttpServer.HttpListenerHost+<RequestHandler>d__70.MoveNext () [0x006d9] in <5dcc71ee105a46ae808df98663db5dea>:0 
	System.NullReferenceException
	  at CoverArt.API.ImageHandler.Get (CoverArt.API.ImageRequest request) [0x00054] in <ecb23a74c2084ff283e50b055faa0177>:0 
	  at (wrapper dynamic-method) System.Object:lambda_method (System.Runtime.CompilerServices.Closure,object,object)
	  at Emby.Server.Implementations.Services.ServiceExecGeneral.Execute (System.Type serviceType, MediaBrowser.Model.Services.IRequest request, System.Object instance, System.Object requestDto, System.String requestName) [0x00076] in <5dcc71ee105a46ae808df98663db5dea>:0 
	  at Emby.Server.Implementations.Services.ServiceController.Execute (Emby.Server.Implementations.HttpServer.HttpListenerHost appHost, System.Object requestDto, MediaBrowser.Model.Services.IRequest req) [0x00054] in <5dcc71ee105a46ae808df98663db5dea>:0 
	  at Emby.Server.Implementations.Services.ServiceHandler+<ProcessRequestAsync>d__13.MoveNext () [0x00161] in <5dcc71ee105a46ae808df98663db5dea>:0 
	--- End of stack trace from previous location where exception was thrown ---
	  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0 
	  at Emby.Server.Implementations.HttpServer.HttpListenerHost+<RequestHandler>d__70.MoveNext () [0x006d9] in <5dcc71ee105a46ae808df98663db5dea>:0 
Link to comment
Share on other sites

Hi there, can you please attach the complete emby server log? What OS are you on and how did you update to 3.4?

Link to comment
Share on other sites

loomes

Its an Debian Testing 32Bit

I updatet by manual replace the Files in /usr/lib/emby-server/bin with the mono zip from https://github.com/MediaBrowser/Emby.Releases

 

Normaly i update over http://download.opensuse.org/repositories/home:/emby/Debian_Next/ but there is only version 3.3.1.0 at the moment.

 

I can open the CoverArt Settings in the Admin Panel and can change settings but he dont display any preview Pictures for Treatments or overlays.

When i go back to version 3.3.1.0 all is working fine.

server.txt

Edited by Luke
Link to comment
Share on other sites

  • Solution

The zip file contains three or four files with .config extensions. I am guessing you overwrote everything however those files should not be overwritten. Without those, imagemagick is going to fail to load and so will cover art because it can't do anything without image magick.

  • Like 1
Link to comment
Share on other sites

loomes

Ohhh im an Idiot :D

Thats it. I reinstalled 3.3.1.0 from the repository and copied the new Version without the .config files and all is working.

Thank you for the super fast support.

Link to comment
Share on other sites

  • 2 months later...
Nikotine

Hello,

 

I am on Debian 9 64bit.

 

I update by manual replace the Files in /usr/lib/emby-server/bin with the mono zip (without config files): https://github.com/MediaBrowser/Emby/releases

Emby.Mono.zip (3.5.0.0)

It works fine for update 3.3.1 to 3.4.

But it does not worf for me for update 3.4 to 3.5

 

Anyone can help me please?

Link to comment
Share on other sites

Nikotine

Hi,

Thanks for your reply.

 

When I update 3.4 to 3.5.

I don't have access to the web interface.

I replace the Files in /usr/lib/emby-server/bin with the mono zip from https://github.com/M...r/Emby/releases

Is it a good way to upgrade?

 

When i go back to version 3.4.0.0 all is working fine.

 

Sorry for spelling, I am a native french speaker...

Link to comment
Share on other sites

 

 

I don't have access to the web interface.

 

What happened when you tried to access the web interface? What version of mono do you have installed?

Link to comment
Share on other sites

Nikotine

- When I try to acces the web interface: timeout bad gateway

 

I use Mono JIT compiler version 4.8.1.

I update wit Emby.mono (3.5.0.0)

 

I will retry.

Link to comment
Share on other sites

Nikotine

After update Emby 3.4 to 3.5 with this methot.

 

emby-server start
Info Main: Emby
        Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
        Operating system: Unix 4.9.0.6
        64-Bit OS: True
        64-Bit Process: True
        User Interactive: False
        Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Sun Jul 15 19:36:19 UTC 2018)
        Processor count: 8
        Program data path: /var/lib/emby-server
        Application directory: /usr/lib/emby-server/bin
appHost.Init
Info App: Application version: 3.5.0.0
Info App: Loading assemblies
Info App: File /var/lib/emby-server/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
Info App: File /usr/lib/emby-server/bin/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
Info App: File /var/lib/emby-server/plugins/IMVDb.dll has version 1.0.1.0
Info App: File /usr/lib/emby-server/bin/plugins/IMVDb.dll has version 1.0.1.0
Info App: File /var/lib/emby-server/plugins/OpenSubtitles.dll has version 1.0.2.0
Info App: File /usr/lib/emby-server/bin/plugins/OpenSubtitles.dll has version 1.0.2.0
Info App: Loading Emby.Server.CinemaMode, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Emby.Server.CinemaMode.dll
Info App: Loading IMVDb, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/IMVDb.dll
Info App: Loading OpenSubtitles, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/OpenSubtitles.dll
Info App: Loading MediaBrowser.Api, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.WebDashboard, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.Model, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.Common, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.Controller, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.Providers, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Photos, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Server.Implementations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Server.MediaEncoding, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Dlna, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.LocalMetadata, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Notifications, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.XbmcMetadata, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading MediaBrowser.Server.Mono, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Server.Connect, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Info App: Loading Emby.Server.Sync, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null
Could not load signature of Emby.Server.Implementations.Library.LibraryManager:Sort due to: Could not resolve type with token 010001ab assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.ValueTuple`2 member:<none>
Error Main: UnhandledException
        *** Error Report ***
        Version: 3.5.0.0
        Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
        Operating system: Unix 4.9.0.6
        64-Bit OS: True
        64-Bit Process: True
        User Interactive: False
        Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Sun Jul 15 19:36:19 UTC 2018)
        Processor count: 8
        Program data path: /var/lib/emby-server
        Application directory: /usr/lib/emby-server/bin
        System.TypeLoadException: Could not load type 'Emby.Server.Implementations.Library.LibraryManager' from assembly 'Emby.Server.Implementations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null'.
          at Emby.Server.Implementations.ApplicationHost.Init () [0x000a7] in <2ffcef5e7afa4820adabddd39d6ca745>:0
          at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Implementations.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Implementations.StartupOptions options) [0x000c2] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
          at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0009c] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
        System.TypeLoadException
          at Emby.Server.Implementations.ApplicationHost.Init () [0x000a7] in <2ffcef5e7afa4820adabddd39d6ca745>:0
          at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Implementations.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Implementations.StartupOptions options) [0x000c2] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
          at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0009c] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0

UnhandledException
System.TypeLoadException: Could not load type 'Emby.Server.Implementations.Library.LibraryManager' from assembly 'Emby.Server.Implementations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=null'.
  at Emby.Server.Implementations.ApplicationHost.Init () [0x000a7] in <2ffcef5e7afa4820adabddd39d6ca745>:0
  at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Implementations.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Implementations.StartupOptions options) [0x000c2] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
  at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0009c] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
System.TypeLoadException
  at Emby.Server.Implementations.ApplicationHost.Init () [0x000a7] in <2ffcef5e7afa4820adabddd39d6ca745>:0
  at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Implementations.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Implementations.StartupOptions options) [0x000c2] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
  at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0009c] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0

I do something wrong, but I don't know what...

Link to comment
Share on other sites

Nikotine

I am an idiot!

Luke, Thank you for your support.

 

I understand your question.

Mono-based releases now require mono 5.4+ to run...

 

I update mono to Mono JIT compiler version 5.12.0.

All works fine.

 

Thanks you.

Link to comment
Share on other sites

@@Nikotine, Emby Server 3.5 now requires mono 5.4+, so you will need to update that since you currently only have 4.8.1. Please let us know if this helps. Thanks.

Link to comment
Share on other sites

  • 7 months later...
adilei

Hi Guys,

 

I've also manually upgraded to 3.5.0.0 by copying the contents of mono.zip, after having upgraded to mono 5.18.0.268.

 

When starting emby-server on my ubuntu machine, emby seems to go into a "loop", as partial log files are continuously written, but it never really starts up (web interface address says "cannot be reached"). 

 

Edit: based on syslog it looks like emby is crashing and respawning, however I'm not seeing the crash/exception in the logs:

 

 
Mar  4 22:24:14 media-server kernel: [3058945.305366] init: emby-server main process ended, respawning

 

Edit #2: trying to run emby from command line shows that it's not able to locate the sqllite binaries?

 

Unhandled Exception:
System.DllNotFoundException: libembysqlite3.so.0
  at (wrapper managed-to-native) SQLitePCL.SQLite3Provider_sqlite3+NativeMethods.sqlite3_libversion_number()
  at SQLitePCL.SQLite3Provider_sqlite3.SQLitePCL.ISQLite3Provider.sqlite3_libversion_number () [0x00000] in <3ba88cd71c374f278501a1db4b226935>:0
  at SQLitePCL.raw.SetProvider (SQLitePCL.ISQLite3Provider imp) [0x00008] in <724f9a22df504a05b4645fb690570b7a>:0
  at MediaBrowser.Server.Mono.MainClass.SetSqliteProvider () [0x00005] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
  at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0000a] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.DllNotFoundException: libembysqlite3.so.0
  at (wrapper managed-to-native) SQLitePCL.SQLite3Provider_sqlite3+NativeMethods.sqlite3_libversion_number()
  at SQLitePCL.SQLite3Provider_sqlite3.SQLitePCL.ISQLite3Provider.sqlite3_libversion_number () [0x00000] in <3ba88cd71c374f278501a1db4b226935>:0
  at SQLitePCL.raw.SetProvider (SQLitePCL.ISQLite3Provider imp) [0x00008] in <724f9a22df504a05b4645fb690570b7a>:0
  at MediaBrowser.Server.Mono.MainClass.SetSqliteProvider () [0x00005] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0
  at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0000a] in <6ecbc9e0c5a4459cb6198c00e242f85d>:0

I do seem to have the binary here: /usr/lib/emby-server/i386-linux-gnu/libembysqlite3.so.0

 

 

Otherwisr, the many (unhelpful) logs files that are written contain the following (server.txt):

 

2019-03-04 22:18:22.296 Info Main: Emby
Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
Operating system: Unix 4.2.0.35
64-Bit OS: False
64-Bit Process: False
User Interactive: False
Mono: 5.18.0.268 (tarball Thu Feb 28 15:29:17 UTC 2019)
Processor count: 2
Program data path: /var/lib/emby-server
Application directory: /usr/lib/emby-server/bin
2019-03-04 22:18:23.571 Info App: Application version: 3.5.0.0
2019-03-04 22:18:23.575 Info App: Loading assemblies
2019-03-04 22:18:23.592 Info App: File /var/lib/emby-server/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
2019-03-04 22:18:23.592 Info App: File /usr/lib/emby-server/bin/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
2019-03-04 22:18:23.592 Info App: File /var/lib/emby-server/plugins/IMVDb.dll has version 1.0.1.0

or server-63687334758.txt:

 

2019-03-04 22:19:15.980 Info Main: Emby
Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
Operating system: Unix 4.2.0.35
64-Bit OS: False
64-Bit Process: False
User Interactive: False
Mono: 5.18.0.268 (tarball Thu Feb 28 15:29:17 UTC 2019)
Processor count: 2
Program data path: /var/lib/emby-server
Application directory: /usr/lib/emby-server/bin
2019-03-04 22:19:17.241 Info App: Application version: 3.5.0.0
2019-03-04 22:19:17.245 Info App: Loading assemblies
2019-03-04 22:19:17.260 Info App: File /var/lib/emby-server/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
2019-03-04 22:19:17.261 Info App: File /usr/lib/emby-server/bin/plugins/Emby.Server.CinemaMode.dll has version 1.0.2.0
2019-03-04 22:19:17.261 Info App: File /var/lib/emby-server/plugins/IMVDb.dll has version 1.0.1.0
2019-03-04 22:19:17.261 Info App: File /usr/lib/emby-server/bin/plugins/IMVDb.dll has version 1.0.1.0
2019-03-04 22:19:17.262 Info App: File /var/lib/emby-server/plugins/OpenSubtitles.dll has version 1.0.2.0
2019-03-04 22:19:17.262 Info App: File /usr/lib/emby-server/bin/plugins/OpenSubtitles.dll has version 1.0.2.0
2019-03-04 22:19:17.279 Info App: Loading Emby.Kodi.SyncQueue, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Emby.Kodi.SyncQueue.dll
2019-03-04 22:19:17.279 Info App: Loading Emby.Server.CinemaMode, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/Emby.Server.CinemaMode.dll
2019-03-04 22:19:17.279 Info App: Loading IMVDb, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/IMVDb.dll
2019-03-04 22:19:17.280 Info App: Loading OpenSubtitles, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby-server/plugins/OpenSubtitles.dll

Any idea what could have gone wrong? 

 

Thanks!

 

Edited by adilei
Link to comment
Share on other sites

You may want to consider going backwards with mono releases in case that might help.

Link to comment
Share on other sites

adilei

Hi, is that all that appears in the server log?

 

I've tried to run emby using command line and got this:

 

Unhandled Exception:

System.DllNotFoundException: libembysqlite3.so.0

 

Could this be the issue?

Link to comment
Share on other sites

adilei

You may want to consider going backwards with mono releases in case that might help.

 

Backwards to which version? Thanks!

Link to comment
Share on other sites

Well we are not actively testing mono on x86 anymore, but you could try 5.14, 5.10, 5.8, etc.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...