Jump to content

Missing albums in Kodi for Emby


jonomite
 Share

Recommended Posts

jonomite

For some reason, Kodi for Emby is not picking up all of my music albums. My movie library is fully synced properly, but I am missing quite a few albums.

 

There doesn't seem to be rhyme or reason to when an album doesn't get picked up. I have albums by the same artist in the same folder that do get picked up.

 

I have tried the "repair local database" option and resynced my music. Hasn't worked. I also tried refreshing all metadata in my Emby server and then did another repair local database but that didn't work.

 

I am using the latest version of Kodi for Emby (3.0.19). Any help is appreciated!

 

Sent from my Nexus 5X using Tapatalk

Link to comment
Share on other sites

Angelblue05

Best thing to do is look at a specific example. Is the music album properly added to your server, or is it missing important metadata such as the musicbrainzid, etc?

Link to comment
Share on other sites

jonomite

Best thing to do is look at a specific example. Is the music album properly added to your server, or is it missing important metadata such as the musicbrainzid, etc?

Sure - what would you need to see? I can confirm that it has all metadata info, thanks to Musicbrainz Picard. I can also confirm it's properly added to the server.

 

Sent from my Nexus 5X using Tapatalk

Link to comment
Share on other sites

Angelblue05

Ok, then, what if you edit info for said album (3 dots menu > edit info > hit save to force it to generate an update in Kodi). Does the album then appear in Kodi? If not, can you provide the kodi log that contains this test.

Edited by Angelblue05
Link to comment
Share on other sites

jonomite

Ok, then, what if you edit info for said album (3 dots menu > edit info > hit save to force it to generate an update in Kodi). Does the album then appear in Kodi? If not, can you provide the kodi log that contains this test.

Yes, I absolutely can. One quick question: what steps do I need to take to give you the most helpful log? Sorry for the basic question - I've not had to find and upload a Kodi log before.

 

Sent from my Nexus 5X using Tapatalk

Link to comment
Share on other sites

Angelblue05

Best way

 

Restart Kodi for a fresh log. Then in the add-on settings > advanced > log level set to debug. Press ok.

In the web app, select a music album that's not showing up > 3 dots menu > edit info > Save.

 

Wait a minute, then grab/post your Kodi log. After that, you can set the add-on log level back to info.

Link to comment
Share on other sites

jonomite

Best way

 

Restart Kodi for a fresh log. Then in the add-on settings > advanced > log level set to debug. Press ok.

In the web app, select a music album that's not showing up > 3 dots menu > edit info > Save.

 

Wait a minute, then grab/post your Kodi log. After that, you can set the add-on log level back to info.

 

Okay, here's what I got. Let me know if I did this right, or if you need something more! Thanks for your help and being so responsive, as always.

kodi.log

Link to comment
Share on other sites

Angelblue05

The log is incorrect the add-on logging is not enabled. After restarting kodi, In emby for kodi add-on settings > advanced tab > log level set to debug. Make sure Kodi debug is not enabled, just the add-on's. Then do the web app steps, wait a minute then grab the log.

Edited by Angelblue05
Link to comment
Share on other sites

jonomite

The log is incorrect the add-on logging is not enabled. After restarting kodi, In emby for kodi add-on settings > advanced tab > log level set to debug. Make sure Kodi debug is not enabled, just the add-on's. Then do the web app steps, wait a minute then grab the log.

 

Sorry. Take 2.

kodi.log

  • Like 1
Link to comment
Share on other sites

Angelblue05

And did the album show up in Kodi? It shows it exists in your Kodi database. Kodi will hide albums that contain no songs, so maybe that's where the issue lies. Do you see the songs that belong to the album in Kodi if you go to Artist > Coldplay?

 

If the songs are also missing, can you provide a new log, repeat the same steps, except this time in the web app, select a song from the album Viva la Vida or Death and All His Friends

Edited by Angelblue05
Link to comment
Share on other sites

jonomite

And did the album show up in Kodi? It shows it exists in your Kodi database. Kodi will hide albums that contain no songs, so maybe that's where the issue lies. Do you see the songs that belong to the album in Kodi if you go to Artist > Coldplay?

 

If the songs are also missing, can you provide a new log, repeat the same steps, except this time in the web app, select a song from the album Viva la Vida or Death and All His Friends

 

The album doesn't display.  I also don't see the songs. I did a search for one of the tracks in Kodi and nothing returned. I will provide a new log.

 

Thanks for helping me troubleshoot this.

Link to comment
Share on other sites

jonomite

And did the album show up in Kodi? It shows it exists in your Kodi database. Kodi will hide albums that contain no songs, so maybe that's where the issue lies. Do you see the songs that belong to the album in Kodi if you go to Artist > Coldplay?

 

If the songs are also missing, can you provide a new log, repeat the same steps, except this time in the web app, select a song from the album Viva la Vida or Death and All His Friends

 

New log attached.

kodi.log

Link to comment
Share on other sites

Angelblue05

Hmm, everything seems normal. The ids match up correctly and it says everything already exists in your Kodi database. I'll pm you in a bit.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...