Jump to content

Update to 3.0.16 - Transcoding no more default for playback


kaufhauslicht
 Share

Recommended Posts

kaufhauslicht

Hi there,

 

I updated to the new version of the emby-Kodi plugin, today. However, an important feature seems to be broken or changed for that matter. Before the update, I clicked on a video and it was transcoded according to my settings, but now it is simply playing in the direct mode, which causes stuttering for my setup.

 

I am using the addon mode with transcoding over the internet on a Raspberry Pi client (libreelec Krypton) in my second home. The server is located in my first home and I am using openmediavault 4 with emby 3.3.1.0 (docker).  

 

However, since the update to the new emby plugin (3.0.16) the automatic transcoding by clicking on a video is not working anymore, instead I have to start it manually over the context menu. Is there a way to set up transcoding as default for playing content again?

 

Thx

Edited by kaufhauslicht
Link to comment
Share on other sites

kaufhauslicht

Hi,

 

thank you. Transcoding is working again as default. However, there is no audio/subtitle selection when you start the playback and the video is starting right away. Only the first audio track is played and no subtitle track is shown. I enable the option audio/subtitle selection in the settings menu. 

Link to comment
Share on other sites

Angelblue05

That is expected as the add-on now uses the pre-built url provided by your server. It should be using your user settings. If you go to the web app > your profile > subtitles and playback settings should have an effect on what happens when you transcode in Kodi.

 

Let me know if it's not the case. I've had users ask me to have this selection done automatically and this is the best approach since you'd get the same result in every player.

Edited by Angelblue05
Link to comment
Share on other sites

kaufhauslicht

Hi,

 

all right and thank you for your quick reply. I changed the settings in the profile menu in order to play the German audio track as default. However, when emby is transcoding the first audio track is always used, regardless of the language settings. For example (see log attached), I want to play the movie "Atomic Blond" with German audio, which is audio track number 2. However, the first audio track- English- is played. Or did I something wrong with the settings?

 

Furthermore, I have a lot of videos with different audio tracks. Sometimes, I want to watch movies in English and sometimes in German or I even want to chose the commentary track. I know, that I can chose the force transcoding option via the context menu, but unfortunately I have not mapped the context button to my remote (too less buttons). Therefore, the old way to choose audio and subtitle tracks before playing was working way better for me. I can understand why other users do not want the audio/subtitle selection interface anymore, since playback is starting right away and they usually prefer the same language. Is it possible to add an option "start video right away" vs. "audio/subtitle selection" for an upcoming update, so everyone can chose the best individual option?

 

 Thank you and happy Easter.  :)

Edited by kaufhauslicht
  • Like 1
Link to comment
Share on other sites

Angelblue05

Ok I will revert this back.

 

Can you give this a try and confirm everything works correctly for you? Thank you!

 

I'll wait to post a new build, to give other users a chance to post their issues if any. Since I already bumped the version twice heh :)

plugin.video.emby-3.0.19a.zip

Edited by Angelblue05
Link to comment
Share on other sites

kaufhauslicht

Hi,

 

now it is working as before and the audio/subtitles dialog appears before starting a video. Great! Is this version going to be the new stable one?

 

Thank you so much.

Edited by kaufhauslicht
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...