Jump to content

Blue boxes instead of cover art


thrlly
 Share

Recommended Posts

thrlly

Hi,

 

since the latest emby server version, i'm getting blue boxes on my clients. i'm not sure if thats related to the emby addon or embuary.

 

i'm running both, the beta version of emby for kodi and the stable version, same problem.

 

 

Link to comment
Share on other sites

Chipsta040365

Server updated to 3.3 and cover art had a compatibility update at same time - make sure emby and cover art are updated

Reboot after each update

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

thrlly

i do not have cover art installed on my server. embuary took the cover art of the libary from emby i guess. this 4 picture cover style from the libarys.

 

did several restarts of the server and clients, rebuild the kodi frontend etc. no change. just blue boxes

Edited by thrlly
Link to comment
Share on other sites

Angelblue05

In your screenshot, are those your emby libraries or something else?

 

You could try to repoint the shortcuts in the skin settings > edit home library menu. Hopefully that'll force it to refresh.

Edited by Angelblue05
Link to comment
Share on other sites

thrlly

they changed from blue to transparant, but now i cant play videos anymore: 

 

15:30:07.225 T:139898601846528  NOTICE: EMBY.default_tvshows -> Parameter string: ?dbid=2151&mode=play&id=2bdaaa990a83770c9737867b56530a2e&filename=
15:30:07.306 T:139898601846528  NOTICE: EMBY.playbackutils -> Play called: 
15:30:07.778 T:139898601846528  NOTICE: EMBY.downloadutils -> ERROR:: === Bad status response: 500 ===
15:30:07.783 T:139898601846528   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'requests.exceptions.HTTPError'>
                                            Error Contents: 500 Server Error: Internal Server Error for url: http:/:16000/emby/Items/2bdaaa990a83770c9737867b56530a2e/PlaybackInfo
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby.tvshows/default.py", line 50, in <module>
                                                entrypoint.doPlayback(itemid, dbid)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/entrypoint.py", line 49, in doPlayback
                                                pbutils.PlaybackUtils(item).play(itemId, dbId)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playbackutils.py", line 90, in play
                                                play_url = putils.PlayUtils(self.item, listitem).get_play_url(force_transcode)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playutils.py", line 55, in get_play_url
                                                info = self.get_playback_info()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playutils.py", line 100, in get_playback_info
                                                info = self.emby.get_playback_info(self.item['Id'], self.get_device_profile())
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/read_embyserver.py", line 671, in get_playback_info
                                                'LiveStreamId': None
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/downloadutils.py", line 287, in downloadUrl
                                                response.raise_for_status()
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/models.py", line 935, in raise_for_status
                                                raise HTTPError(http_error_msg, response=self)
                                            HTTPError: 500 Server Error: Internal Server Error for url: http://16000/emby/Items/2bdaaa990a83770c9737867b56530a2e/PlaybackInfo
                                            -->End of Python script error report<--
15:30:07.857 T:139898601846528 WARNING: CPythonInvoker(67, /storage/.kodi/addons/plugin.video.emby.tvshows/default.py): the python script "/storage/.kodi/addons/plugin.video.emby.tvshows/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
15:30:07.862 T:139900039389888   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.emby.tvshows/0b38974f6a27a1b3c73705e0be840642/?dbid=2151&mode=play&id=2bdaaa990a83770c9737867b56530a2e&filename=1.mkv]
15:30:09.729 T:139898444936960  NOTICE: EMBY.kodimonitor -> Method: Playlist.OnClear Data: {"playlistid":1}
Link to comment
Share on other sites

thrlly
16:15:24.892 T:140498647906048   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--

                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!

                                            Error Type: <type 'exceptions.ValueError'>

                                            Error Contents: invalid literal for int() with base 10: 'a9a7a20'

                                            Traceback (most recent call last):

                                              File "/storage/.kodi/addons/plugin.video.emby.tvshows/default.py", line 50, in <module>

                                                entrypoint.doPlayback(itemid, dbid)

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/entrypoint.py", line 49, in doPlayback

                                                pbutils.PlaybackUtils(item).play(itemId, dbId)

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playbackutils.py", line 127, in play

                                                if self._detect_widgets():

                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playbackutils.py", line 59, in _detect_widgets

                                                if kodi_version and "Git:" in kodi_version and int(kodi_version.split('Git:')[1].split("-")[0]) <= 20171119:

                                            ValueError: invalid literal for int() with base 10: 'a9a7a20'

                                            -->End of Python script error report<--

Link to comment
Share on other sites

thrlly

the covers where there, but i was unable to play anything. i've reverted back to the stable version. playback works but blue boxes are back.

Link to comment
Share on other sites

Angelblue05

Please provide your complete Kodi log. Otherwise I can't fix the issue because I can't see how we got there, thank you.

 

I will post a new build today.

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

thrlly

i've fixed the first error with restarting kodi and emby. 

this is what i now get in the kodi log, when i try to start something:

 

16:15:24.892 T:140498647906048   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: invalid literal for int() with base 10: 'a9a7a20'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby.tvshows/default.py", line 50, in <module>
                                                entrypoint.doPlayback(itemid, dbid)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/entrypoint.py", line 49, in doPlayback
                                                pbutils.PlaybackUtils(item).play(itemId, dbId)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playbackutils.py", line 127, in play
                                                if self._detect_widgets():
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/playbackutils.py", line 59, in _detect_widgets
                                                if kodi_version and "Git:" in kodi_version and int(kodi_version.split('Git:')[1].split("-")[0]) <= 20171119:
                                            ValueError: invalid literal for int() with base 10: 'a9a7a20'
                                            -->End of Python script error report<--
Link to comment
Share on other sites

Angelblue05

I understand that. I'll be posting a build shortly to correct this error.

 

How did you fix your first error?

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...