Jump to content

'Show Information' not working for Movies and TV Shows


yosh2k
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Hi Guys,

I think I may have identified a bug with Emby for Kodi when in 'Native (Direct Play)'.

 

My Setup is as follows:

5 x Raspberry PI 3 B+ running the latest Kodi (Libreelec) and Emby addon (2.3.62a) to manage my movies and TV Shows

2 x Computers with Kodi (Windows 10) and Emby addon (2.3.62a) as well

Synology NAS hosting my media (Movies, TV Shows, etc) and running Emby Server 3.2.70

 

I have been using Emby as my media manager for the past 8 months... but recently, I have noticed that with my RPi 3 B+, running in Add-on mode, appears to very slow in loading a Movie or TV Show when selected... would possibly take 20 seconds or so... and the temperature seems to increase of the system, at odd times overheating when in use

 

I have reset all my setups as recommended (RPi and Computers running Kodi/Emby) and use Native (Direct Play) in the Emby addons, and the loading of the Movies/TV Shows are almost instant when selected.

 

The bug I did notice thou, is that if "Default select action" is set on 'Choose' or 'Show Information' within Kodi settings for media... it will just play the source and not show the information screen!

This worked well in Add-on mode, but in Native (Direct Play), it seems to treat the "Show information" as "Play"

 

If I select "Show information" - when a movie (or TV Show is selected) - it simply plays the source, ignoring the 'show Information' screen

I set it as 'Choose' - when a movie (or TV Show is selected) - it will show a popup with 'Play', 'Show information', 'More...' ('Play' and 'Show information' do the same function and play the source)

The only way I can get it to show information is to select 'More...' in the popup, and then select 'Information', or if I press the context menu and select 'Information'

 

I have changed skins to verify its not a skin issue (Amber, Aeon Nox: Silvo, etc...) and this only happens when Emby is set to use use Native (Direct Play), else in Add-on mode, everything works well... but its just so slow to load my content, taking half a minute...

 

If logs are required, please let me know... but I think this issue can be replicated on your end to verify this bug

 

 

 

Link to comment
Share on other sites

Angelblue05

I can't say that I have this issue. Did you reset your database when you made the switch from add-on playback mode to native?

 

Everything is working as intended with native playback. I set the default action to show information and choose. Both show me information when selected.

Edited by Angelblue05
Link to comment
Share on other sites

Thanks for your quick reply!

 

I have reset my database on all my setups... I reset by using the option "Reset local Kodi database" found within 'Advanced' in the 'Settings-Emby' menu

(Settings-Emby->Advanced->"Reset local Kodi database")

 

After I got your reply... I gave it some thought, and decided to try a fresh install on a new computer, I grabbed my laptop which has never had Kodi installed before, downloaded the latest version of Kodi for Windows 10, then installed Emby addon - remember, this laptop has never had Kodi, and after installing Kodi, the only addon it has is Emby - other then that, its on the stock skin with no other addons or personalized data/settings - I wanted to convince myself that there must be an issue or step I am missing on my other setups.

 

After carefully setting up Emby, and signing into my Emby server - I get the same result - upon having Show Information in settings (or 'select' and then choosing 'show information'), I still get the same issue, which is bizarre!

After installing Emby addon - I select the server, then select the user, choose "Native (Direct Play)", input my credentials, select 'No' for Music... after its successfully sync'd all my Movies and TV Shows, ensured that the setting in Kodi is on 'Show Information' (and then later tried 'select')  - in both cases, goes straight into the movie (or tv show).

I even restarted Kodi to see if there was any difference :( still no success!

 

I even downloaded the latest version "plugin.video.emby-3.0.6a.zip", and still the same issue... could the issue be with Emby Server on my Synology? or something not quite going to plan with the way I have configured Emby addon?

Link to comment
Share on other sites

  • Solution
Angelblue05

The issue was using NFS:// vs nfs://. I will be posting a fix for this in the next beta build.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...