Jump to content

External Connections - Force HTTPS


James W
 Share

Recommended Posts

In a recent server update the advanced section for hosting changed. This has caused a bit of an issue for me and possibly other people that are using a reverse proxy for Emby

 

Before I was able to show the external address as the domain I input and the custom port I use. I am using IIS to proxy and do SSL offloading. 

 

IIS is programmed to work on the internal IP over http X.X.X.X:8096

 

My external connection is my domain xxx.xxxx.xxx:custom port  

 

The issue becomes if i checkbox the "Require https for external connections" it will update the remote address to the proper one but then my SSL offloading does not work as all requests are being redirected to https on the Emby server

 

It seems that one of my remote clients a Kodi box actually automaticlly updated the server address to the wrong one because Emby is reporting the wrong external address to clients. 

 

Can the option to use a custom external address and port be returned without forcing https on the Emby server?

Edited by James W
Link to comment
Share on other sites

Swynol

@@James W

 

leave the require HTTPS box unticked. You need a valid PFX cert and password - fill the emby boxes with them. The boxes need to be filled even though we wont be using them!

 

then edit the emby system.xml 

 

look for something like - 

 

<enableHTTPS>false</enableHTTPS>

 

change it to true and restart emby server.

 

it will now report the correct HTTPS://blahblah:443 in the dashboard. point your reverse proxy to the local HTTP port. this way IIS manages the SSL part.

Edited by Swynol
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...