Jump to content

idle timeout expires while syncing


shred00
 Share

Recommended Posts

shred00

I have my users's Kodi profiles set to timeout (using a screensaver addon) after a few minutes of idle time.  But there are times where the sync that happens right after logon takes longer than that timeout and because the user is sitting there waiting for the sync to finish.  Ideally the sync shouldn't take that long but regardless it's a race.

 

Is there any way to make the sync activity look like non-idleness as far as the Kodi idle timer is concerned so that users are not considered idle while waiting for the sync and logged out before it can complete?

 

Obviously it would be better to get sync times to be under even a few minute idle time but until we are there, this seems like it would be a good fix in any case.

Link to comment
Share on other sites

Angelblue05

Ah... using a screensaver addon? What is it? The sync already disables the internal screensaver and re-sets it when done. I don't believe there's a way for the addon to generate activity. I'll have to check.

 

If your server generates a lot of updates for content you haven't watched, etc. you better check server side to see why it's doing that. I have no updates except for content I watch or modify myself. My syncs are a few seconds.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

shred00

Ah... using a screensaver addon? What is it?

script.screensaver.logoff

 

But I am happy to take suggestions of a better logoff screensaver, or method even.

 

The sync already disables the internal screensaver and re-sets it when done.

I wonder why I am getting logged off while the sync is running then.

 

If your server generates a lot of updates for content you haven't watched, etc. you better check server side to see why it's doing that.

Yeah, that's my next avenue per my other thread.

 

I have no updates except for content I watch or modify myself. My syncs are a few seconds.

That's what I want. :-)

Link to comment
Share on other sites

  • 2 weeks later...
shred00

So, this still happens for me.  Maybe it's the particular logoff screensaver that I have chosen to use.  I don't really care which one I use so if there is a better one, that doesn't consider the time Emby is updating to be idle and logoff while that is happening, I'd be happy to switch.

 

Which logoff screensavers (or other methods, if there are other methods) are people using which don't log them off while many-minute updates are happening?

Link to comment
Share on other sites

shred00

Can you give this build a try, let me know if it resolves your situation.

 

So, I am unsure if it resolves the timeout issue.  I only just got it installed yesterday.

 

But one thing I have noticed is that when you start a show playing, the UI overlay sticks around (like when you exit a show playing without pressing stop) and you have to go to the side menu and choose the full-screen option.  Hopefully that explanation makes sense.

Link to comment
Share on other sites

Angelblue05

You'll have to give context, where are you starting playback from, what skin are you using again, etc.

 

I've not seen this issue. And there's no way the add-on is causing this. All it does it either a/ provide the playback path for the file (addon playback mode) or b/ does nothing (native playback mode).

 

The add-on is not involved in playback beyond that.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

shred00

You'll have to give context, where are you starting playback from,

From any menu of show episodes.

 

But if I start from a "TV Shows" screen widget, it plays fine without the menu overlay on top of it.

 

what skin are you using again, etc.

The default Kodi 17.6 skin. I think it's called Estuary.

 

I've not seen this issue. And there's no way the add-on is causing this.

I can't really comment on that. I can just report what I am seeing. The only thing I did was upgrade the Emby plugin.

 

I can upgrade and downgrade back and forth many times and the problem replicates every time only with the new plugin.

 

All it does it either a/ provide the playback path for the file (addon playback mode) or b/ does nothing (native playback mode).

 

The add-on is not involved in playback beyond that.

Again, I don't really have the required understanding of the Kodi playback and plugin system to comment one way or the other. I'm just reporting what I am experiencing, 100% of the time, completely reproducible upgrading and downgrading.   :huh:

Link to comment
Share on other sites

shred00

Not really possible.  These are "STB" (set top box) style Kodi boxes.  There is no "desktop" or tools of such to take screenshots.

 

It's not really hard to imagine.  It's exactly what happens if you "exit" something playing without first pressing stop and the you get the UI overlay translucently on top of what you were watching.  The exact same thing.

 

If you really are not understanding the phenomenon and still think it would be useful, I suppose I could take a "photo" of the TV with it happening.  It will likely be complete with glare on the TV's shiny screen and everything.

Link to comment
Share on other sites

Angelblue05

I understand what you are saying. You get an UI overlay over playback. However, as I said I don't see how this can be an add-on issue.

 

Are you controlling Kodi with a mouse? A remote control?

Edited by Angelblue05
Link to comment
Share on other sites

shred00

I understand what you are saying. You get an UI overlay over playback.

Yes, but to be clear, the problem is not that some UI overlay starts on top of the playback, it's that the UI overlay that I was on when I chose "Play" just doesn't disappear when the playback starts. The playback starts underneath the UI overlay that was there when I pressed Play.

 

However, as I said I don't see how this can be an add-on issue.

I can certainly understand you perplexity. I can completely see how this would not appear to be a add-on issue. but I can replicate this problem with 100% reproducibility simply by upgrading the stable emby addon to the 3.0.7a one and make the problem go away by downgrading back to stable. Nothing else is changed.

 

Are you controlling Kodi with a mouse? A remote control?

A remote control with LIRC. But I suspect this would happen if I used an IP/API remote such as Kore for example.

Link to comment
Share on other sites

Angelblue05

So your default play action is set to what? Choose? Show information?

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

shred00

So your default play action is set to what? Choose? Show information?

 

 

Sent from my iPhone using Tapatalk

 

I'm not sure how to determine that.  I just know that on a menu of show episodes, when I press "OK" (Enter perhaps is what it maps to) on the remote, the show starts playing.  Here's what the settings for the plugin are:

<settings>
    <setting id="LastIncrementalSync" value="2018-02-05T03:14:50Z" />
    <setting id="SyncInstallRunDone" value="true" />
    <setting id="accessToken" value="" />
    <setting id="additionalUsers" value="" />
    <setting id="askCinema" value="false" />
    <setting id="backupPath" value="" />
    <setting id="connectMsg" value="true" />
    <setting id="connectUsername" value="" />
    <setting id="dbSyncScreensaver" value="false" />
    <setting id="dblock" value="false" />
    <setting id="deleteMovies" value="false" />
    <setting id="deleteTV" value="true" />
    <setting id="deviceName" value="Kodi" />
    <setting id="deviceNameOpt" value="false" />
    <setting id="displayMessage" value="4" />
    <setting id="downloadThreads" value="3" />
    <setting id="enableCinema" value="true" />
    <setting id="enableContext" value="true" />
    <setting id="enableContextTranscode" value="true" />
    <setting id="enableCoverArt" value="true" />
    <setting id="enableExportSongRating" value="false" />
    <setting id="enableExternalSubs" value="true" />
    <setting id="enableImportSongRating" value="true" />
    <setting id="enableMusic" value="true" />
    <setting id="enableTextureCache" value="true" />
    <setting id="enableUpdateSongRating" value="false" />
    <setting id="failedCount" value="0" />
    <setting id="idMethod" value="0" />
    <setting id="ignoreSpecialsNextEpisodes" value="false" />
    <setting id="imageCacheLimit" value="5" />
    <setting id="incSyncIndicator" value="10" />
    <setting id="limitIndex" value="15" />
    <setting id="limitResolution" value="false" />
    <setting id="logLevel" value="1" />
    <setting id="markPlayed" value="90" />
    <setting id="metricLogging" value="true" />
    <setting id="networkCreds" value="" />
    <setting id="newContent" value="false" />
    <setting id="newmusictime" value="2" />
    <setting id="newvideotime" value="5" />
    <setting id="offerDelete" value="true" />
    <setting id="offlinetMsg" value="true" />
    <setting id="playFromStream" value="true" />
    <setting id="restartMsg" value="false" />
    <setting id="resumeJumpBack" value="10" />
    <setting id="server" value="http://10.75.22.2:8096" />
    <setting id="serverId" value="[redacted]" />
    <setting id="serverName" value="pvr" />
    <setting id="serverSync" value="true" />
    <setting id="skipContextMenu" value="false" />
    <setting id="skipDialogTranscode" value="0" />
    <setting id="sslcert" value="None" />
    <setting id="sslverify" value="false" />
    <setting id="startupDelay" value="0" />
    <setting id="streamMusic" value="false" />
    <setting id="syncEmptyShows" value="false" />
    <setting id="token" value="[redacted]" />
    <setting id="transcodeH265" value="0" />
    <setting id="transcodeHi10P" value="false" />
    <setting id="transcode_h265" value="false" />
    <setting id="useDirectPaths" value="0" />
    <setting id="userId" value="[redacted]" />
    <setting id="username" value="Mom & Dad" />
    <setting id="videoBitrate" value="20" />
</settings>
Link to comment
Share on other sites

Angelblue05

You can find the info in Kodi settings > media > video I think. It should be named: default action or maybe default play action. Sorry I'm not at my computer right now.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...