Jump to content

Live TV back isn't working


FordGT90Concept
 Share

Recommended Posts

FordGT90Concept

This was two hours into a live stream. Upon hitting the back button, the Android TV app would effectively lock up for at least a minute. Once it started playing again, it wasn't back relative to where back was pressed, it was live again. Jumping back effectively doesn't work.

Link to comment
Share on other sites

Exactly what "back" are you referring to?

 

You tried to seek in the stream or you tried to stop the stream?

 

What version of the app are you running?

Link to comment
Share on other sites

FordGT90Concept

Equivalent of left arrow: jump back in time relative to the current position in the stream.

 

Seek.

 

Should be current beta (as of yesterday). A shame Emby Server doesn't record the version number under devices.

 

Edit: 1.5.17g

Edited by FordGT90Concept
Link to comment
Share on other sites

Did the new small OSD pop up?  Server log from when this happened?

 

It sounds like the app requested a seek and it timed out waiting for the server response and then continued playing normally.

 

Of course, that's assuming you were in seek mode in the first place... Are you sure it wasn't direct streaming...?

Link to comment
Share on other sites

FordGT90Concept

Talking the loading circle? Nope.

 

All my devices are set to seek because we use it often.

 

None of the Live TV boxes are checked in the app settings.

 

 

I just jumped back several times which seemed to work fine but when I jumped forward to live, it got stuck like it did going back yesterday. The time coincides with the end of the ffmpeg directstream log. I don't think it should be directstreaming.

logs.zip

Link to comment
Share on other sites

When it "gets stuck" the app is still responsive (or becomes so again) correct?

 

If so, can you please make the problem occur and then send a log from the app?

 

Thanks.

Link to comment
Share on other sites

FordGT90Concept

Yeah, app is responsive.

 

Now got a related problem: can't even live TV now. I tune to a channel, it plays for a second, stops, I see loading wheel, then it stops, it streams enough for a picture, but it doesn't progress. I tried twice, gave up, and switched to HD HomeRun. I'll go try reproduce it and submit logs...

 

 

Edit: I submitted the logs (user Lynn) then went to test. Now it's working fine. In the last 1-2 weeks, live TV via Android app has generally been unreliable.

Edited by FordGT90Concept
Link to comment
Share on other sites

Looks like the stream simply stops coming from the server, then it times out and we re-start it.

12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: Source error.
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: com.google.android.exoplayer2.source.hls.playlist.HlsPlaylistTracker$PlaylistStuckException
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at com.google.android.exoplayer2.source.hls.playlist.HlsPlaylistTracker$MediaPlaylistBundle.processLoadedPlaylist(HlsPlaylistTracker.java:598)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at com.google.android.exoplayer2.source.hls.playlist.HlsPlaylistTracker$MediaPlaylistBundle.onLoadCompleted(HlsPlaylistTracker.java:539)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at com.google.android.exoplayer2.source.hls.playlist.HlsPlaylistTracker$MediaPlaylistBundle.onLoadCompleted(HlsPlaylistTracker.java:472)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at com.google.android.exoplayer2.upstream.Loader$LoadTask.handleMessage(Loader.java:383)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at android.os.Handler.dispatchMessage(Handler.java:102)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at android.os.Looper.loop(Looper.java:154)
12-17 10:22:06.284 13111 13229 E ExoPlayerImplInternal: 	at android.os.HandlerThread.run(HandlerThread.java:61)
12-17 10:22:06.285 13111 13111 I System.out: ***** Got error from Exo player: null
12-17 10:22:06.285 13111 13111 I System.out: Playback error - Failed to load video
12-17 10:22:06.285 13111 13111 I System.out: Player error encountered - retrying

Link to comment
Share on other sites

  • 2 weeks later...
FordGT90Concept

Had the problem described above again. Submitted logs from the SHIELD and here's the server logs.

 

There's two issues here, one unrelated to Live TV (#1-3 below) and the issue described above (#6-16). Figure it's better to spell it all out here because there's 3 submitted logs + server log.

 

Sequence of events as I recall them:

1) Playing Christopher Tin's Calling All Dawns

2) Started playing Vivaldi's album and it was either in the second or third track and the app locked up. I submitted logs through the Google form.

3) I tried to get back into Emby but it just gray-screened me.

4) Restarted the SHIELD.

5) Started Emby, submitted logs, logged back in as Lynn.

6) Started Live TV: Antique's roadshow.

7) May have bounced around TV channels a bit, I forget.

8) Backed out Emby.

9) Opened YouTube app and played a music video.

10) Backed out of YouTube and went back into Emby.

11) Tried to play Antique's roadshow again.

12) Showed a still picture of the show.

13) After at least 10 seconds, I saw the looping circle for a second.

14) The still picture changed. It's not streaming.

15) Back out of Emby.

16) Start Emby, submitted logs.

17) Restarted SHIELD.

logs.zip

Edited by FordGT90Concept
Link to comment
Share on other sites

FordGT90Concept

It just did it again (stuck, wheel, black, stuck). Submitted logs again from Lynn account. Attached server logs.

 

It seems like it doesn't know how to stop one stream and start another. First stream is usually okay, changing channels from that is not.

 

 

Edit: Oops, these two posts are in the wrong thread. That said, live TV back still tends not to function especially after watching the same program for over an hour so...could be related.

problems.zip

Edited by FordGT90Concept
Link to comment
Share on other sites

FordGT90Concept

The above two posts of issues are definitely related to watching Live TV on Android TV and using the guide to change to another TV channel. Tuning the second channel always results in failure.

Link to comment
Share on other sites

FordGT90Concept

When finished watching one channel, backing all the way back to the SHIELD main menu and back into Emby to a different channel is a functional workaround. Time consuming though.

Link to comment
Share on other sites

The above two posts of issues are definitely related to watching Live TV on Android TV and using the guide to change to another TV channel. Tuning the second channel always results in failure.

 

1) By using the guide do you mean backing out of playback to the guide and re-selecting another channel, or bringing up the guide during playback and selecting another channel?

 

2) By "failure" do you mean what you described above (the stream hanging up) or an actual failure with a message?

Link to comment
Share on other sites

FordGT90Concept

1) Watching -> back button (into guide) -> select new channel (in guide).

2) it never gives an error from the android TV side (except the beginning of post #10, which is related to music I think), it just hangs.

Link to comment
Share on other sites

FordGT90Concept

Changing channels via guide issue is now resolved; however, there's still two observed issues yet:

 

1) Similar to the one in the OP: I'm not sure the specific criteria but it may be watching the same channel live for over an hour or after the program on said channel changes, attempting to go back (left arrow) while watching often takes you forward, potentially all the way to real time. The longer you something live, the more likely this bug will surface. Only observed on Android TV app.

 

2) Start from the guide. Pick a channel to watch. Wait until the program information changes to a new program on the same channel. Hit the back button to get back to the guide. The guide is as it was when you started watching. If you try to tune to one of these channels, expect problems because you're trying to go back in time.

 

The guide should invalidate itself after a minute forcing it to refresh. Also, anything on the guide that is older than present, it should assume tune-to-channel instead of tune-to-program.

 

 

Feature request: add a "live TV" button to jump forward to live TV when trick playing. If live (or close to it), pressing it does nothing.

Edited by FordGT90Concept
Link to comment
Share on other sites

The guide should invalidate itself after a minute forcing it to refresh. Also, anything on the guide that is older than present, it should assume tune-to-channel instead of tune-to-program.

 

I think maybe you are just experiencing a delay because it already does this.  However, also, there should be absolutely no problem tuning to a channel even if the guide is "old".  There is no such thing as "tune to program".  The app always just tunes to the channel.

 

So, exactly what problems did you encounter in this situation?

Link to comment
Share on other sites

FordGT90Concept

Maybe it was related to the bug you just fixed where changing channels at all via guide would cause problems. I should do some testing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...