Jump to content

Emby won't play audio when screen is locked


RedBaron164
 Share

Recommended Posts

When playing something in background mode and I turn the phone off, it works great, audio only of course. However when I turn the phone back on, the picture is black. If I expand it to full screen, stays black. The only way I have figured out to fix it is to stop playback and restart it. Phone is a Pixel 2 XL.

@@troyhough

Link to comment
Share on other sites

There has not been a new beta release in the mean time and the original post was removed, so I suppose they found a last minute show stopper. Please wait for a 3.0.22+ release.

  • Like 1
Link to comment
Share on other sites

When playing something in background mode and I turn the phone off, audio keeps playing, works great. However when I turn the phone back on, the video (picture) is black. If I expand it to full screen, the video/image stays black. The only way I have figured out how to fix it is to stop playback and restart it. Phone is a Pixel 2 XL. Also tested on Pixel 1 XL.

Edited by troyhough
Link to comment
Share on other sites

When playing something in background mode and I turn the phone off, audio keeps playing, works great. However when I turn the phone back on, the video (picture) is black. If I expand it to full screen, the video/image stays black. The only way I have figured out how to fix it is to stop playback and restart it. Phone is a Pixel 2 XL. Also tested on Pixel 1 XL.

Luke, did you mean to move this in this thread. My issue is video, not audio.

 

Thanks

Link to comment
Share on other sites

Hi Guys, Hi Luke... I know this is being worked on, just another Me Too.

 

S8 running Android 8.0. I use my android exclusively for listening to music in the shop. (hmm, one thing Plex did better?)

  • Like 1
Link to comment
Share on other sites

Hi Guys, Hi Luke... I know this is being worked on, just another Me Too.

 

S8 running Android 8.0. I use my android exclusively for listening to music in the shop. (hmm, one thing Plex did better?)

 

You use Emby to play back your music library and it stops playing when screen goes black?

Edited by troyhough
Link to comment
Share on other sites

You use Emby to play back your music library and it stops playing when screen goes black?

Yup... That's the one. Also Sometimes(?) stops when it is just not front-center  ie: I'm doing something else with my phone.

 

We should have an update for this in the next few days. Thanks guys.

Thanks Luke!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

I apologize for the delay on this. A beta build is currently going up to resolve this. Thanks everyone.

 

**********Still not fixed in 3.0.24 Beta**********

 

When playing something in background mode and I turn the phone off, it works great, audio only of course. However when I turn the phone back on, the picture is black. If I expand it to full screen, stays black. The only way I have figured out to fix it is to stop playback and restart it. Phone is a Pixel 2 XL.

Link to comment
Share on other sites

That is unrelated to this topic. In my testing i have not seen that, but I'll do some testing and see if I can reproduce. Thanks.

Link to comment
Share on other sites

That is unrelated to this topic. In my testing i have not seen that, but I'll do some testing and see if I can reproduce. Thanks.

 

Unrelated to this topic but you merged my "fix it" post in here?

Link to comment
Share on other sites

  • 2 weeks later...

I apologize for the delay on this. A beta build is currently going up to resolve this. Thanks everyone.

 

I just tried 3.0.28. The issue appears to be fixed. Perfect. Thank you so much :)

  • Like 1
Link to comment
Share on other sites

Audio works while screen is locked, however when you turn the phone screen back on, the video is black. This issue still exists and always has since I started using Emby.

Edited by troyhough
Link to comment
Share on other sites

Audio works while screen is locked, however when you turn the phone screen back on, the video is black. This particular still exists and always has since I started using Emby.

 

We're looking into it, thanks.

  • Like 2
Link to comment
Share on other sites

  • 1 month later...

Hmmm, My phone or tablet will only play two songs from the server and then stops.

 

I have a nokia 8.1 with android 9 and a samsung tablet with android 8.1

Emby server is on a synology nas.

Emby version 4.0.2.0-1

 

I have given Emby no restrictions on my phone.

 

Where do i go wrong is there a work around for this or a setting in the server software?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...