Jump to content


Photo

Hdhomerun emulate using antennas


  • Please log in to reply
3 replies to this topic

#1 arkx82 OFFLINE  

arkx82

    Newbie

  • Members
  • 1 posts
  • Local time: 07:53 PM

Posted 26 July 2017 - 12:27 PM

hello.

 

I would like to use the tvheadend client, but I want to record through emby.(Native)

 

so I am setting....

 

I did use antennas docker (like tvhproxy)

and I did setup plex dvr through antennas (port 5004)

 

so I can live tv and recording in plex

 

but in case emby...

 

I did select hd homerun. and I write IP(ex 192.168.1.8:5004) 

and It is added.

and I did add xmltv.xml

 

but I can't map channels..

 

please help me..

or guide..

 

 

 

 

Attached Files



#2 haraldov OFFLINE  

haraldov

    Advanced Member

  • Members
  • 122 posts
  • Local time: 12:53 PM

Posted 23 December 2017 - 06:22 AM

Maybe to late answer, but antennas works great for me without docker implementation.

I followed the notes the developer made here: https://github.com/TheJF/antennas

Ubuntu 16.04 x64 with Emby server 3.2.60.0 .net

# Create a directory to store antennas, i.e. mkdir antennas
$ mkdir -p /home/hts/antennas/

# Install crystal Link: https://crystal-lang.org/docs/installation/on_debian_and_ubuntu.html
$ sudo curl https://dist.crystal-lang.org/apt/setup.sh | sudo bash

# Download a Linux release of antennas inside Antennas directory
$ cd antennas/
$ git clone https://github.com/TheJF/antennas.git
$ cd antennas/
# Install Crystal dependency
hts@vdrsrv:~/antennas$ shards install
hts@vdrsrv:~/antennas$ shards update
# Compile antennas.cr 
hts@vdrsrv:~/antennas$ crystal build ./src/antennas.cr

# Configure your antennas server. Edit config.yml
$ nano config/config.yml
# Edit the correct ipadresse for your tvheadend server and antennas url. 
# I have emby server, tvheadend server and antennas on the same server. 
# Check if the url: http://admin:admin@192.168.9.2:9981 to tvheadend works with the tvheadend admin user and password admin. 
# If not make a user with admin rights in tvheadend web interface
tvheadend_url: http://admin:admin@192.168.9.2:9981
antennas_url: http://192.168.9.2:5004
tvheadend_weight: 300 # subscription priority
tuner_count: 4 # numbers of tuners in tvheadend

# Run ./antennas as the tvheadend user
hts@vdrsrv:~/antennas$ ./antennas

# Check antennas is working
http://192.168.9.2:5004/

# In Emby server setup the antennas server 
Emby server --> Live TV Tuner Setup --> Tuner Ip adresse: http://192.168.9.2:5004
# Check with Emby theater if the channels works

Edited by haraldov, 23 December 2017 - 06:39 AM.


#3 haraldov OFFLINE  

haraldov

    Advanced Member

  • Members
  • 122 posts
  • Local time: 12:53 PM

Posted 23 December 2017 - 12:47 PM

If you want antennas to start as a systemd service via hts user and start on boot you can do it like this:

# Make antennas systemd service file in /lib/systemd/system
hts@vdrsrv:/$ cd /lib/systemd/system
hts@vdrsrv:/lib/systemd/system$ sudo nano antennas.service

# Paste this content in the antennas.service and save the file

[Unit]
Description=HDHomeRun emulator for Plex DVR to connect to Tvheadend
After=network.target

[Service]
WorkingDirectory=/home/hts/antennas/
ExecStart=/home/hts/antennas/antennas
Restart=always
User=hts

[Install]
WantedBy=multi-user.target

# Test the antennas service 
hts@vdrsrv:/lib/systemd/system$ sudo systemctl start antennas.service

# Access antennas url with your choosen webbrowser
http://192.168.9.2:5004/

# If ok then enable the service at boot
hts@vdrsrv:/lib/systemd/system$ sudo systemctl enable antennas.service

Edited by haraldov, 23 December 2017 - 12:47 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139743 posts
  • Local time: 05:53 AM

Posted 23 December 2017 - 12:58 PM

Can you describe your channel mapping problem in more detail? Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users