Jump to content

MediaPortal 2 Emby Support


Go to solution Solved by pünktchen,

Recommended Posts

I have just installed MediaPortal 2 on my Emby Server and it runs very well, but does not work through Emby. Is MP2 supported yet or is it just MP1?

Link to post
Share on other sites
  • Solution
pünktchen

May i ask what you are trying to do?

 

If you just want to use the tv part of MediaPortal in either Emby or Kodi, then go with the standalone TVServer of MediaPortal 1. The tv engine of MediaPortal 2 is the same, so no benefits there.

If you also want to use the MediaPortal frontend and video libraries, then i don't know how Emby comes into the game. There's no connection between the two systems other than using Trakt.tv. But again this is only possible with MediaPortal 1 right now.

If for whatever reason you really want to use MediaPortal 2 as your main mediacenter and Emby just for mobile and remote watching/management of live tv, then you'll have to wait until the prerequisites are coded into MediaPortal 2. Maybe we get this by the end of the year. But then MediaPortal 2 will have its own webinterface, so need for Emby by this time.

  • Like 2
Link to post
Share on other sites

May i ask what you are trying to do?

 

If you just want to use the tv part of MediaPortal in either Emby or Kodi, then go with the standalone TVServer of MediaPortal 1. The tv engine of MediaPortal 2 is the same, so no benefits there.

If you also want to use the MediaPortal frontend and video libraries, then i don't know how Emby comes into the game. There's no connection between the two systems other than using Trakt.tv. But again this is only possible with MediaPortal 1 right now.

If for whatever reason you really want to use MediaPortal 2 as your main mediacenter and Emby just for mobile and remote watching/management of live tv, then you'll have to wait until the prerequisites are coded into MediaPortal 2. Maybe we get this by the end of the year. But then MediaPortal 2 will have its own webinterface, so need for Emby by this time.

Thank you for that clarification. Yes I am only interested in the TV aspect of MediaPortal as EMBY covers the rest very well and I want Emby Theater to remain the front end for access in the lounge. It's my first look at MediaPortal and I was very impressed with the speed of channel switching and the better quality playback compared to NextPVR. I did a full image backup of my EMBY PC before installing MediaPortal2 as this was an experiment. I will restore that image and try MediaPortal 1. I am encouraged by your comment that the engine is the same.

 

I assume then that once MP1 is installed, configured and running smoothly, then the EMBY plugin is all that is required? No special tweaking or additional components?

Link to post
Share on other sites
  • 7 months later...
  • 3 months later...

I got this working today.

I had to migrate to MP2 to sort out some issues I had with the TVServer/Kodi plugin. The old version for MP1 doesn't seem to work properly with newer versions of Kodi on RPi.

 

The old version of MPExtended has been updated as MP2Extended: https://forum.team-mediaportal.com/threads/plugin-mp2extended.132322/

I used the Beta 9 version. I added in the updated streaming profiles and the 64bit version of ffmpeg (even though I use direct stream).

 

 

Previously with the Emby Mediaportal plugin (for MP1) I could only get it to work properly if authentication was turned off.

This version of MP2Extended doesn't work properly when you turn off authentication. It pops up wanting a username and password. You can put in any username and no password it still works.

 

So, I configured MP2Exteneded for 'no authentication' and I deleted all the user accounts out of MP2extended.

I then configured the Emby MediaPortal plugin to use authentication but I put in a dummy username and no password. Streaming Profile is set to 'Direct'

 

Works great! Guide, LiveTV and Recordings.

FYI, MediaPortal is on a Windows 10 box and Emby is on an Ubuntu box.

 

Hope you folks can get it working too.

 

Nick.

Link to post
Share on other sites
  • 1 month later...
arrbee99

So with MediaPortal I can just install the TV Server - that means I don't have to install MediaPortal 1 or MediaPortal 2 ?

 

I need to install the item mentioned on Post#6 as well ?

 

I need to install the MediaPortal plugin into Emby as well as that mentioned above ?

Link to post
Share on other sites
pünktchen

So with MediaPortal I can just install the TV Server - that means I don't have to install MediaPortal 1 or MediaPortal 2 ?

 

I need to install the item mentioned on Post#6 as well ?

 

I need to install the MediaPortal plugin into Emby as well as that mentioned above ?

Yes to all of your questions.
Link to post
Share on other sites
arrbee99

Thanks. You wouldn't know where I can find this TV Server, if thats its actual name. Can't see anything called TV Server at MediaPortal to download.

Link to post
Share on other sites
pünktchen

Thanks. You wouldn't know where I can find this TV Server, if thats its actual name. Can't see anything called TV Server at MediaPortal to download.

There's only one installer package. It will ask you what you want to install. Full installation, client only or server only.

Just a big warning, because i know some of your NextPVR issues from the forum here: You will not get any program guide images! This is not a limitation of the plugin but of the TVServer.

Link to post
Share on other sites
arrbee99

There's only one installer package. It will ask you what you want to install. Full installation, client only or server only.

Just a big warning, because i know some of your NextPVR issues from the forum here: You will not get any program guide images! This is not a limitation of the plugin but of the TVServer.

 

Thanks. Hopefully I'll have a go tomorrow.

 

I remembered about the guide images, just though I'd have a go to see if it would a) actually start playing TV quicker and B) direct play at all.

 

BTW I added MrMC to my Fire TV and added the NextPVR plugin/service/whatever its called to that and it starts playing in only 5 seconds which is way quicker and about the same as using the NextPVR app on the main PC, just not sure if its direct playing or transcoding.

Link to post
Share on other sites
arrbee99

What does 'There was a problem authenticating with the MP service' under 'Refresh MediaPortal Timers Failed' in Emby mean ?

 

I think I installed the TV Server and MP Extended and the plugin OK. Not sure how they actually talk to each other though.

 

In the TV Server Configuration thing The Preview seems to play channels OK.

 

Thanks

 

Edit - and MP Extended seem to crash frequently and need repairing.

Edited by arrbee99
Link to post
Share on other sites
pünktchen

The error indicates that no connection to MPExtended could be established. Either firewall port 4322 is blocked or authentification in MPExtended is enabled but you don't have set the right credentials in the plugin.

Have you installed the TVServer with the MediaPortal 1 or 2 installer?

Where you able to choose a channel group inside the plugin settings?

 

Btw. MPExtended hasn't crashed for me since over a year...

Edited by pünktchen
Link to post
Share on other sites
arrbee99

In Norton Firewall thingy I have this, which I presume is correct...

 

5b0333bb58ab3_EmbyMediaPortalMPExtendedN

 

In MPExtended I have this...

 

5b0334832b131_EmbyMediaPortalMPExtendedC

 

In the plugin I have this...

 

5b0335196aab4_EmbyMediaPortalMPExtendedP

 

I installed TVServer with MP1 installer.

Couldn't choose a channel group, the drop down is empty.

 

TVServer is version 1.19.

MPExtended is version 0.6.0.4-Emby.

 

I do have other things installed  - NextPVR app and plugin and Hauppauge WinTV for the Emby native Emby Hauppauge tuner feature - hopefully they don't interfere. Have been using NextPVR and built in Emby Hauppauge feature together and they didn't seem to interfere with each other before I added Media Portal.

Am using a dvb-s pci-e tuner.

Link to post
Share on other sites
pünktchen

I'm talking about this one in MPExtended's configuation tool:

5b03394883cf2_mpextended.png

 

Just disable the authentication and restart the service!

Link to post
Share on other sites
arrbee99

Its like that already. Think that's the default ?

 

...I'll try the restarting bit though...

Link to post
Share on other sites
arrbee99

Get this now...

 

5b033ddc14213_EmbyMediaPortalMPExtendedV

 

Stopped service. Restarted service. Gave that message. Then restarted Emby server and tried 'Refresh MediaPortal Timers' a few times and got that message a few (more) times.

Link to post
Share on other sites
pünktchen

For connection testing as a simple test you can click on the TVServer link inside the Troubleshooting tab of MPExtended.

It should open a browser window with something like this:

// 20180521234457
// http://192.168.0.2:4322/MPExtended/TVAccessService/json/GetServiceDescription

{
  "ApiVersion": 6,
  "HasConnectionToTVServer": true,
  "ServiceVersion": "0.6.0.4-Emby"
}
Link to post
Share on other sites
pünktchen

Get this now...

 

5b033ddc14213_EmbyMediaPortalMPExtendedV

 

Stopped service. Restarted service. Gave that message. Then restarted Emby server and tried 'Refresh MediaPortal Timers' a few times and got that message a few (more) times.

Are you using the beta server of Emby?

But one after the other. Can you choose a channel group now inside the plugin?

Link to post
Share on other sites
pünktchen

@@Luke you'd better have to communicate if there a changes in Emby beta server that lead to broken live tv plugins:

List<string> Genres to string[] Genres???

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...