Jump to content

Recommended Posts

I've built the latest ApiClient version from source and released E2PL v1.1.2.0-beta which is now using this client instead of the NuGet package.

https://github.com/red217/EmbyExternalPlayerLauncher/releases/tag/v1.1.2.0-beta

 

I haven't made any other changes and haven't had time to set up a VM with the latest version of the server, so I'm not sure if this actually fixes anything or not. It does seem to work with the old server version that I'm using for my own media. Anyone having the authentication issues could give this a try and with a bit of luck it'll work, assuming the new library uses the new authentication method in the background when talking to the server. If not, I'll get an install of the latest server going and look into it in more depth when I've next got a bit of time.

Thank you for your great work, I got it working.

Edited by angryblue
Link to post
Share on other sites
  • 8 months later...
vivificus

Does Emby External Player Launcher only work with from web interface or is there some way to use it as the external player for Emby Theatre on Windows? If so how?

Link to post
Share on other sites
Luke

Emby theater for windows has it's own external player feature built in so I would just use that.

Link to post
Share on other sites
Bloodred

E2PL just connects to the server, it doesn't interact with other clients (or the web interface) directly. I don't use Emby Theater so I can't say for sure, but as long as it allows you to select a player like the web interface does then it should work. If that option isn't available in Emby Theater, then probably doing as Luke suggested would be the quickest solution.

Link to post
Share on other sites
vivificus

Thanks for the info, I'll try using a 'normal' external player. I was hoping to get the playback position syncing that E2PL offers. I tried it as the external player but it just launches another copy of your program each time you play something there doesn't seem to be a 'cast' option like with the web version.

Link to post
Share on other sites
  • 4 weeks later...

Hi,

I used the E2PL to play the movies directly from my Emby Server but it does not work. The E2PL connects to the Emby Server OK but when I play the movies, it's still using the default web video player.

Did I do anything wrong?

 

Thanks.

 

Vu

 

Link to post
Share on other sites
  • 2 weeks later...
Guest AllRoCol
On 9/21/2020 at 6:44 PM, VuH said:

I used the E2PL to play the movies directly from my Emby Server but it does not work. The E2PL connects to the Emby Server OK but when I play the movies, it's still using the default web video player.

Did I do anything wrong?

 

The first two things that come to mind are that you didn't enable the web server in your video player (Off by default) and you didn't choose the casting option on the main page of your Emby Server (Top right, button on the left of the four buttons).

Link to post
Share on other sites
Buku.lawas

I've been using this E2PL, and it was great. Solvied some issues related to lagging video playback with web player (Chrome browser).
One thing still can't figure how to solve is : Play next episodes automatically. This option already been turned on in EMBY server settings, and it works with internal web browser/player.
But with same  settings, the E2PL can't seem to play next episodes automatically (playing TV Series).

Link to post
Share on other sites
Bloodred

Unfortunately that's not a feature that E2PL has, I only ever really intended to have it play the episode/movie you click on. Sorry to say but I'm also not really planning on adding that at this point.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...