Jump to content

Subtitle suddenly appearing for one movie


nortok00
 Share

Go to solution Solved by ebr,

Recommended Posts

nortok00

Hi folks,

 

Apologies if this has been asked/answered but I couldn't find anything that matched my issue.

 

I've been running Emby on Windows 10 (using Chrome browser to display my library) with download subtitles disabled for months without any issue. I don't have any local srt files (or any other subtitle files), all files are English audio and there are no embedded subtitles. Suddenly this week one of my movies started displaying English subtitles. I thought maybe somehow my server settings had been changed but nothing seems out of place. I don't know if this is associated with any Emby update.

 

After checking that no server settings were changed I checked the file settings by clicking on the three dots and going to "Edit Subtitles" and suddenly this movie has an extra field that has the title "My Subtitles" then below it "Eng Default". It looks like "Eng Default" is clickable (I thought maybe I could turn it off or delete it) but nothing happens. I randomly checked my other files and this extra field isn't there (and they don't display subtitles) so it's not like it's happening to my entire library.

 

Where is this coming from and why is this suddenly showing for this movie? More importantly how do I get rid of this. To try and get rid of this I moved the movie out of my library folder, restarted the server and re-scanned the library to ensure it was gone then re-added it but that didn't do anything. I have attached a screenshot of what I'm seeing at the file level and my server settings for subtitles (which I have never touched). To the best of my knowledge it's only this movie that's suddenly doing this but haven't checked every file.

post-177961-0-56713000-1488123310_thumb.png

post-177961-0-31228200-1488123804_thumb.jpg

Link to comment
Share on other sites

You can't delete it because those subtitles are embedded inside the video. What you can do is just turn them off once video starts playing. You can also configure your Emby user preferences to never play subtitles by default.

Link to comment
Share on other sites

nortok00

OMG. I am so lame. I usually test my movies in VLC first (for things like subtitles, etc and didn't see any subtitles in this movie but just realized I had subs disabled in VLC (now enabled). Duh!!

 

OK so... what I don't understand is that I've been playing this movie for months in Emby and the subtitles haven't played so I don't know what has changed or what I might've accidentally clicked on to enable this and I don't see a way to turn it off at the movie level or as a general setting so can you tell me:

 

1. Where do I disable at the movie level. As mentioned I don't see anything under "Settings > Edit Subtitles" nor in the details of the movie (where you can read the description, play the movie, etc.).

2. Disable subtitles globally. I've been in the server settings under Subtitles and Playback but don't see anything. The only other post I could find for this (that had an answer) was from 2014 and it says it can't be done in the interface but is done with the codec/splitter.

 

Thanks again!

Link to comment
Share on other sites

  • Solution

During playback there is an icon with a "CC" in it.  Click it.

 

For defaults, one of the options for subtitle handling is "No Subtitles".  Sounds like that's what you want.  User icon->Playback->Subtitle Mode

  • Like 1
Link to comment
Share on other sites

Yea just turn them off during playback and you'll be fine. Let us know if this helps.

Link to comment
Share on other sites

  • 2 weeks later...
nortok00

I found the cc button as per ebr and Luke's suggestions. This worked. I probably stared at that panel for 30 minutes before I posted and didn't even see it. I kept looking for something that said "subtitles". Thanks again for the speedy replies.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...