Jump to content
Marc_G

Line at bottom of Emby Theater screen during playback (Taskbar Autohide)

Recommended Posts

Marc_G

Hi folks,

 

Just installed Emby Theater on my Win7 PC, working towards a migration from Emby for WMC.

 

During playback I often get a line at the bottom of the screen. See this pic:

post-489-0-10080400-1480798231_thumb.jpg

 

If I minimize and re-maximize the screen the line goes away. But, after browsing some more and starting playback it often comes back.

 

The TV is just a standard Panasonic 1080p TV (60ST60 plasma), and I don't do anything funky with resolutions, scaling, or anything else. My desktop and playback are all 1080p.

 

The line appears to be the taskbar "autohide" residual line (my taskbar is set to autohide). The two brighter sections of the line are where there are two apps open, with icons in the taskbar.

 

I may go in and un-auto-hide the taskbar for a while, but I really prefer for it to hide when not in use.

 

This seems to be a bug that ET doesn't always cover over the hidden taskbar, or perhaps I've configured something incorrectly? Or maybe certain events cause ET to lose focus, making the taskbar come back in front?

 

Please advise! :-) 

 

Marc

Edited by Marc_G
  • Like 1

Share this post


Link to post
Share on other sites
MEB

I actually like this "feature" since it allows me to have my blue iris cameras show up while watching videos but covers up the cameras when browsing the menus. But yea the different layers of ET is sometimes a PITA.

Share this post


Link to post
Share on other sites
Marc_G

I've set up a new windows 10 dedicated box, and notice that "sometimes" the taskbar shows up on top of Emby Theater and I can't make it go away in any reproducible way. On this box I haven't set the taskbar to minimize. Eventually doing a minimize/maximize with the upper right corner controls eventually sorts it out, but not always. I'm pretty sure this is the same issue/feature I reported last week in this thread, just slightly different result because the taskbar is full screen on this box.

 

I'll keep paying attention and report back when I have more information.

Share this post


Link to post
Share on other sites
greenwoc

I've also had this issue on Windows 7 prior to a rebuild. I also saw it with other programs than Emby. It started off with the taskbar just sitting on top of some fullscreened apps. Since it affected other apps I assumed it was not an Emby issue. Since a re-install and upgrade to Windows 10 the issue has totally gone away. The only oddity I have now is that if I have to full screen emby (due to the HTPC coming on with the TV) I have to click maximise once to make Emby cover the while screen except for the taskbar, then once more to cover the taskbar as well. Not an issue just behavior I haven't seen before in a Windows app.

Share this post


Link to post
Share on other sites
Luke

Thanks for the info

Share this post


Link to post
Share on other sites
Sammy

I experience this too. It seems ET doesn't retain focus. I run WMC on the same machine and this mostly doesn't happen with it but I have seen it randomly but not like ET which is basically all the time almost. While I'm typing this, it came to mind that maybe this is an issue with how ET handles AeroPeek. Should we just disable it? I do think that ET is having issues with retaining focus. What to post to assist in troubleshooting this?

Edited by Sammy

Share this post


Link to post
Share on other sites
Luke

You can't disable Aero, no.

Share this post


Link to post
Share on other sites
Sammy

I am still experiencing this issue. Here's a couple or pics taken with my cell because screen capture is a not possible when ET is in full screen (by me anyhow, any way to do it?) I don't have this problem with mpc-hc, BTW. I want to use the built in player because it is a very nice interface and it is more fluid so I'm hoping it can be fixed.

 

TIA

 

post-110-0-87596200-1485438143_thumb.jpg

 

post-110-0-78195900-1485438149_thumb.jpg

Edited by Sammy

Share this post


Link to post
Share on other sites
Luke

do you have the windows auto hide taskbar setting turned on?

Share this post


Link to post
Share on other sites
Sammy

do you have the windows auto hide taskbar setting turned on?

Yes. I figured turning auto hide was best to make the task bar hide itself but maybe that is what is causing the issue here. This is on my HTPC and I'm not seeing it on the NUC.

Share this post


Link to post
Share on other sites
Luke

yea try turning that off.

Share this post


Link to post
Share on other sites
Sammy

Yeah. I will tonight and report back. Hopefully this cures an issue with a command window that pops up and takes focus every night at 9:00 reporting that rc.exe did not run correctly due to improper parameters with a list of acceptable parameters. This doesn't cover the WMC screen or mpc-hc full screen exclusive in any way so it isn't a problem there, just on ET. That's a whole other issue I need to resolve. I need to find what is triggering it and fix that too but if it doesn't show up on screen during playback I really don't need to worry so much about it.

Share this post


Link to post
Share on other sites
Sammy

Yeah. I will tonight and report back. Hopefully this cures an issue with a command window that pops up and takes focus every night at 9:00 reporting that rc.exe did not run correctly due to improper parameters with a list of acceptable parameters. This doesn't cover the WMC screen or mpc-hc full screen exclusive in any way so it isn't a problem there, just on ET. That's a whole other issue I need to resolve. I need to find what is triggering it and fix that too but if it doesn't show up on screen during playback I really don't need to worry so much about it.

It would seem that this resolved the issue with the task bar peeking at the bottom of the screen but I've been away this whole last weekend and haven't had much viewing time with it to see if it doesn't come back. I still have this nagging Command Window come up, usually on the hour, that says that the switches of sc.exe haven't been properly set with a list of proper switches. This is on my HTPC and not on the NUC. I can't seem to find out what is triggering this. I've looked through the task scheduler and the event logs for things at the top of the hour and can't find it. This command window takes focus away from ET and lies on top of the video player until I grab a keyboard and hit ALT Tab to bring ET back in focus. Is there a setting someplace to give ET (Electron?) higher priority to stay on top?

 

TIA

Share this post


Link to post
Share on other sites
Luke

When full screen we already use the electron api to have the window be always on top.

Share this post


Link to post
Share on other sites
Sammy

Okay. I'm guessing that whatever is triggering this PITA pop up has a higher priority or something like that??

 

Or do I need to tweak a setting in ET to force it to be exclusive full screen just like mpc-hc?

Share this post


Link to post
Share on other sites
Sammy

So I was not having any problems with the task peaking through until I had this guy show up, which occurs at the top of the hour:

 

post-110-0-07061600-1485894219_thumb.jpg

 

post-110-0-10685300-1485894280_thumb.jpg

 

It is as if it is an overlay. If I try to hit the Red X Close button the video pauses, responding to a mouse click creating a pause. If I hit Alt + Tab I can make it hidden under the video player. After minimizing the video player, I can scroll up to the top to show what the first line of the Command Window says which is this:

 

post-110-0-87572200-1485894348_thumb.jpg

 

 

After that, I can click the Red X to close it but when I return to ET to view, the entire task bar is showing until I log out then log back into ET. Also, the overlay scaling is all wrong until I log out and back in:

 

post-110-0-40706000-1485894409_thumb.jpg

 

post-110-0-10305600-1485894463_thumb.jpg

 

post-110-0-07172200-1485894595_thumb.jpg

 

While I realize that I need to fix the underlying problem I'm perplexed as to find what is triggering it but ET does not stay on top completely and correctly like mpc-hc does. This pop up can occur and never interrupts playback on mpc-hc.

 

post-110-0-41070500-1485894515_thumb.jpg

Edited by Sammy

Share this post


Link to post
Share on other sites
Sammy

If there's anything in the log, this playback started around 4:56am today, this pop up occurred at or on the top of the hour (5:00am) and playback was stopped due to the scaling issues in the pictures above somewhere around 5:05am.

 

Log.txt

 

 

Share this post


Link to post
Share on other sites
Sammy

Any feedback on the above? Last night I had to pause it covering the time period at the top of the hour (9pm) and this pop up didn't rear it's ugly head. I'll keep testing but there's got to be a way to ensure that ET / Electron stays focused on completely on top.

 

TIA

Share this post


Link to post
Share on other sites
Marc_G

Lately I haven't been seeing the taskbar popping to the foreground as much on my system. My current Emby Theater system is a lot beefier than the one I was using when I started this thread. Not sure if that has anything to do with it or if it relates to improvements in ET. I don't currently autohide the taskbar but I had previously seen the whole unhidden bar pop forward frequently. Maybe I just got better at not triggering the problem. I also have an HDMI detective on the line so Windows isn't reacting to hotplug events which might have been a trigger.

Share this post


Link to post
Share on other sites
Luke

Well done. Thanks for reporting back.

Share this post


Link to post
Share on other sites
Sammy

Any feedback on the above? Last night I had to pause it covering the time period at the top of the hour (9pm) and this pop up didn't rear it's ugly head. I'll keep testing but there's got to be a way to ensure that ET / Electron stays focused on completely on top.

 

TIA

 

Still trying to figure this one out but haven't seen the task bar and scaling issues again but I haven't minimized ET to close that pesky pop up either..

Share this post


Link to post
Share on other sites
Swynol

i get the taskbar issue. i think its to do with the hot plug and play feature of HDMI. i only get the taksbar show up when my TV has been off but my htpc stays on. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...