Jump to content

CoverArt 4.0 problems


ShoutingMan
 Share

Recommended Posts

CoverArt 4.0 isn't working with Emby Server Version 3.0.8500.0 and Emby app.

 

It partially works, converting some of the library, but leaving many images, including all collections, without coverart. It also slows down navigation, sometimes completely preventing accessing libraries. Uninstalling the plug-in fixes the problem. I reinstalled the plug-in and let it run all night, about 16 hours now, and it hasn't improved behavior or finished fully populating the library artwork. I have the plug-in at default configuration; perhaps it needs needs days to process a full library of music and movies?

 

This is on a (6th gen) Core i5 Windows PC with 8GB RAM. The OS and Emby applications are isntalled on a 500GB SSD and the library is on conventional spinny drives run in RAID with DrivePool and SnapRaid.

 

5842ff3a3b308_CoverArtProblems1.png

5842ff571f834_CoverArtProblems2.png5842ff66627f1_CoverArtProblems3.png

Edited by ShoutingMan
Link to comment
Share on other sites

Do you see the same behavior in the web client?

 

Yes.

In fact, it's much worse in the web client. Clicking on a library tab, it just spins and doesn't show anything.

Link to comment
Share on other sites

Cover art processes images on the fly and it will have some CPU impact. There appear to be no problems in your log so it looks like it's just taking a little time. The pain is only temporarily because as the apps build up their caches the images will come from there.

Link to comment
Share on other sites

How does it typically take? Or is there a way I can have it only work on a section of the media library (like, just blu-rays but not DVD or music)? The server plug-in has been enabled for about 18 hours and it's no better than when it started. The app hasn't been running the whole time. Neither one seems to be getting anywhere.

 

I've not used server plug-ins before, but it seems odd to take 24+ hours to run, while at the same time there's no CPU load on my computer from the process. Emby has been at 0% everytime I check it.

Link to comment
Share on other sites

Everything is on the fly so you need to use your Emby apps for the images to be generated and saved for re-use. Yes, you can configure per folder in cover art settings.

Link to comment
Share on other sites

That's not happening. I run Emby (app or library). Navigate. Try to look at my library. Look at a movie in the library. There are no images generated. Leave the window open for a minute or two. Nothing. The images don't appear.

Link to comment
Share on other sites

CoverArt 4 was definitely not working while I was adding new content. I had previously uninstalled / reinstalled it twice.

 

Having finished adding new media, I again uninstalled / reinstalled CoverArt and it's working correctly.

 

With this visual distinction, I'm considering going to a single Movie library. Instead of having three separate libraries for Blu-ray, DVD, and MKV, so I know what's what, CoverArt should let me go to a single merged library and can distinguish easily what the format is from the cover artwork. If this works as I hope, it will be a nice simplification of Emby and nice feature benefit.

 

 

On the symptoms of what was happening with CoverArt:

I was adding new movies the past two days while the plug-in was installed.

During the first run, it wasn't behaving properly. I tried creating a Collection that I found was empty of any meta-data or content. In case it was corrupted by the plug-in problems, I deleted the Collection and re-created it.

 

And having finished adding the new batch of movies, I reinstalled CoverArt.

 

It's working now normally. As I scrolled through my library, the cover art populated on the fly. I went through all media in Emby app and generated all the artwork. I did a spot check in the web server interface and that also was working correctly with the new cover art.

Link to comment
Share on other sites

  • 2 weeks later...

A little update: I eliminated my separate DVD and blu-ray libraries, merging them into one movies library. I can distinguish what's what visually with the Cover Art plug-in. Simplified my Emby setup. Good feature :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...