Jump to content
Lilan

Moving Items in Playlist Broken

Recommended Posts

Lilan
Recently, maybe in the last couple months I noticed that when items are moved in a playlist, they are to the wrong location. 

 

What I mean is say I have the following playlists with 5 items: 



+------+
|  1   |
+------+
|  2   |
+------+
|  3   |
+------+
|  4   |
+------+
|  5   |
+------+


 

 

If I try to move this item up to the third spot, after refreshing the page even though it's moved into the third spot, it will end up in the fourth spot. 

 



+------+   +------+          +------+
|      |   |      |          |      |
+------+   +------+          +------+
|      |   |      |          |      |
+------+   +------+          +------+
|      | ^ |  3   |          |      |
+------+ | +------+  Refresh +------+
|      | | |      |          |  4   |
+------+ | +------+          +------+
|  5   | + |      |          |      |
+------+   +------+          +------+


 

This happens every time and it's really irritating when editing playlists as items have to be moved into the spot one above where you want them. When you want to put an item in the first spot it makes things even more difficult.

Share this post


Link to post
Share on other sites
Luke

Hi, thanks for taking the time to create that diagram. What version of Emby Server are  you running?

Share this post


Link to post
Share on other sites
Lilan

Version 3.0.8500.0 on FreeBSD 10.3

Share this post


Link to post
Share on other sites
Luke

Hi, thanks for the report. I've put in a fix for the next release of Emby Server.

Share this post


Link to post
Share on other sites
Lilan

Hi, thanks for the report. I've put in a fix for the next release of Emby Server.

Thanks! :)

Share this post


Link to post
Share on other sites
Lilan

Hi, thanks for the report. I've put in a fix for the next release of Emby Server.

 

For some reason this problem seems to be back, but instead of the video ending up down one spot, the video ends up up one spot in the playlist from where it should be.

 

The server's on FreeBSD 11.1-RELEASE, and i'm on Emby 3.2.60.0.

Share this post


Link to post
Share on other sites
Luke

Can you give an example? thanks.

Share this post


Link to post
Share on other sites
Lilan

So let's say there are five videos.

 +------+
 |  1   |
 +------+
 |  2   |
 +------+
 |  3   |
 +------+
 |  4   |
 +------+
 |  5   |
 +------+
 

You want to move the fifth video to the third spot. After moving the video you refresh the page, and instead of the video being in the third spot it's in the second spot. This happens consistently.

 

 +------+       +------+         +------+
 |      |       |      |         |      |
 +------+       +------+         +------+
 |      |       |      |         |  5   |
 +------+       +------+         +------+
 |      |   ^   |  5   | refresh |      |
 +------+   |   +------+         +------+
 |      |   |   |      |         |      |
 +------+   |   +------+         +------+
 |  5   |   +   |      |         |      |
 +------+       +------+         +------+

It's basically the exact same problem as before but instead of the video popping down a spot, and ends up up a spot.

Share this post


Link to post
Share on other sites
Luke

Thanks for the info. It will be resolved for the next release.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...