Jump to content

Emby Theater 2.5.25 bugs


julianb
 Share

Go to solution Solved by julianb,

Recommended Posts

julianb
Hi, was using Emby Theater last night and it worked just fine. 

 

Today it updated to  v.2.5.25 and it broke several things.

 

- Backspace no longer take you back. This is pretty critical for me, as the remote emulates the backspace. 

- Settings have lost alot of options. I can no longer change between EVR, EVR+ or madVR. 

 

I reinstalled the whole thing, and now I can't get it to use madVR because I wiped it settings, and I can't find that option anymore. 

 

Is there a way to install the older version until this is fixed? 

Edited by julianb
Link to comment
Share on other sites

Latchmor

 

Hi, was using Emby Theater last night and it worked just fine. 
 
Today it updated to  v.2.5.25 and it broke several things.
 
- Backspace no longer take you back. This is pretty critical for me, as the remote emulates the backspace. 
- Settings have lost alot of options. I can no longer change between EVR, EVR+ or madVR. 
 
I reinstalled the whole thing, and now I can't get it to use madVR because I wiped it settings, and I can't find that option anymore. 
 
Is there a way to install the older version until this is fixed? 

 

 

Hi, I just updated to 2.5.25 also and see none of what you are saying, which is strange...

 

You could try downloading ET from website and re-installing maybe?

Link to comment
Share on other sites

julianb

Hi, I just updated to 2.5.25 also and see none of what you are saying, which is strange...

 

You could try downloading ET from website and re-installing maybe?

Weird, yesterday it worked perfectly. But today, after the update i can no longer use the backspace on my keyboard or remote to go back, I have to push ESC instead. 
 
Also, Video settings and External player settings are gone.. Just redownloaded it from the website, after a complete uninstall. Did not work. 
 
Will try to backup my Emby.Theater folder from Appdata folder on my second machine (2.5.23)
Edited by julianb
Link to comment
Share on other sites

Latchmor

Yeah, sorry I see you tried to re-install originally.

 

You can see releases here: https://github.com/MediaBrowser/Emby.Theater.Windows/releases

 

These will let you extract to a folder and run it directly from that folder. Will get you going until you can sort out your main install I guess but they too will try to update when you close and re-open.

Link to comment
Share on other sites

  • Solution
julianb
Well, I don't know what was causing the problem, but a lot of the files in the appdata was missing. 

 

Tried to download the install again, but it did not help.

 

the solution for me was to copy my Emby Theater folder from another computer. That fixed the problem. 

 

Now 2.5.25 works great on my HTPC. Thanks. 

  • Like 1
Link to comment
Share on other sites

 

Well, I don't know what was causing the problem, but a lot of the files in the appdata was missing. 
 
Tried to download the install again, but it did not help.
 
the solution for me was to copy my Emby Theater folder from another computer. That fixed the problem. 
 
Now 2.5.25 works great on my HTPC. Thanks. 

 

 

Sounds like an anti-virus program messing with the install.

Link to comment
Share on other sites

puithove

FWIW (not really related to the issue you apparently had) - I switched from using BACKSPACE to using ESC as my "Back" key... because if you go into any of the text input fields, backspace then works (of course) as backspace instead of "back".  ESC works as "Back" in all cases.

Edited by puithove
Link to comment
Share on other sites

Della Dog

Sounds like an anti-virus program messing with the install.

Not really, update often clears out the madVr files - don't know why. Manually copying them to the com folder and executing mad install bat file fixes.

Link to comment
Share on other sites

stettler

Same problem with the exit or back button of the remote: It bring the setting menu. So it's totaly impossible to navigate with a remote anymore.

Link to comment
Share on other sites

Same problem with the exit or back button of the remote: It bring the setting menu. So it's totaly impossible to navigate with a remote anymore.

 

On the home screen it has always been this way. That is the exit menu of the application.

Link to comment
Share on other sites

stettler

On the home screen it has always been this way. That is the exit menu of the application.

 

It wasn't in the home screen... It was in the list of movies or the list of episodes of a TV serie.

 

When using the back or exit button, it was getting into the menu screen with "settings", "Select server", "sign out",... buttons. But there wasn't a "Home" button like if you go into that screen by clicking on the profile icon.

 

Funny thing is that it "fixed itself" after I went into the settings menu via the profile icon (the one near the clock, at the top/right if the screen).

 

Weirdness...

Link to comment
Share on other sites

I have never seen that before. I suppose it's possible your remote sent multiple back commands in a very short period of time. i'll have to see if we have any safeguards against that.

Link to comment
Share on other sites

stettler
Luke, on 16 Oct 2016 - 8:04 PM, said:Luke, on 16 Oct 2016 - 8:04 PM, said:

I have never seen that before. I suppose it's possible your remote sent multiple back commands in a very short period of time. i'll have to see if we have any safeguards against that.

 

I doubt it was caused by the remote: I closed and restarted ET. I even rebooted the computer and each time the result was the same. Then I navigated to the menu screen, went into setting and tried to use again the back button (as there is no other way to go out of the "video setting" for example) and it worked. Then it worked again everywhere as expected.

 

It never happened before and it didn't happened again since it started working again. Seems it only "glitched" after the update.

 

Oh, and it can't be multiple back sent by the remote because I was getting this, for example:

 

Navigate to TV Serie, enter a serie, enter a season to get the list of episodes. Then:

Back button -> display the menu screen (without the big "home" button on the left)

Back button -> go back to the list of episodes

Back button -> display the menu screen

Back button -> go back to the list of episodes

...

 

It never allowed to go "up" one or more levels. So it was not possible to go to the home screen that way.

Edited by stettler
Link to comment
Share on other sites

julianb

Sounds like an anti-virus program messing with the install.

Hmm, the HTPC has just been freshly reinstalled with windows 10 (3 weeks ago) no anti-virus installed, only the build-in "windows defender". Could be it, but I did not receive any warnings during download/install.. Anyway, got it working by copying the missing files from another computer. 
 
Now I got another problem: 
In windows power settings, I have chosen the plan "high performence" with the option to turn of the screen if inactive for 15 minutes. Now, every 15 minutes during a playback, the movie start lagging like crazy, until I move the cursor again. The easiest solution is of course to disable the "turn of the screen" feature, but I don't like it to show a static screen for long hours when i'm not there.
 
Why does this happen? It's like windows does not detect that i'm playing a movie?
Link to comment
Share on other sites

I'm not sure. I have not seen that happen. my test system for Emby Theater also uses the 15 minute screen inactive and i haven't seen any problems.

Link to comment
Share on other sites

julianb

I'm not sure. I have not seen that happen. my test system for Emby Theater also uses the 15 minute screen inactive and i haven't seen any problems.

 

Ok, thanks. It was working before the 2.5.25 update. Will try to reinstall the GPU drivers. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...