Jump to content

TvOS 10 major issues


Sarithz
 Share

Recommended Posts

Lots of continuous issues since my Apple TV upgraded to tvOS 10. Media sometimes will not play or the device just goes black and locks up. Other times, the system will just exit out to the main Apple menu. Not happening with my Roku or with Plex on the AppleTV.

 

 

Sent from my iPad using Tapatalk

Link to comment
Share on other sites

If any of your media contains DTS tracks I've noticed they no longer play on tvOS 10. I've reported that as a bug to Apple.

 

The 'goes black and locks up' is something else I've observed as well but I've been unable to track it down.

Link to comment
Share on other sites

@@ebr, so I spent quite a bit of time looking into this and while it wasn't consistently repeatable I was able to get the 'goes black and locks up' situation a number of different times. When this occurred the main thread CPU was spiking, and it appeared to be waiting on a web socket message sent from the server to be processed.

 

I modified the web socket handler to delegate to the JS handler on a background thread and the problems seem to subside. The app still crashed a couple of times but it was very infrequent and I believe that's actually another bug (potentially in tvOS) but it wasn't nearly as prevalent as this 'goes black and locks up' situation.

 

I have the changes ready to go on a branch if you want a PR.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...