Jump to content

An error occurred loading this content


mollie
 Share

Recommended Posts

Hello,

 

fairly new here on the forum and with Emby, but I wanted to give it a try.

Enthousiast about Emby, the interface and the server, I'm even thinking about getting me an 'lifetime license', but all the movies must play well of course :-)

 

I setup Emby server on Ubuntu server 14.04, with NFS shares to my NAS.

Server version: 3.0.6060.0

AppleTV 4 with latest Emby client

 

Now the strange thing happens, a lot of my movies play flawlessly with Emby, but some do not.

Gravity for example. It gives me the 'An error occurred loading this content' error, and I don't know why :-(

 

This I found in the logfile:

 

2016-08-12 22:33:12.4132 Info App: Bitrate exceeds DirectPlay limit

2016-08-12 22:33:12.4132 Info App: Profile: Unknown Profile, Path: /mnt/movies/Gravity/Gravity.mkv, isEligibleForDirectPlay: False, isEligibleForDirectStream: True
2016-08-12 22:33:12.4132 Info App: Profile: Unknown Profile, No direct play profiles found for Path: /mnt/movies/Gravity/Gravity.mkv

 

The movies seems to start, but gives the error message 1 second later.

Now exact the same happens with The Grand Budapest Hotel for example.

 

from the logfile:

2016-08-12 18:07:07.9481 Info App: Bitrate exceeds DirectPlay limit

2016-08-12 18:07:07.9481 Info App: Profile: Unknown Profile, Path: /mnt/movies/The Grand Budapest Hotel/The Grand Budapest Hotel.mkv, isEligibleForDirectPlay: False, isEligibleForDirectStream: True
2016-08-12 18:07:07.9481 Info App: Profile: Unknown Profile, No direct play profiles found for Path: /mnt/movies/The Grand Budapest Hotel/The Grand Budapest Hotel.mkv
2016-08-12 18:07:07.9482 Info App: Bitrate exceeds DirectPlay limit
2016-08-12 18:07:07.9482 Info App: Profile: Unknown Profile, Path: /mnt/movies/The Grand Budapest Hotel/The Grand Budapest Hotel.mkv, isEligibleForDirectPlay: False, isEligibleForDirectStream: True

 

I attached the movie info from the dashboard (browser) with this post.

 

I just don't understand why these movies won't play.

I use Plex server on Ubuntu, with Plex client on AppleTV 4 and the movies play perfectly.....

I play these movies with Infuse 4.x Pro on AppleTV 4 and they play perfectly.....

 

I tried to lower the bitrate in the Emby AppleTV app. Default it was at "Auto"

Then I tried 40 Mbit/s

Then I tried 30 Mbit/s

and I tried 10 Mbit/s

All to no avail with these particularly movies.

 

Hope there is someone that understands whats going on and why these movies won't play.

 

Thanks

 

Marcel

post-149800-0-09310500-1471036260_thumb.jpg

post-149800-0-35828100-1471036268_thumb.jpg

Link to comment
Share on other sites

Hi Luke,

 

so I restarted the server (twice), which gives me an 'clean' logfile, which I included.

Tried to start "Gravity" and "The Grand Budapest Hotel", both resulting with the error-message.

 

I didn't see any other log, like remux log or something, as you can see in the screenshot.   :(

 

hope this helps

 

Greetz

 

Marcel

Log.txt

post-149800-0-06307700-1471066976_thumb.jpg

Edited by mollie
Link to comment
Share on other sites

What is different about these from the ones that work? Is the path shown in the log message correct from the perspective of the server?

Link to comment
Share on other sites

Hi Ebr,

 

yes, the path is correct. It's the same NAS, same share and structure as where are all my movies stored.

 

What I did notice today, is that when I use the iPhone Emby client and cast to chromecast, there is no problem at all!

Gravity and Grand Hotel Budapest playing flawlessly when being casted to Chromecast (via the iPhone Emby client!)

 

Makes it look like there could be a tiny bug in the AppleTV 4 client of Emby, which gives the "An error occurred loading this content" error?

 

GreetZ

 

Marcel

Link to comment
Share on other sites

Hi Ebr,

 

yes, the path is correct. It's the same NAS, same share and structure as where are all my movies stored.

 

What I did notice today, is that when I use the iPhone Emby client and cast to chromecast, there is no problem at all!

Gravity and Grand Hotel Budapest playing flawlessly when being casted to Chromecast (via the iPhone Emby client!)

 

Makes it look like there could be a tiny bug in the AppleTV 4 client of Emby, which gives the "An error occurred loading this content" error?

 

GreetZ

 

Marcel

 

can you put this url in your browser and then tell us what the response is?

http://10.0.2.220:8096/emby/videos/05e92afa2590d2e6e134c37d5bc235ab/master.m3u8?DeviceId=B9237F90-5221-43FA-A8CA-845B8E2747C8&MediaSourceId=05e92afa2590d2e6e134c37d5bc235ab&VideoCodec=h264&AudioCodec=ac3,aac,mp3&AudioStreamIndex=1&VideoBitrate=19552000&AudioBitrate=448000&MaxAudioChannels=6&MaxHeight=1080&Level=41&Profile=high&PlaySessionId=c23f2bd8633c497d86f081ddcb50c881&CopyTimestamps=false&ForceLiveStream=false&EnableSubtitlesInManifest=true

It appears that Apple TV downloaded the master manifest, but then stopped and went no further and did not download anything after that. Why, I'm not sure. It may have seen something in the master manifest that it didn't like.

 

thanks.

Link to comment
Share on other sites

Hi Luke,

 

I did copy and paste the URL and I get an black tab in Safari, which says: Loading (Laden in Dutch!)

See the screenshot :-)

 

What I do find strange, in the URL you provided (it's from the server log) is that there is this part:

 

 

http://10.0.2.220:8096/emby/videos/05e92afa2590d2e6e134c37d5bc235ab/master.m3u8?DeviceId=B9237F90-5221-43FA-A8CA-845B8E2747C8&MediaSourceId=05e92afa2590d2e6e134c37d5bc235ab&VideoCodec=h264&AudioCodec=ac3,aac,mp3&AudioStreamIndex=1&VideoBitrate=19552000&AudioBitrate=448000&MaxAudioChannels=6&MaxHeight=1080&Level=41&Profile=high&PlaySessionId=c23f2bd8633c497d86f081ddcb50c881&CopyTimestamps=false&ForceLiveStream=false&EnableSubtitlesInManifest=true

 

The Audiocodec=ac3,aac,mp3 part in particular.

Because "Gravity" as "The Grand Budapest Hotel" do only have 1 audiotrack being DTS HD-Master.

But I don't know if that has something to do with it?

post-149800-0-42424500-1471159330_thumb.jpg

Edited by mollie
Link to comment
Share on other sites

Do all the ones that fail only have a DTS-MA track?

 

Do the ones that play properly have some other type of audio?

Link to comment
Share on other sites

@@ebr I tried a couple more movies, with or without extra audiotracks, and it doesn't matter.

I tried an version of "The Lady In the Van" with DTS HD-Master only, and it played perfectly!

I tried an version of "The Hunger Games: Mockingjay - Part 2" with DTS HD-Master and an Dolby Digital audiotrack, to no avail!

Wether I am starting the movie with DTS HD-Master selected  as soundtrack or Dolby Digital as soundtrack.

Keep getting the error "An error occurred loading this content"...... :-(

 

@@Luke, the safari browser does not play the movie. it's just stuck there with an black tab, and endlessly stating that it's loading......

Edited by mollie
Link to comment
Share on other sites

Keep getting the error "An error occurred loading this content"...... :-(

 

@@Luke, the safari browser does not play the movie. it's just stuck there with an black tab, and endlessly stating that it's loading......

 

Okay, so something about those particular movies the iOS platform simply cannot play.  We just need to determine exactly what it is and then be able to transcode them properly.

 

That message you are seeing is coming from the Apple TV video player itself.

Link to comment
Share on other sites

@@ebr I tried a couple more movies, with or without extra audiotracks, and it doesn't matter.

I tried an version of "The Lady In the Van" with DTS HD-Master only, and it played perfectly!

I tried an version of "The Hunger Games: Mockingjay - Part 2" with DTS HD-Master and an Dolby Digital audiotrack, to no avail!

Wether I am starting the movie with DTS HD-Master selected  as soundtrack or Dolby Digital as soundtrack.

Keep getting the error "An error occurred loading this content"...... :-(

 

@@Luke, the safari browser does not play the movie. it's just stuck there with an black tab, and endlessly stating that it's loading......

 

Can you put that url back in your browser, this time, download it by using "save as". I want to see the contents of the m3u8. Basically there is something about it that the apple tv player doesn't like and we need to figure out what that is. thanks.

Link to comment
Share on other sites

@@ebr that's hard to tell wether the error is generated by de AppleTV or the Emby Client.

I made an photo of the error on my television, maybe that helps determine which of the two producing the error.

 

@@Luke I did as you said and included the m3u8 file with this post for inspection :-)

I renamed it to 'master.txt' as the system wouldn't allow to upload the 'master.m3u8' file.

master.txt

post-149800-0-38187800-1471292147_thumb.jpg

Link to comment
Share on other sites

It is the video player producing that message.

 

Hopefully Luke will spot something in the manifest we can adjust.  Thx.

Link to comment
Share on other sites

It might be the audio is above hls specifications 384k bitrate. The server at times (ive noticed since roku uses same hls as apple) sends back a bitrate of 448 when downmixng from 640k. This might be the kicker. Just making you aware it might be an easy fix.

 

The roku is resilent enough to play these higher bitrates, but with sometimes noticeable tinny sound and lower decibel since anything over 384 is stripped. If the bitrate goes too high towards the 448 side during explosions/loud noises, the roku will drop the audio stream and play silence from that point on. The video stream will happily continue.

Edited by speechles
  • Like 1
Link to comment
Share on other sites

Glad someone else reported this since I totally failed with following up on my post a couple of weeks ago. (walking away with head hanging down)...... :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...