Jump to content

Force transcode H265 setting does nothing


Bloodred
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Bloodred

Hello, I've got an older laptop (2.13GHz C2D, GT240M) set up as a HTPC with Kodi and Emby (and the sync addon installed server-side). It is connected via Gbit Ethernet to the Emby server, running on a Debian machine. The Emby addon is configured to stream everything directly via SMB and this works flawlessly for all H264 files I've tried - the old C2D can even handle Hi10p 1080p content very well with no dropped frames, to my surprise.

 

Here comes the problem, though - it cannot handle H265 properly and Kodi itself seems to have trouble decoding it properly (bad artifacting), so I enabled the "Force transcode H265" setting. Problem is, the setting doesn't work, it does not do anything. H265 files are still streamed directly from the server (I checked the server's dashboard). I thought it could be due to other settings, so here's what I've tried (in all possible combinations):

  • Playback method: Addon or Native (Direct Path)
  • Stream from HTTP or SMB
  • Force transcode H265: 480p (or higher), 720p (or higher), 1080p - the file is 1080p
  • Video quality: 100Mbps, 1000Mbps, low values at 1-2Mbps - the file is ~3Mbps H265
  • 2 different Kodi installs
  • Restarting the server and Kodi
  • (Tried in-browser playback too - transcoding works properly here, though it's probably unrelated)

At this point I don't know what else to try, the setting simply does not seem to take effect no matter how I configure playback. Some version info:

  • Kodi 16.1
  • Windows 8.1 client OS
  • Kodi plugin 2.2.10
  • Emby server 3.0.5986.0
  • Server OS is up to date Debian stable

I'd appreciate any help with this, I'd love to be able to watch all my videos in the living room too. Thanks!

Link to comment
Share on other sites

  • Solution
Angelblue05

It will only work if you use addon playback mode. Is that what you are using right now? Did you reset your local database between changing playback modes?

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

Bloodred

I tried addon playback mode but wasn't aware that I also had to reset the library since I had chosen native mode on initial setup, though it does make sense in hindsight, I imagine Kodi had stored the SMB paths for the files and was playing them directly with no Emby involvement. Everything seems to work perfectly now, thank you!

Edited by Bloodred
  • Like 1
Link to comment
Share on other sites

Angelblue05

Thanks for reporting back. We will include a way to make users aware they need to reset their local database with a visual warning.

 

Anyway, glad everything is working. :)

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...