Jump to content

Network Shares not found


budssgc
 Share

Go to solution Solved by dcook,

Recommended Posts

budssgc

Emby is not seeing the network shares, when I go to add media it shows the local drives and networking (networking is blank) but if I try to use IP or network name the info is blank, I can access the shares from windows.

 

Details:

So I had emby setup and working for about a month or 2, all the media added and accessible, went and finally paid for the lifetime subscription and went to go log in and so some test, when I couldn't see any media, Started troubleshooting, found out that if I tried to add new media or modify the existing, that emby could not see the network essentially. Tried adding drive as mapped networking drive, ensured I could see the network shares, checked permissions for username ( which has full writes to the drives) checked networking settings across the board. I even went as far as to completely wipe it and re-install fresh, and tried it on a different pc and the pc that has the data, still cant see the network path. I work in IT tier2/tier3 so I know my way around and how to troubleshoot, but this issue has me perplexed.  Error is "There was an error adding the media path. Please ensure the path is valid and the Emby Server process has access to that location." when adding media to the library.

Edited by budssgc
Link to comment
Share on other sites

  • Solution
dcook

You need to make sure that the user account EMBY is running as has access to your shared drives.  Just because your use account has access to the shares does not mean that EMBY does. 

 

Also you should not use Mapped Drive as they are unreliable.  You should use the UNC path instead.

  • Like 2
Link to comment
Share on other sites

budssgc

Just want to make sure I understand, My setup is on a domain, and the network shares in the library are added by the \\IP\NetworkSharename the user account that emby is running on is added to a group in AD, and that group has full read/write the network drives, and your saying that there is an EMBY user, that im assuming is within the program that I need to added to the AD group, Or do I just create a username in AD called EMBY?

(mapped network drive was only for testing , not intended for long-term)

Edited by budssgc
Link to comment
Share on other sites

dcook

I am saying that whatever user account that is running the EMBY service, needs to have access to those shared drives

 

If you login to the PC with the EMBY user account and try to access the drive via explorer: \\ip\sharename does it work? and can you read/write?

Link to comment
Share on other sites

budssgc

Okay, so yes then, the user account that has the emby server running on it, does have access to those shares with full permissions, and I can access/read/write to the shared drives with that account on the server its running on from within windows. Within Emby in the library section, when adding/editing media under folders + , it shows local drives and network. If I expand network its completely blank with no ... for  going back a level. if I manually type in the IP and wait or hit refresh its blank. if I manually type in the IP and hit enter, it shows it as added in the list, then when I hit save it gives me that error.

Edited by budssgc
Link to comment
Share on other sites

dcook

If you expand network and its blank, then the user account is not able to browse the network, since you are running on a domain there is any number of things that could be causing issues, Group Policy for example.

 

I suggest posting screen shots of what you are seeing, and server log for the same time period

Link to comment
Share on other sites

budssgc

I thought GPO as well at first, but I had it working awhile ago with no issues and no settings were changed anywhere between now and then, but I went down that route anyways, with no luck, just double checked GPO that are applied to that user and the servers, nothing that stands out, or that would indicate a issue in GPO. I'll add some screen shots of everything.

Link to comment
Share on other sites

budssgc

See screen shots and log attachments, the order is a little off, but it should be, emby 1.png: emby network selected.png: emby ip.png: emby added.png: emby added error.png. I am not beyond letting you into my system to see if we can figure this out, I spent most of yesterday working on this. 

post-119322-0-25370100-1462978062_thumb.png

post-119322-0-96253700-1462978062_thumb.png

post-119322-0-28393500-1462978063_thumb.png

post-119322-0-79355200-1462978063_thumb.png

post-119322-0-29030800-1462978064_thumb.png

post-119322-0-80255400-1462978064_thumb.png

post-119322-0-35756600-1462978065_thumb.png

post-119322-0-82566200-1462978065_thumb.png

post-119322-0-32246700-1462978066_thumb.png

post-119322-0-81526500-1462978066_thumb.png

Edited by budssgc
Link to comment
Share on other sites

budssgc

So funny story, I was reviewing the logs I sent, and I noticed there was an extra period at the end of the ip. So I went back in and this time I copied the network path from windows and pasted it, and bam it worked, even though that's what I did months ago and that library was still there not working, and no changes were made. But whatever it works, its currently rebuilding the library and movies and shows are showing up. Thanks for your time, and effort.

Link to comment
Share on other sites

  • 8 months later...
TinkeringTot

I just wanted to add this note since I found this searching for a very similar problem.

If you are running the Emby service you may need to change who that service runs as.  For me it was running as "local machine". Once I corrected that my shares came up as expected.

  • Like 1
Link to comment
Share on other sites

Nebular Nerd

I read through this and another thread and after changing the Emby Service to my personal Admin account I now get Direct Playing show up on a couple of systems that were being tetchy, I still cannot directly browse to the shares (only shows 2 or 3 of the networked systems and can't scroll down or such) but the important part is DIRECT PLAYING :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...