Jump to content

Root Access by changing Sudoers file failed


Michael_Schmitz
 Share

Recommended Posts

Michael_Schmitz

Hi,

 

Tried to get access to Root in DSM 6.

Edited sudoers file as described. But seem to made a mistake. No I cannot use the sudo su- command any more?

 

Any idea how to change the sudoers file?

sh..t

 

 

Link to comment
Share on other sites

The way i fixed this issue ... but be warned I still can't get winSCP to work.. I can - however - get ssh access as root.. So that's fine for me.. i just use scp and copy files around that I upload to a share (i can get winSCP to work as non-root)

 

1) SSH as admin

2) synouser --setpw root [CURRENT - ADMIN - PASSWORD]

 

3) and then log out,

4) SSH as root ..

 

tadaaa

 

it all worked for me from here... Not 100% sure that the root password needed to be the same as the admin password, but, it seemed safer given the history of the root and admin accounts being linked up!

Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...