Jump to content

Ubuntu Server Error


Agyy
 Share

Recommended Posts

Hello, 

 

Im currently running server version 3.0.5786.0 

 

For some reason I´ve started to get a error messages yesterday.

Error getting channel itemsSystem.IO.IOException: Corrupted data ReadInternal
  at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_delegate_end_invoke (object,intptr)
  at (wrapper delegate-end-invoke) <Module>:end_invoke_int__this___IAsyncResult (System.IAsyncResult)
  at System.IO.Compression.DeflateStream.EndRead (IAsyncResult async_result) <0x41641320   0x000ab> in <filename unknown>:0 
  at System.IO.Stream.<BeginEndReadAsync>m__4 (System.IO.Stream stream, IAsyncResult asyncResult) <0x7fd3ada54770   0x00019> in <filename unknown>:0 
  at System.Threading.Tasks.TaskFactory`1 FromAsyncTrimPromise`1[TResult,TInstance].Complete (TInstance thisRef, System.Func`3 endMethod, IAsyncResult asyncResult, Boolean requiresSynchronization) <0x7fd3add64e90   0x0005d> 24789 in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7fd3ada8b6d0   0x00029> in <filename  

I don´t know what causing it but I know it seems to be with some regularity and Ive got it three times today. I did the update to the latest version five days ago so it dosen´t seem to be a failure in the installation. I have already checked the scheduled tasks but I diden´t find any that did match the timeframe for the errors.

 

If anyone could provide me with some help where to look or any other useful information i would be glad.

 

If you need any logs I will provide them just don´t know what would be useful.

 

Kind Regards!

 

 

Link to comment
Share on other sites

Well I recived the error in a  PushBullet notification, It seems that my Podcast addon dosen´t display any Podcasts any more so Im guessing something is wrong with it or maybe the feed

Link to comment
Share on other sites

I put up an update to the podcasts plugin. let me know if the issue persists. 

 

also fyi, you have some issues with the server being unable to access your media locations

	Access to the path "/mnt/torrent/localmovies/Black.Mass.2015.720p.BluRay.x264-BLOW/blow-black.mass.2015.720p.bluray.x264.nfo" is denied.
	System.UnauthorizedAccessException

Link to comment
Share on other sites

thanks!

 

Yea I know about that for some reason when i create a new folder on that mount I have to manually go in and set the chmod on that folder to get access to it even thou it should have access by default but that is a whole other headache for me to solve :)

 

thanks for the help!

Link to comment
Share on other sites

We'd have to see the server log to know what that means but if it's the same access denied errors then it's just a matter of permissions.

Link to comment
Share on other sites

Well This is not a permissions issue I´d think, this is related to the Podcast addon and what I know the addon just streams the audio from the source and dosen´t save anything locally?

 

Il try and remove all my podcasts an disable the Podcast addon and see if the errors stop.

 

 

Server.txt

Link to comment
Share on other sites

I've posted an update to the podcast plugin. It's marked as beta so in order to see it you'll need to set your update level to Beta under advanced. Please try it out and let me know how it goes. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...