Jump to content

New beta appears to be listening on IpV6 only


tymanthius
 Share

Recommended Posts

tymanthius

Ok, so saw the beta update and decided to try it b/c of ipv6 & a few other tweaks.

 

So on my debian 8 system did apt-get update && apt-get install emby-server-beta.  (server is headless, so 'localhost' doesn't work well)

 

Easy.

 

But when I went to try it out, couldn't get to my server from emby.media, or from ipv4:8096.  Tried [ipv6]:8096 and gave a 400 error.

 

If I do netstat -tuln I get tcp        :::8096 with -beta, but nothing on the ipv4 side.  With stable I get tcp       0 0.0.0.0:8096, but of course nothing on the ipv6 side.

 

Anything else I can provide to help with troubleshooting?

Link to comment
Share on other sites

tymanthius

Hmmm . . . I did that.  and did apt-get clean, then ran apt-get update && apt-get upgrade too.

 

Still same issues.

 

When it installed beta gave this msg: Setting up emby-server-beta (3.0.5782.0.9)

 

Seems the version # is off . . .

Link to comment
Share on other sites

tymanthius

So, finally had some time today.  I shutdown stable server, moved the logs out.  Updated to beta via apt-get, & it started.  Tried to access from a Win10 64bit Box running chrome using the global IPv6 address.  I got "Bad Request (Invalid url: http://[2600:8096/)"

 

The ipv4 wouldn't ever connect, no error msgs (actually tried it first).

 

 

Stopped the server, went back to stable.

 

Attached is the log from beta start up to shutdown.

 

 

beta.server.log

Link to comment
Share on other sites

Ok, it appears we hadn't setup the beta branch to trigger automatic updates on each commit. We will be enabling that in the next couple days so i would try again after the new year.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...