Jump to content

Stretch and Wily support and more (libmediainfo0v5)


hurricanehrndz

Recommended Posts

hurricanehrndz

Hey Everyone,

 

First of all sorry for the delay in releases. Now for state of affairs. Currently OBS (open build system) does not support stretch, so support for stretch will be provided via the new docker package builder. It is up to each user to build their own package for stretch. You will find the instructions below. For wily, it will be the same for the next couple of days or weeks until we get our ppa for wily up and running. Many users are reporting installation issues because of our dependency of libmediainfo0 and the fact that some distros such as stretch and wily include libmediainfo0v5 instead. Additionally, there seems to be some users running jessie, trusty, utopic and so who have upgraded their libmediainfo library file to the new libmediainfo0v5 via a third party ppa or testing ppa, for us to support these users would require us to include libmediainfo0v5 in our ppas. This would increase the workload on the very tired and busy packaging group. To say the least this scenario is still under consideration and no decision has been made. 

 

Building your own packages using the package builder via docker:

 

stretch:

Feel free to replace "emby-server" with "emby-server-dev" or "emby-server-beta"

git clone https://github.com/MediaBrowser/Emby.Build.git
cd emby-builder
make DIST=debian/stretch emby-server

Wily

git clone https://github.com/MediaBrowser/Emby.Build.git
cd emby-builder
make DIST=ubuntu/wily emby-server

Please feel free to use the following two packages as well, these will be provided once and only once.

Dropbox

 

PS if there is a lot of interest in this, I will be more than happy to include other distros. Please place your request here.

Edited by hurricanehrndz
Link to post
Share on other sites

Hi, I'm trying to install the .deb package for Wily but I get some errors.

 

It seems that imagemagick-6.q8 libmagickwand-6.q8-2 and libmagickcore-6.q8-2 have been replaced by imagemagick-6.q16 libmagickwand-6.q16-2 and libmagickcore-6.q16-2 

 

This is the result with the latter packages installed:

Unpacking emby-server-dev (3.0.5768.7.git75051fa) ...
dpkg: dependency problems prevent configuration of emby-server-dev:
 emby-server-dev depends on libmagickwand-6.q8-2; however:
  Package libmagickwand-6.q8-2 is not installed.
 emby-server-dev depends on libmono-corlib4.5-cil (>= 4.0.0~alpha1); however:
  Version of libmono-corlib4.5-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-posix4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-posix4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-configuration4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-configuration4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-core4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-core4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-data4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-data4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-runtime-serialization4.0-cil
dpkg: error processing package emby-server-dev (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (225-1ubuntu9) ...
Errors were encountered while processing:
 emby-server-dev
Edited by kvirkel
Link to post
Share on other sites
hurricanehrndz

 

Hi, I'm trying to install the .deb package for Wily but I get some errors.

 

It seems that imagemagick-6.q8 libmagickwand-6.q8-2 and libmagickcore-6.q8-2 have been replaced by imagemagick-6.q16 libmagickwand-6.q16-2 and libmagickcore-6.q16-2 

 

This is the result with the latter packages installed:

Unpacking emby-server-dev (3.0.5768.7.git75051fa) ...
dpkg: dependency problems prevent configuration of emby-server-dev:
 emby-server-dev depends on libmagickwand-6.q8-2; however:
  Package libmagickwand-6.q8-2 is not installed.
 emby-server-dev depends on libmono-corlib4.5-cil (>= 4.0.0~alpha1); however:
  Version of libmono-corlib4.5-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-posix4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-posix4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-configuration4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-configuration4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-core4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-core4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-data4.0-cil (>= 4.0.0~alpha1); however:
  Version of libmono-system-data4.0-cil on system is 3.2.8+dfsg-4ubuntu4.
 emby-server-dev depends on libmono-system-runtime-serialization4.0-cil
dpkg: error processing package emby-server-dev (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (225-1ubuntu9) ...
Errors were encountered while processing:
 emby-server-dev

You still need to add our 15.04 repo and follow the install instructions, except don't install emby-server from the repo install it from the package provided. 

Link to post
Share on other sites

@@hurricanehrndz, Great work figuring this out, I've run into a small problem though. I downloaded the wily.emby-server-dev_3.0.5768.7.git75051fa_all.deb, installed it with dpkg -i wily.emby-server-dev_3.0.5768.7.git75051fa_all.deb but upon running sudo service emby-server start I receive errors in the script. I can paste the systemd status -l if that will help

 

● emby-server.service - Emby Media Server
   Loaded: loaded (/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2015-10-31 15:11:35 MDT; 4min 52s ago
  Process: 11885 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=0/SUCCESS)
  Process: 11876 ExecStart=/usr/bin/emby-server start (code=exited, status=1/FAILURE)
 Main PID: 11876 (code=exited, status=1/FAILURE)
 
Oct 31 15:11:35 monkeytv emby-server[11876]: /usr/bin/emby-server: line 82: $PIDFILE: ambiguous redirect
Oct 31 15:11:35 monkeytv su[11876]: No passwd entry for user 'env'
Oct 31 15:11:35 monkeytv su[11876]: FAILED su for env by root
Oct 31 15:11:35 monkeytv systemd[1]: emby-server.service: Main process exited, code=exited, status=1/FAILURE
Oct 31 15:11:35 monkeytv emby-server[11885]: dirname: missing operand
Oct 31 15:11:35 monkeytv emby-server[11885]: Try 'dirname --help' for more information.
Oct 31 15:11:35 monkeytv emby-server[11885]: chown: missing operand after ‘.’
Oct 31 15:11:35 monkeytv emby-server[11885]: Try 'chown --help' for more information.
Oct 31 15:11:35 monkeytv systemd[1]: emby-server.service: Unit entered failed state.
Oct 31 15:11:35 monkeytv systemd[1]: emby-server.service: Failed with result 'exit-code'.
Edited by Delphi
Link to post
Share on other sites
hurricanehrndz

It's seems like when you setup emby you told it to install with the run user being env, unfortunately there seems to be no user named env. Your best bet would probably be to try and do a purge and ensure your read all debconf prompts on reinstall

 

Sent from my D6603 using Tapatalk

Edited by hurricanehrndz
  • Like 1
Link to post
Share on other sites

As compiling it myself didn't work

make: docker: Command not found
Makefile:33: recipe for target 'build' failed
make: *** [build] Error 127

I managed installing it using the precompiled .deb files from your Dropbox and using the dependencies from the Ubuntu 15.04 repo. It seems to run fine, I can access the web interface, it finds my media, and the Android app plays everything fine.

However, the web interface doesn't play any audio. Might this have anything to-do with the current way of installing?

Link to post
Share on other sites
hurricanehrndz

In terms of no audio in the web interface, it might be best if you post a topic with your log. I don't think it's related to the package. 

Edited by hurricanehrndz
Link to post
Share on other sites

No I found out it's not indeed. Seems to be an issue with Firefox on Linux, I'll post an seperate issue for it. For now, this method works fine, thanks a lot! Although I do hope you're still going to make the official repo ;)

Link to post
Share on other sites

Quick question. My Emby Server dashboard is telling me there is a new version. Currently Version 3.0.5724.6 and Version 3.0.5781.0 is available. My docker is running on unraid.

 

Based on what you mentioned above, should we hold off upgrading at this time? I think the only way I can upgrade is to delete and reinstall the docker. I don't thing the dev upgrades are working now but i could be wrong.

 

Thanks.

Link to post
Share on other sites
hurricanehrndz

This thread is not for docker and my statement was in regards to the 15.10 repo. But to answer your question, I am very close to finishing the repo fix for beta packages. That being said there have been many stable updates and the docker release for the stable version is being updated and perfectly fine.

 

Sent from my D6603 using Tapatalk

Link to post
Share on other sites

As compiling it myself didn't work

make: docker: Command not found
Makefile:33: recipe for target 'build' failed
make: *** [build] Error 127

I managed installing it using the precompiled .deb files from your Dropbox and using the dependencies from the Ubuntu 15.04 repo. It seems to run fine, I can access the web interface, it finds my media, and the Android app plays everything fine.

However, the web interface doesn't play any audio. Might this have anything to-do with the current way of installing?

Hey PureTryOut,

I had the same error, and did apt-get install docker

Still had same issue, as you did. 

Found that a package called docker-compose is the one to be installed, in order to build. 

 

Keep up the good work Devs :D Much appriciated.

Link to post
Share on other sites
hurricanehrndz

Thank you for you feed back. I'm not sure why you would need compose, I will look over the project and ensure that compose is not needed.

 

Update:

 

I look it over and I see no reason why compose would be required at all. There is no reference to docker-compose.

 

@salskin

 

Where did you install docker from? Did you add their official ppa? PS the package might be called docker-engine.

 apt-cache search docker
docker-engine - Docker: the open-source application container engine
karbon - vector graphics application for the Calligra Suite
docker - System tray for KDE3/GNOME2 docklet applications
Edited by hurricanehrndz
Link to post
Share on other sites

Thank you for you feed back. I'm not sure why you would need compose, I will look over the project and ensure that compose is not needed.

 

Update:

 

I look it over and I see no reason why compose would be required at all. There is no reference to docker-compose.

 

@salskin

 

Where did you install docker from? Did you add their official ppa?

Hmm, nope, just used wily defaults.

Not sure if it is related, doubt it though, but got this error from the make command (after it was almost complete)

Building emby-server...
Cloning into '/var/cache/buildarea/emby-source'...
remote: Counting objects: 153893, done.
remote: Compressing objects: 100% (87/87), done.
remote: Total 153893 (delta 20), reused 0 (delta 0), pack-reused 153803
Receiving objects: 100% (153893/153893), 772.21 MiB | 4.81 MiB/s, done.
Resolving deltas: 100% (104420/104420), done.
Checking connectivity... done.
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
dch: fatal error at line 584:
Cannot find debian directory!
Are you in the correct directory?
Makefile:36: recipe for target 'emby-server' failed
make: *** [emby-server] Error 2

Not sure if it was supposed to change directory in the script, and if so, which :/

I'll remove the docker-compose/docker, and try their ppa

Link to post
Share on other sites
hurricanehrndz

 

Hmm, nope, just used wily defaults.

Not sure if it is related, doubt it though, but got this error from the make command (after it was almost complete)

Building emby-server...
Cloning into '/var/cache/buildarea/emby-source'...
remote: Counting objects: 153893, done.
remote: Compressing objects: 100% (87/87), done.
remote: Total 153893 (delta 20), reused 0 (delta 0), pack-reused 153803
Receiving objects: 100% (153893/153893), 772.21 MiB | 4.81 MiB/s, done.
Resolving deltas: 100% (104420/104420), done.
Checking connectivity... done.
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
dch: fatal error at line 584:
Cannot find debian directory!
Are you in the correct directory?
Makefile:36: recipe for target 'emby-server' failed
make: *** [emby-server] Error 2

Not sure if it was supposed to change directory in the script, and if so, which :/

I'll remove the docker-compose/docker, and try their ppa

 

Hmm, docker-compose is fine. It installed the docker-engine and wily has a recent release so no need. Can you post the exact run command you ran and I will try and debug it.

Edited by hurricanehrndz
Link to post
Share on other sites

Hmm, docker-compose is fine. It installed the docker-engine and wily has a recent release so no need. Can you post the exact run command you ran and I will try and debug it.

Right - I ran 'make DIST=ubuntu/wily emby-server'

(Ran it twice, as I had forgot to stop the running emby-server the first time, which reported that port was already assigned, which lead to an error)

Ran it as root, and was cloned to a subdir in regular users ~/embystuff/Emby.Build/emby-builder

Link to post
Share on other sites
hurricanehrndz

Right - I ran 'make DIST=ubuntu/wily emby-server'

(Ran it twice, as I had forgot to stop the running emby-server the first time, which reported that port was already assigned, which lead to an error)

Ran it as root, and was cloned to a subdir in regular users ~/embystuff/Emby.Build/emby-builder

Thank you. The issue is being addressed, I will have it fixed within the hour. The problem was with the fact that I did all my testing with dev and beta builds. Never tested the stable build.

Link to post
Share on other sites

Most excellent, looking forward to updating, as I have an issue with the recent update (before the current one) which I don't want to report if the update actually fixes it.
I've looked through the forum, and couldn't find others having same issue. I think its transcoding related, but its another story :) 
Cheers for the hard work :D

Link to post
Share on other sites
hurricanehrndz

Transcoding might be related to ffmpeg too, repo has been update. Just tested and it should all be fixed now.

Edited by hurricanehrndz
Link to post
Share on other sites

There was a lot of warnings during the installation - But this time it completed - and seems functional, as before the update :)
However, it tells me: 

Version 3.0.5780.36522

A new version of Emby Server is available!

Version 3.0.5781.0 is now available for download.

As a sidenote: the issue with transcoding, is sound scratches from time to time.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...