Jump to content
kuebs

Cannot add Movie folders

Recommended Posts

kuebs

My next issue is that I cannot add a folder called movies.

 

Each time I try to add it, I can add the type of folder.  When I go to the D drive to pick the movies folder it jumps me to the user login screen.  And I never seem to have the right password.   I even tried resetting the password and get a message, (after following the steps) that I have reset the password to no password.  But each time I try to add the folder content it never lets me past this user permission.

 

Now it has allowed me to add other folders, which happen to be on a separate drive to the library, but not this one.   And I get no explanation as to why.

Share this post


Link to post
Share on other sites
ebr

Make sure the user under which the server is running has permissions to access the locations you are trying to access.  Getting dropped to the log-in screen sounds like a permissions issue that could be getting mis-interpreted as our authorization failing.

Share this post


Link to post
Share on other sites
kuebs

I checked.  Full permissions for the user and read for everyone.   Still doesn't help.

Edited by kuebs

Share this post


Link to post
Share on other sites
ebr

You said that before and then we found domain access issues in the log. :)

 

Not seeing this specific log, I can't be sure but there are access problems in the log you posted elsewhere.

Share this post


Link to post
Share on other sites
Happy2Play

Log from other post shows "Access to the path 'D:\Movies' is denied."

Share this post


Link to post
Share on other sites
kuebs

That is very odd.  I just readded the user with the read, change and full control and everyone also has read permissions.

 

Log is also attached as a txt file now.

Share this post


Link to post
Share on other sites
kuebs

I just stopped the shared folder.  And then recreated it and gave it permissions to just everyone and the account.  Again, immediate denial.   Is this at related to the scanned library failing?

Share this post


Link to post
Share on other sites
kuebs

I was having continual trouble with allowing access to the folders on this drive.   I finally figured out a script that reset file and owner rights to all files on the drive.

 

Its, icacls  * /t /q /c /reset

 

It reset all rights to default and then I could assign folders and was able to add movies to the library.

 

I still cannot get the library to scan.  But that is for another thread.

Share this post


Link to post
Share on other sites
jordy

you mentioned "read" permissions, are you also providing "write" permissions? Emby needs to write .nfo or .xml files to each movie directory to keep all the info related to the movie...

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...