Jump to content

Server Re-Install: Custom Path for former ImagesByName Folder?


gochiefs88842

Recommended Posts

gochiefs88842

I just did a reinstall of the server (and Windows, for that matter) and I'm trying to direct the server to reference a different folder than the default ImagesByName folder for People.

 

My server is installed on the C: drive, which is a small 60GB SSD.  To save space on my C: drive, I want Emby to locate people images on my E: drive instead.

 

Prior to having to completely reinstall Windows, I was able to save my "ImagesByName" folder (with ~16.5 gb of hi-res actor images from an IMDB IBN People Downloader) to a thumb drive and then migrate those files to the E: drive upon fresh reinstall of Windows and Emby Server.  I seem to recall previous iterations of the Server config having a specific setting for redirecting the "ImagesByName" folder to another location, however I can no longer find that setting on the server config.  All I have been able to find is the "Path Substitution" under "Library" which is not working for me; I've tested this and it appears that (1) the default C: drive "ImagesByName" folder is empty and that now the C: drive "metadata-->People" folder is where this data is located by default, and (2) even after attempting the "Path Substitution" as noted above, it appears Emby Server is still trying to search in the default folder (~1.15 gb) for People images rather than my substituted path (~16.5 gb, better resolution, etc.).  The only other custom path config screen I can find is the cache path, but I'm not thinking that's related.

 

Please advise on how to get Emby Server to recognize a custom path for People images.  Thanks in advance for any guidance.

post-4652-0-19691600-1441654659_thumb.png

post-4652-0-56007100-1441654669_thumb.png

Link to post
Share on other sites

It is under Metadata -> Advanced.

 

The first option is the metadata path. Path Substitution (IIRC) is for mapped drives, not replacing existing directories so you can definitely remove that.

Link to post
Share on other sites
Happy2Play

There are two option.

 

Point Metadata to your IBN

 

or

 

add   <ItemsByNamePath>(enter your path)</ItemsByNamePath> to your system.xml (another legacy option for old users)

 

locate in system.xml

  <IsPortAuthorized>true</IsPortAuthorized>
  <ItemsByNamePath>Z:\ServerFolders\Emby-Server\ImagesByName</ItemsByNamePath>
  <MetadataPath />
Edited by Happy2Play
Link to post
Share on other sites
gochiefs88842

Is this for People, though?  Because the Metadata->Advanced verbiage suggests that it's for artwork/metadata that's not being saved within folders.  I always have the movie artwork metadata saved within the individual movie folder, I'm more concerned with where the images for the People/Actors will be saved and indexed.

Link to post
Share on other sites
Happy2Play

Correct that location is also used for metadata in you don't use "save artwork/metadata in media folders".

 

This was a change awhile ago combining the two folders.  So the new location will be Metadata\People  unless you point Metadata to your previous IBN folder.

Link to post
Share on other sites
gochiefs88842

This just created a major problem with my server.  I can no longer browse my library because it keeps asking me to log back in when I hit "Home."  Now I can't even go into my movies, let alone to see if they are using the correct path for the People images.  When I deleted the Metadata-Advanced path (image attached), the server then allowed me to view my library again.  

 

To be clear, your advice above is for me to go into the Metadata-Advanced and change the path (Image #1) to E\ImagesByName, knowing that my old ImagesByName folder is structured like Image #2?  Because I'm not sure how this is telling the server to only look in this folder for People images and only People Images.

 

 

post-4652-0-97955800-1441658007_thumb.png

post-4652-0-65264700-1441658023_thumb.png

Link to post
Share on other sites
Happy2Play

That look correct to me.  Did you perform a library scan and then Refresh people?  This should ensure the databases are updated and looking in the right location.

Link to post
Share on other sites
gochiefs88842

Well, it appears that correct path for my situation (noting how my former ImagesByName folder was structured in the previous image attachment) was  E\ImagesByName\People and notably not using a networked drive for that path.  The "Paths" on the main server config page also now notes Metadata as running through E:\ImagesByName\People\metadata.  I ran a library scan and now I'm doing a People refresh (which originally failed until I removed the networked path and just used the direct E: path), which appears like it will take at least another hour or two to complete.  I'll update at that point, but thanks for the advice thus far.

Edited by gochiefs88842
Link to post
Share on other sites
Happy2Play

Sorry for all the trouble didn't know additional metadata folder would be add.  The easiest solution for your direct path is adding <ItemsByNamePath>E:\ImagesByName</ItemsByNamePath> to your system.xml.

 

%appdata%\Emby-Server\config

 

This give you back path entry.

 

55ee0bd4c4685_ibn.jpg

Edited by Happy2Play
Link to post
Share on other sites
gochiefs88842

 

Happy2Play, the refresh People library didn't work, so I will try your .xml edit, however, I'm not sure where to add that code into the file?  At the end of document, or does it need to replace some text somewhere?  

 

Link to post
Share on other sites
Happy2Play

See post #3.  Don't really know if it matters.

Edited by Happy2Play
Link to post
Share on other sites
  • 2 weeks later...

as far as i can see the option to map IBN folder to a different location has been removed from the server, instead you must edit the system.xml file

 

Just think of it as the old IBN was renamed to the Metadata folder.

Link to post
Share on other sites

when i read that i interpreted it as meaning all metadata rather than just IBN. all good anyway

 

Well, if you don't store the metadata with your media, then it is all metadata.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...