Jump to content

Cannot connect to Roku Emby App after upgrade to BT Infinity


itsnot400
 Share

Go to solution Solved by itsnot400,

Recommended Posts

I have had Emby on my Panasonic TV via the Roku stick app for some time now and always works perfectly. However, this week we upgraded from broadband to Infinity, i have set up TV and all devices to connect to the new network and all works fine except i am not unable to connect to Emby via the app. Is there something i have missed? I uninstalled the Emby App and reinstalled and still wont connect. Any help i can find just sayes make sure everything is running in the same network. 

 

THanks

Link to comment
Share on other sites

Have you restarted the roku? That should solve the problems if the roku is the issue. Fairly straight forward how simple that box is.

 

The next question is: Are the roku and emby server on the same local network?

 

If yes: Did the server IP change from what it was? Is there a firewall on the server machine blocking access? Is the new router using a firewall?

 

If no: Did you set up port forwarding?

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

Im not even sure how to check all those things out. Impresuming eveything is on the same network? How can i check?

Assuming same local network. So to explain and simplify. Let's say, if the emby server and the roku use the exact same router, they are on the same local network. Check the windows firewall of your emby server. It needs to have an exception for emby made entirely, or told to allow traffic freely on port 8096. Otherwise just turn off windows firewall to test this. This is the most common reason why the roku won't immediately connect. The second reason is the internet/external ip has changed (if using emby connect fails) and/or the local/internal ip has changed (if manually logging in fails). You can get both of these from the machine running the emby server, and choose "manage server" the internal/external ip's are at the top of the page.

 

You can also look in the "network" of the server running emby. Type "network" in the "my computer" explorer dialog. You should "see" your roku listed in "other devices". If you don't there is a bigger issue afoot in the router somewhere and we can deduce further.

 

Additionally, make sure UPnP is enabled on your router. This simplifies things significantly when enabled.

 

a8RILMll.png

Edited by speechles
Link to comment
Share on other sites

  • Solution

Guys its working again. All i did was rest the network settings in the Roku and tried Emby again and it opened up straight away! Thanks for all the help.

  • Like 1
Link to comment
Share on other sites

Good to know, it had to be something simple and overlooked. Glad you caught it, now go enjoy your roku. ;)

Edited by speechles
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...