Jump to content

Tags issue


zarxic
 Share

Recommended Posts

I just setup a fresh install of Kodi 15 beta 1 with Emby 0.1.4.  In my Emby library setup, I have a shared folder of Movies that I have in 2 separate Media Folders (Movies and Kids Movies).  I have playlists setup for the tags and the shared movies are only showing up in the Kids Movies tags.  They should have both tags applied to them.  The shared movies do show up in both media folders in Emby.

 

I wasn't sure what log I would need to upload for this, be it Emby or Kodi.  Is this a known issue (I didn't see anything on a search) or would you like to see a log file?

Link to comment
Share on other sites

marcelveldt

We have uploaded a new version tonight (I believe its 0.1.7) which solves this issue... Could you please test with that version and report back?

Link to comment
Share on other sites

Right after I posted, I actually did a force check of new add-on updates because I saw in another thread that 0.1.5 had just been released. It actually installed version 0.1.7. I went into the Emby settings and told it to reset the Kodi database. I can try again tonight though.

Link to comment
Share on other sites

marcelveldt

Right after I posted, I actually did a force check of new add-on updates because I saw in another thread that 0.1.5 had just been released. It actually installed version 0.1.7. I went into the Emby settings and told it to reset the Kodi database. I can try again tonight though.

OK, please let us know. I've been working on this for the last couple of days and I think it's all fine now.

Link to comment
Share on other sites

Ok, I tried again after a Kodi DB reset and I still have movies that should have multiple tags that seem to only have one.  I don't know how to check what tags are actually on a movie, but they're not showing up under my smart playlist for Movies, but only Kids Movies (should be both).  I did notice that it scanned Kids Movies first, if that matters.  Which log can I get to you?

Edited by zarxic
Link to comment
Share on other sites

I just now realized I had selected to reset Emby settings, so nothing was logged.  I did again with debug and here is the new log with some actual information in it.  A few examples that should have multiple tags are 9, African Cats, Alexander and the Terrible, Horrible, No Good, Very Bad Day.

 

https://www.dropbox.com/s/es0wkk0flotk886/kodi.log?dl=0

Edited by zarxic
Link to comment
Share on other sites

marcelveldt

Ok, I tried again after a Kodi DB reset and I still have movies that should have multiple tags that seem to only have one.  I don't know how to check what tags are actually on a movie, but they're not showing up under my smart playlist for Movies, but only Kids Movies (should be both).  I did notice that it scanned Kids Movies first, if that matters.  Which log can I get to you?

Now I understand what you're saying.. I must confess I've misread your post. I thought you meant that you were seeing all movies while it should be filtered by tag.

 

It is the other around. You have some movies that should be in multiple collections. Sorry, I never realized that would be a valid possibility too. It's not implemented that way now, We assumed a movie a to be in 1 collection only...

 

I will take a look at the code if we can easiliy add this in.

Link to comment
Share on other sites

marcelveldt

@@zarxic I looked at both Emby webinterface and the Emby addon's code and what you're trying to do is impossible.

You added the exact same media folder to different media folders but assigned to the same user.

Both webinterface and Kodi addon won't show you this content seperated, mainly because it's the same content you added.

 

What you need to do is add both the movies subfolder and the kids movies as seperate media folders to Emby and it should work fine.No need to manually create tags or playlists, the emby addon will do all that for you.

 

1. Go to your Emby server settings/dashboard.

2. On the left, click Library

3. remove your current library item for movies that you've added there

4. press add, name the folder "movies"

5. add a media location --> choose your folder on the filesystem/UNC with the movies

6. Do the same for your kids movies

 

7. In emby addon, go to settings --> advanced and press local database reste.

8. A complete library import will be done.

9. Now in Kodi take a look at the "videos" section, you'll notice that your library folders will be seperated.

Link to comment
Share on other sites

Thanks for taking a look.  But it seems to me that it is working in the web interface as expected.  I hope I'm explaining this correctly.  Here's a few screenshots of my setup and the movies displayed to try and make it a little more clear.  These were all taken with the same user signed in (it's also the same user that Kodi is signed in with as well).  If the add-on can't do this, that's fine.  I will think of another way to set this up.  I just wanted to stay away from a separate third media folder for "Shared".

 

The Shared directory is in both the Kids Movies media folder and the Movies media folder:

 

5551024c950b7_kids_movies.png

 

5551025deae08_movies.png

 

 

When I go to the webserver to look at the movies listed, the movie "9" shows up correctly under both Media Folders.  This movie is only found in the Shared directory.

 

5551031dcb203_kids_movies_posters.png

 

55510342a9059_movies_posters.png

Edited by zarxic
Link to comment
Share on other sites

marcelveldt

The addon can handle this but only if used with multiple profiles. So:

 

1. You have a user "kids" to which you assign the "kids movies", when they log in in Kodi (or any other emby app) they will only have access to that content.

2. You have a user "adults" (or something like that) which is added to the folder "users"

 

The Kodi addon for Emby can not handle a movie to be assigned to more then 1 folder currently. I looked at the code yesterday but it will require some changing to add that. If you want I can add it to our feature requests ?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...