Jump to content
chef

Vera Home Automation Plugin (Emby Vera)

Recommended Posts

gmontem
22 minutes ago, gmontem said:

I installed Emby Server onto a new Windows server. I then installed the Vera plugin. After restarting the Emby Server, the Emby Server crashed.

It looks like the Vera plugin is making a request to my VeraSecure's port 3480 which is probably closed. My browser receives a connection reset error when I try to navigate to http://192.168.11.224:3480/data_request?id=sdata. Is there something I need to setup from my Vera's web frontend to get this work? I tried re-installing the "Emby Interface" app for Vera, but that didn't help.

I attached the server log and the Vera plugin's XML file.

embyserver.txt 19.29 kB · 0 downloads VeraHomeAutomation.xml 271 B · 1 download

 

Looks like the way you access ports has changed after some Vera FW release. This request works with my Vera FW:

http://192.168.11.224/port_3480/data_request?id=sdata

Share this post


Link to post
Share on other sites
chef
4 hours ago, gmontem said:

I installed Emby Server onto a new Windows server. I then installed the Vera plugin. After restarting the Emby Server, the Emby Server crashed.

It looks like the Vera plugin is making a request to my VeraSecure's port 3480 which is probably closed. My browser receives a connection reset error when I try to navigate to http://192.168.11.224:3480/data_request?id=sdata. Is there something I need to setup from my Vera's web frontend to get this work? I tried re-installing the "Emby Interface" app for Vera, but that didn't help.

I attached the server log and the Vera plugin's XML file.

embyserver.txt 19.29 kB · 0 downloads VeraHomeAutomation.xml 271 B · 1 download

@gmontem 

Did you manually change the port and url settings for your Vera in the dashboard?

EDIT: There are some setting in your Vera to enable secure connection.

I'll do some testing and see if I can fix this.

 

Edited by chef

Share this post


Link to post
Share on other sites
chef

@gmontem

 

Would you try un-checking this setting in your vera dashboard and tell me if the issue goes away.

 

 

veraexample.png

Share this post


Link to post
Share on other sites
gmontem
6 hours ago, chef said:

@gmontem

 

Would you try un-checking this setting in your vera dashboard and tell me if the issue goes away.

 

 

veraexample.png

 

Unchecking the setting seems to work!

 

Web browser navigating to 

http://192.168.11.224:3480/data_request?id=sdata

gives me JSON data.

 

It turns out this address still works regardless of security setting:

http://192.168.11.224/port_3480/data_request?id=sdata

Something to consider in case the Vera guys decide to close ports in a future FW update.

 

But most important, your Vera plugin works!

image.thumb.png.db1f990e2ea8dbb33cf2a33075ab61be.png

Although I have a Vera Secure model and not the Vera Plus.

I will try to turn on my HTPC and run MB Theater so it'll show up as a network device. If you don't hear from me, you can assume my problems are gone.

Thanks!

 

 

  • Like 1

Share this post


Link to post
Share on other sites
chef
1 hour ago, gmontem said:

 

Unchecking the setting seems to work!

 

Web browser navigating to 


http://192.168.11.224:3480/data_request?id=sdata

gives me JSON data.

 

It turns out this address still works regardless of security setting:


http://192.168.11.224/port_3480/data_request?id=sdata

Something to consider in case the Vera guys decide to close ports in a future FW update.

 

But most important, your Vera plugin works!

image.thumb.png.db1f990e2ea8dbb33cf2a33075ab61be.png

Although I have a Vera Secure model and not the Vera Plus.

I will try to turn on my HTPC and run MB Theater so it'll show up as a network device. If you don't hear from me, you can assume my problems are gone.

Thanks!

 

 

Is there a way to give me the device type serial for a Vera secure? I was collecting device types and coding them into a list inside the plugin.

I hadn't met anyone with a secure version, so this is why it says "plus".

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...