Jump to content

CANNOT Download & Install Application


Bach Patu
 Share

Recommended Posts

Bach Patu

Every time I click on the setup file (Which BTW is only 418K), I get this error (See screenshot)

 

IS THERE A SERVER DOWN ??  Me thinks so.....

 

BP

post-34286-0-42445200-1426899256_thumb.jpg

Link to comment
Share on other sites

Bach Patu

Have you tried UPGRADING YOUR INSTALLER ??

 

I'm NOT a techie here & am not inclined to start entering stuff into a command prompt to solve issues that can be easily solved on YOUR end by using a PROPERLY CONFIGURED installer

 

I should also add I have Firefox set to send ALL downloads to the Desktop unless I specify otherwise.  I've downloaded FOUR instances of setup.exe to the Desktop but have yet to see ANY of them on the Desktop (Firefox DOES show them in downloads though).  I have to click on those in order to open it because THERE ARE NO ICONS saying setup on the Desktop itself to click on

 

I have never had this problem with anything else OR with the browser (And my Anti-Virus software will let me know if it has to remove anything from the Deskrtop due to malware - But that is extremely extremely rare (READ - It HAS NEVER happened before) )

 

Somehow I seriously doubt using a different browser will solve the issue

 

BP

Link to comment
Share on other sites

We are using Microsoft's ClickOnce technology and, unfortunately, it does have problems sometimes.  The procedure I referenced is widely posted on the internet as a solution to these problems and it has helped the few other people in a similar situation.  Whether or not it will solve your issue I can't be sure but it is definitely the first thing to try in these instances.

Link to comment
Share on other sites

CBers

This happens with BOTH the Beta AND Stable releases

 

BP

I just downloaded both the Beta and Official Release without issue. I'm in the UK.

 

Could have been a glitch somewhere between you and the download server at the time.

 

Please try again and report back what happens.

 

.

Edited by CBers
Link to comment
Share on other sites

Hello!

Cannot download server software today. All attempts were failed. internet connection is ok (10Mbit). new win7 64bit system (fully installed today). The same problem with other PC (32bit W7. No way... neither Release nor beta version.  Progress bar shows about 5-10%

550edf1831897_1.jpg

 

and after I'm getting the message

 

550edf32e012a_2.jpg

 

Please help to fix the problem or give a solution advise.

BR.

Stan

Link to comment
Share on other sites

That is a network issue of some sort.  I don't see any issues on our end or with our CDN so it may be something with your local ISP...

Link to comment
Share on other sites

CBers

That is a network issue of some sort. I don't see any issues on our end or with our CDN so it may be something with your local ISP...

Still working OK here in the UK.

Link to comment
Share on other sites

  • 3 weeks later...
AlmasKabir

I am having similar problem while trying to install Emby Theater! The Setup file downloads fine, but when it downloads the package, it stops in the middle and displays:

 

Error Downloading Package

 

System.Net.WebException

An exception occurred during a WebClient request.

 

What is happening?!? Please help!!

Link to comment
Share on other sites

  • 4 months later...
notCharlie

Just created an account today to answer this.

 

If you have a fresh install of Windows, please make sure that Windows updates are up to date.

 

 

I don't know which one allowed me to download the emby software, but one of them did.

 

I had tried to download it many times without success prior to doing this.

 

I had already cleared the online app cache without success.

 

The exact error I had was:

 

Error Downloading package.There may be a problem communicating with

the update server. Please try again.

 

System.nullReferenceException

Object reference no set to an instance of an object

 

 

I tried the download on another PC in my house and it was successful.

The first thing I tried was clearing the online app cache - no success.

Tried a different browser - no success

The next thing I tried, was to match the Microsoft Visual C++ installations for the PC that couldn't download, with the PC that did download.

This changed nothing, even after a reboot.

 

I purposely checked for any Windows Updates after this. I had about 30 to install. I just let them all install, then rebooted, then I was able to download the emby software successfully.

 

If this proves to be a fix, then emby support should be supplying the client with a software requirements list. I can't seem to find one for emby.

 

I don't plan on rolling back each individually to find which one is the cause, but if emby support want to be aware of this, I can provide a screenshot of the updates that did install.

Link to comment
Share on other sites

Windows updates are constantly changing.  Making sure you have all current patches should be something we always suggest.

Link to comment
Share on other sites

  • 11 months later...
djsecrist

There has to be a better way...  I am constantly getting this same error.  I have cleared the cache many times, installed all Windows updates, and retried about 50 times.  With Emby Theater and the previous release, eventually the install worked.  I shouldn't have to try 100 times before it finally works though.  Are the servers that overloaded with the new release???

Link to comment
Share on other sites

djsecrist

It is the same error as notCharlie had previously.

 

The exact error I had was:

 

Error Downloading package.There may be a problem communicating with

the update server. Please try again.

 

System.nullReferenceException

Object reference no set to an instance of an object

 

 

I kept trying every minute and it eventually worked after about the 75th time.  There really needs to be a better way of handling this error.  I suspect it has something to do with the server being overloaded.  I didn't do anything on my side; just kept trying the setup program again and again and again...

Link to comment
Share on other sites

Ok, thanks for the info. It's actually hosted with github so that's surprising to hear. We could add a retry button though, definitely.

Link to comment
Share on other sites

  • 3 weeks later...
djsecrist

I'm still getting this error constantly...  Is there any way that I can get more details, like a log message to post?  This is SO frustrating!

 

57a89bf347e24_error.png

Link to comment
Share on other sites

I'm still getting this error constantly...  Is there any way that I can get more details, like a log message to post?  This is SO frustrating!

 

57a89bf347e24_error.png

 

it is just a failure to download the server install package. I would try it again. Thanks.

Link to comment
Share on other sites

djsecrist

I have tried again... And again... And again... And again... It usually decides to work after 50+ tries, 25+ times clearing the cache, 5+ reboots, and a couple of times making sure all Windows updates have been applied. This is on Windows Server 2012 Essentials R2. If there were a way to enable debug logging and get more information on the failure, I would LOVE to try that.

Link to comment
Share on other sites

I have tried again... And again... And again... And again... It usually decides to work after 50+ tries, 25+ times clearing the cache, 5+ reboots, and a couple of times making sure all Windows updates have been applied. This is on Windows Server 2012 Essentials R2. If there were a way to enable debug logging and get more information on the failure, I would LOVE to try that.

 

I think it is just a download failure, which is strange because the files are coming from github. Install logs are available at

%appdata%\Emby-InstallLogs

Another option is you can just do the portable windows installation:

 

http://emby.media/windows-server.html

Link to comment
Share on other sites

djsecrist

Thanks for the log location. Looks like I am getting a 403 error. Strange... https???

 

 

MediaBrowser.Server.Installer.exe Information: 0 : Request: {"Operation":"Install","Product":"server","PackageClass":"Release","Version":{"Major":4,"Minor":0,"Build":-1,"Revision":-1,"MajorRevision":-1,"MinorRevision":-1},"ServiceName":""}

MediaBrowser.Server.Installer.exe Information: 0 : Creating install session for server

MediaBrowser.Server.Installer.exe Information: 0 : Installing Emby Server

MediaBrowser.Server.Installer.exe Information: 0 : Attempting to retrieve latest version of MBServer

MediaBrowser.Server.Installer.exe Information: 0 : Getting github releases for MediaBrowser Emby minVersion: 1.0.0 level: Release

MediaBrowser.Server.Installer.exe Information: 0 : Github url: https://api.github.com/repos/MediaBrowser/Emby/releases?v=636063034190911948

MediaBrowser.Server.Installer.exe Information: 0 : Error getting package version: The remote server returned an error: (403) Forbidden.

MediaBrowser.Server.Installer.exe Information: 0 : Version is 3.0

MediaBrowser.Server.Installer.exe Information: 0 : Downloading Emby Server version 3.0

MediaBrowser.Server.Installer.exe Error: 0 : Error downloading. Installation aborting. Object reference not set to an instance of an object.

Link to comment
Share on other sites

I believe the github api returning a 403 means you've reached their api usage limit, which seems unlikely but i suppose is possible if you've been trying over and over. what i would do is either wait and try again tomorrow, or use the portable install mentioned above.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...