Jump to content

MB3's Fetchers do not identify "St. Vincent (2014)"


ginjaninja
 Share

Go to solution Solved by ebr,

Recommended Posts

ginjaninja

Version 3.0.5509.223

 

This Film with this folder name is not identified..

A local .nfo has localtitle tag populated as St. Vincent (2014)

Further use of identify function, without manual changes, does not detect.

 

The Following Work as manual ammedments within the identify function...

St. Vincent - without the year

St Vincent (2014) - without the full stop

St. Vincent 2014 - without the year in brackets

 

%Movietitle% (%Year%) ...has always been a good way to get 100% detection...so is this a bug/an opportunity to improve? or am i out of step with naming convention and need to change...?

 

I have OMDB First and TMDB second as metadate fetchers...

 

edit

noted server version

Edited by ginjaninja
Link to comment
Share on other sites

Latchmor

Hi, not sure what version of server you are on but I can confirm the dev server is doing this too.

Cheers

Link to comment
Share on other sites

ginjaninja

Hi, not sure what version of server you are on but I can confirm the dev server is doing this too.

Cheers

thnks for reproducing..yes i am on dev build

Link to comment
Share on other sites

CBers

Works here OK.

 

Use themoviedb ID of 239563 in MEDIA BROWSER.

 

I also used IMDB ID of tt2170593.

Link to comment
Share on other sites

ginjaninja

Works here OK.

 

Use themoviedb ID of 239563 in MEDIA BROWSER.

 

I also used IMDB ID of tt2170593.

yup for aadvanced users they can force a recognition..but if the casual user is king..the automatic fetch is where the problem is..

Link to comment
Share on other sites

CBers

It auto fetched for me few days ago (running dev)

It did for me as well, also running dev, but wanted to re-fetch which was why I used the IDENTIFY option.

Link to comment
Share on other sites

ginjaninja

for those that it auto fetched for

are you using a folder\file structure of \\SERVER\Share\St. Vincent (2014)\St. Vincent (2014).mkv or some thing else

 

what is your metadata order for movies?

 

is the identify function working..

 

it seems unlikely ...like for like its not working for me but working for you...there must be a difference and were not comparing like for like.

 

edit..

i think the identify routine must be slightly different for the identify routing post successful  identification..or a server update has affected.

once identified....

St. Vincent (2014)

identified ok when using identify function a 2nd time...

 

edit

 

a freshly created

\\SERVER\Share\St. Vincent (2014)\St. Vincent (2014).mkv

is auto fetched ok for me today.....maybe the primary fetchers was offline and the other has an issue...who knows....its working today..

Edited by ginjaninja
Link to comment
Share on other sites

CBers

We're there any errors in the MBS log when you first added the movie.

 

My structure is the same as your's.

 

I don't use nfo files.

 

My metadata fetchers are tmdb then the open movie database.

 

Same for image fetchers.

Link to comment
Share on other sites

ginjaninja

We're there any errors in the MBS log when you first added the movie.

 

My structure is the same as your's.

 

I don't use nfo files.

 

My metadata fetchers are tmdb then the open movie database.

 

Same for image fetchers.

wasnt looking out on first ingestion..so no logs

thanks for confirming your settings..

i have omdb first then tmdb..

 

wonder what latchmoor finds..?

@@Latchmor

Edited by ginjaninja
Link to comment
Share on other sites

Is it possible that, when it was first added, a stub nfo file came over with it?  That would stop us from even trying to fetch metadata.

Link to comment
Share on other sites

Latchmor

Hi Guys,

 

Yesterday my log showed this,
2015-01-31 16:57:23.8246 Info - App: HttpClientManager GET: http://api.themoviedb.org/3/search/movie?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=St++Vincent+(2014)&language=en
2015-01-31 16:57:23.9636 Debug - App: MovieDbProvider returned no metadata for \\ED-WORK\F\Test\Films\St. Vincent (2014)\St. Vincent (2014).mkv
2015-01-31 16:57:23.9636 Debug - App: Running OmdbItemProvider for \\ED-WORK\F\Test\Films\St. Vincent (2014)\St. Vincent (2014).mkv
2015-01-31 16:57:23.9726 Info - App: MovieDbProvider: Finding id for item: St. Vincent (2014)
2015-01-31 16:57:23.9726 Info - App: HttpClientManager GET: http://api.themoviedb.org/3/search/movie?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=St.+Vincent+(2014)&language=en
2015-01-31 16:57:24.1076 Info - App: HttpClientManager GET: http://api.themoviedb.org/3/search/movie?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=St++Vincent+(2014)&language=en
2015-01-31 16:57:24.2496 Debug - App: OmdbItemProvider returned no metadata for \\ED-WORK\F\Test\Films\St. Vincent (2014)\St. Vincent (2014).mkv
Nothing else appeared in the folder. Identify also found nothing unless I removed full stop. I left it blank (as it was a dummy movie anyway) to see if subsequent scans would find it.
 
Still no metadata today but now, after seeing this thread again, if I go to Identify it finds it without removing full stop so not sure what changed.
 
Cheers
  • Like 1
Link to comment
Share on other sites

  • Solution

Probably, this was just a search issue on the provider end and they fixed it while we were trying to figure it out.

  • Like 1
Link to comment
Share on other sites

Latchmor

Probably, this was just a search issue on the provider end and they fixed it while we were trying to figure it out.

 

I'm guessing you are correct. I just added a dummy St. Trinians (2007).mkv as another full stop test and the first scan found everything as normal  ;)

Edited by Latchmor
Link to comment
Share on other sites

CBers

I'm guessing you are correct. I just added a dummy St. Trinians (2007).mkv as another full stop test and the first scan found everything as normal  ;)

You mean you haven't already got that in your collection?

  • Like 1
Link to comment
Share on other sites

Latchmor

They are, but they don't have a young Gemma Arterton in them ;)

 

True. I'm glad you mentioned that and didn't pick on my age instead...

  • Like 1
Link to comment
Share on other sites

CBers

True. I'm glad you mentioned that and didn't pick on my age instead...

I wouldn't, as I'm older than you :)

 

.

Edited by CBers
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...