Jump to content

Roku client wake on LAN (WOL) issues


clm000
 Share

Recommended Posts

Hi,

Thanks for the great Roku client and MB3 in general.  I'm having an issue with WOL and the Roku client and have a few questions.

1) Is WOL coded into the Roku client (I'm using v 1.78 now)?  I read conflicting statements about WOL support in the Roku client in other forum posts

2) If it is, what should I see in the logs generated by the client relative to WOL?

3) WOL works using Media Browser Theater (MBT) running on a laptop waking the MB3 server running as service on a desktop on the same LAN.  WOL also works from many other apps and scripts I use all the time, so I'm sure the MB3 server is capable and configured correctly to wake from a WOL magic packet.

4) I assume your sending a magic packet for WOL, is that correct? As opposed to ping or some other "pattern match" packet

5) Am I missing some configuration step to get WOL working?

 

I have sideloaded the app to generate logs and an example of the issue is below (I don't see anything relative to WOL in the log):

------ Running ------

--1.78

Anamorphic support: true

Server.info: listening on 0.0.0.0:8324

Using broadcast address 10.68.68.255

Send To Address: 10.68.68.255:7359 / 10.68.68.255:7359

Cancel UDP Broadcast

Found 0 servers

Connect returned 0 servers

Creating server data cache

Found string in the registry: {"a1d90fbe6f7400e5d7663049cd848bd0":{"AccessToken":"bba7f6b930b74a3986875b76ec6a4aa8","UserId":"0130cfdac20bb8c7147cfed6ffaf0e39","RemoteAddress":"http://xxx.yyyy.com:8096","LastAccess":"1421039815","Name":"PC-C","LocalAddress":"http://10.68.68.34:8096","id":"a1d90fbe6f7400e5d7663049cd848bd0"}}

Parsed as: roAssociativeArray

connectionManagerGetServers returning 1 servers

connectToServers called with 1 servers

Attempting to connect to http://10.68.68.34:8096/mediabrowser/system/info/public?format=json

Failed Response with Error: -7

Failed to get Server Info

Attempting to connect to http://xxx.yyyy.com:8096/mediabrowser/system/info/public?format=json

Failed Response with Error: -7

Failed to get Server Info

connectInitial returned State of ConnectSignIn

connectInitial returned ConnectionMode of Manual

Processing ConnectionResult State of ConnectSignIn

Entered CreateScreenForItem

Not sure what to do with breadcrumbs on screen type: roCodeRegistrationScreen

Pushing screen 1 onto view controller stack - ConnectSignIn

Sending pin poll request to https://connect.mediabrowser.tv/service/pin?pin=73098&deviceId=1GU451103739

Poll result: {"Id":"51108","Pin":"73098","DeviceId":"1GU451103739","IsExpired":false,"IsConfirmed":false,"AccessToken":""}

Sending pin poll request to https://connect.mediabrowser.tv/service/pin?pin=73098&deviceId=1GU451103739

Poll result: {"Id":"51108","Pin":"73098","DeviceId":"1GU451103739","IsExpired":false,"IsConfirmed":false,"AccessToken":""}

Sending pin poll request to https://connect.mediabrowser.tv/service/pin?pin=73098&deviceId=1GU451103739

Poll result: {"Id":"51108","Pin":"73098","DeviceId":"1GU451103739","IsExpired":false,"IsConfirmed":false,"AccessToken":""}

 

Link to comment
Share on other sites

After you connect once it will record the servers Mac address. Try connecting over then exit the app, shut down mbs and try to connect. When the local connection fails it should wol then try again

Link to comment
Share on other sites

I have connected to the server multiple times in the past, yet it still will not wake it from sleeping.  Should I be able to see anything in the log above?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...