Jump to content
Marc_G

ANSWERED MBC messing up frame step in MPC-HC?

Recommended Posts

Marc_G

Hi folks,

 

I've noticed something odd, that has repeated a few times, but I'm not sure I can completely reproduce it.

 

I've used MPC-HC (currently the latest release, 1.70 something...) quite a bit, and I've got it freshly installed on my new Win7x64 system. One of the things I like to do with it is go frame by frame through movie action sequences and the like and see neat stuff in each still that you can't see properly when the movie is playing.

 

Anyway, I recently added MPC-HC as an official external player in MBC. I assigned it in the configurator and let it do some configurations (which messed up my key assignments, but that's another minor story).

 

About a day after doing the setup in MPC-configurator, I noticed that anytime I frame stepped a sequence, it wasn't smooth. It looked like it was doing short seeks instead of one frame after another. Kinda messed up. I've got a defined key that I assigned to do frame stepping (right arrow, and I've made sure nothing else is defined as right arrow that would interfere).

 

I reinstalled MPC-HC and the problem went away.

 

I re-configured MPC-HC through the configurator, and eventually the problem came back. I just noticed it now. I think it didn't come back until the next time I started MBC, or maybe did an upgrade (tonight).

 

I never had this problem before running the MBC Configurator... what exactly is it doing, and how might it be interfering with frame step to make it not do nice even frame by frame steps but instead jerky seeks?

 

Thanks for any light that can be shed on this.

 

Marc

Share this post


Link to post
Share on other sites
Marc_G

I've discovered this has nothing to do with MB.

 

Basically, configuring the LAV audio decoder properties to enable SPDIF bitstreaming of AC-3 seems to cause the problem to start. Disabling AC-3 in there makes the problem go away, but then I'm just outputting stereo PCM over SPDIF.  I'll dig into the issue over on the Doom9 forum or other places and see if I can find a resolution. I'll report it back, eventually, to help anyone else who sees it.

 

Sorry for implicating MB in this. My order of operations in configuring things had the MB configurator setup and the Audio properties closely paired. My bad!

 

Marc

  • Like 2

Share this post


Link to post
Share on other sites
mboehler

I've discovered this has nothing to do with MB.

 

Basically, configuring the LAV audio decoder properties to enable SPDIF bitstreaming of AC-3 seems to cause the problem to start. Disabling AC-3 in there makes the problem go away, but then I'm just outputting stereo PCM over SPDIF.  I'll dig into the issue over on the Doom9 forum or other places and see if I can find a resolution. I'll report it back, eventually, to help anyone else who sees it.

 

Sorry for implicating MB in this. My order of operations in configuring things had the MB configurator setup and the Audio properties closely paired. My bad!

 

Marc

 

I am having this problem as well.  If I have AC3 checked in LAV, some files refuse to play in WMC.  They WILL play in Windows Media Player though, which is strange.  If I disable AC3, it will play, but I have to crank up the stereo in order to hear it properly.

 

I'll be heading over to http://www.thehtpc.net to see if I can find out what's up with this and how to fix it.  If you figure anything out, would you please let me know?  I will do the same for you.

Thanks!

Share this post


Link to post
Share on other sites
ebr

WMP and WMC use different codecs.  Especially if you are on a x64 OS.

Share this post


Link to post
Share on other sites
mboehler

I am having this problem as well.  If I have AC3 checked in LAV, some files refuse to play in WMC.  They WILL play in Windows Media Player though, which is strange.  If I disable AC3, it will play, but I have to crank up the stereo in order to hear it properly.

 

I'll be heading over to http://www.thehtpc.net to see if I can find out what's up with this and how to fix it.  If you figure anything out, would you please let me know?  I will do the same for you.

Thanks!

 

I started a new thread on this here.

Share this post


Link to post
Share on other sites
Marc_G

I'm at work now but I will provide a link to wherein have initiated a discussion on Doom9. I will definitely share progress! And thanks for starting a parallel thread re: your specific case which I think is closely paired to mine.

Note that with AC-3 unchecked, LAV is probably downconverting to 2 channel PCM and sending that to your AVR when you play AC-3 (DD) content. On mine, not only does this remove surround sound, it gets really quiet.  just like what you get!

Marc

  • Like 1

Share this post


Link to post
Share on other sites
Marc_G

All, as a more or less final resolution of this, it turns out the problem is in the MPC-HC "EVR-CP" renderer. Switching to Sync renderer clears it up. I've got a ticket on the issue at the MPC-HC tracker. They are hopeful to fix it, but it's not a big deal right now since the Sync renderer supports similar functionality to EVR Custom Presenter.

 

https://trac.mpc-hc.org/ticket/3688#

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...