Jump to content

MBClassic slow loading no more!


porkbone
 Share

Recommended Posts

porkbone

Hi, everyone

 

Been reading the forum a lot lately looking for a fix for my Win7 desktops in the house running MBC that are not on the server box. The MBC on my server has been running fine-ish. A little laggy, but usable. The ones not on the server have been very slow to load, crashing at first back to WMC, or unable to load at all. Sometimes messing up the artwork for categories (TV's RAL would show movies) - frustrating to say the least.

First tried clearing the ARP Cache & flushing the DNS, but that didn't help. So I deleted all plugins except Chocolate, but did delete it's configs in ProgramData & in AppData-Roaming. I then deleted the Image Cache as well giving me a fresh install so to speak. I then went through the config and adding one setting change at a time, then backing out of MBC to WMC and restarting Classic. It took a while to nail down, but I found that in the first General tab, putting a check in the "Default to first unplayed item" was the culprit.

Now MBC loads after 2 to 3 dots and the RAL loads very quick and no more crashing!!

 

Granted - this could be only related to my setup, but if you are seeing something similar, give it a try! :)

 

 

  • Like 1
Link to comment
Share on other sites

Did you check or uncheck "Default to first unplayed item"? Lately my MBC (Xenon theme) has been extremely slow (sometimes it takes more than a minute to go to a new view or start playing something) and I also noticed that MBC no longer defaults to the first unplayed item even though I have this checked in the config.
I will try to uncheck this tonight and see if it improves the loading times!

Link to comment
Share on other sites

porkbone

Unchecked. I haven't had the time to check this with Xenon yet, but plan to start adding plugins again today.

Let us know how that worked out.

Link to comment
Share on other sites

AdrianW

There's no way I could turn "Default to first unplayed item" off - that functionality is one of the most important for usability, I'd hate to have to scroll to the correct season and then the correct episode every time I want to watch something.

 

-edit-

I just tried that setting both on and off, and it makes no difference to the loading speed for me.

Edited by AdrianW
Link to comment
Share on other sites

porkbone

AdrianW, did you close classic and then restart it after changing the setting? Wondering if it was a combination of everything I did like deleting all the plugins and deleting the image cache.

 

I just switched user accounts (I have three) to see how it would work. Some categories loaded very fast, and some looked like they loaded only to say No Items or show the items but selecting would then show No Item.

 

Starting to think that there is a communication problem between Classic and the Server. The Default to first unplayed item might just be another symptom. I'll post some logs later that maybe @@ebr can take a peek at, but that will have to wait till tomorrow.

Link to comment
Share on other sites

AdrianW

AdrianW, did you close classic and then restart it after changing the setting? Wondering if it was a combination of everything I did like deleting all the plugins and deleting the image cache.

 

 

Yes - that's how I was determining the loading speed. 

Link to comment
Share on other sites

porkbone

Well. Turns out I had a bad C drive with about 15 bad sectors and over a thousand communication errors. I tested this hard drive 4 months ago when I built this new system and it was perfect. oh well...

 

Swapped out HD and reloaded Win7 yadda yadda yadda and classic runs fast with the only issue still being Music. I'm going to start a new post for the Music issue.

 

Just to clarify, the bad HD was on a separate computer and not on the server. The steps I did above worked for my setup since the other two boxes running Classic are also running fast again. Wish it could have helped someone else  :mellow:

 

edit - just in case you want to try the whole routine:

open cmd as admin

type arp -d

then

ipconfig /flushdns

close the cmd window and delete everything I listed in the first post. I even did this on the server box that runs classic (stop the server first) and start fresh

I have since reloaded all the previous installed plugins and everything is still fast (except Music)

Edited by porkbone
Link to comment
Share on other sites

Sorry for the late reply but I have been quite busy last week and didn't have much time to test this.
I tried checking and unchecking "Default to first unplayed item" but didn't notice any difference.
However I also noticed the laptop has overall become very slow.
I didn't notice this before because it's an old laptop I only use for MBC.

Before pointing fingers to MBC I decided to go for a long overdue clean install and upgrade the laptop to Windows 8.1.

I will let you know what the performance is when the system is fully set up.
Right now I'm having a bit of a problem with Windows activation.
I used a free Media Center Pack key I got when from Microsoft when Windows 8 was just out but since updating to Windows 8.1 with Media Center Windows can no longer activate...
In the meantime I will also try to do some tests on the htpc in the living room although the server is on the main pc so that's not entirely representative I think.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...