Jump to content

Video playback stuttering in certain transcoding settings


Riezel
 Share

Go to solution Solved by Riezel,

Recommended Posts

My current spec :
Server : Synology DS920+, Emby-server 4.7.6.0 (non docker)
Player : iPad Pro 2021 M1, latest version on appstore (2.2.5) | Realme 7pro, latest version on playstore (3.2.62)


as the title says, it seems the iOS player stuttering while playing the 1080p 5mbps ~ 10mbps mode, i attached my ipad recording for the proof, also sorry for big files ._.
it was perfectly fine on android player tho

embyserver.txt

Link to comment
Share on other sites

Rather than making new thread, i'll just post it in here, 

is there any way to handle this kind of meta data? Show more button perhaps?

* this happens in any client platform (web, android, ios, pc)

 

038540C8-0EE4-400F-9A3E-37D977313A62.png

A21A94CD-3AAF-4690-9DF5-BDF422702C2F.png

Link to comment
Share on other sites

5 hours ago, Riezel said:

Rather than making new thread, i'll just post it in here, 

is there any way to handle this kind of meta data? Show more button perhaps?

* this happens in any client platform (web, android, ios, pc)

 

038540C8-0EE4-400F-9A3E-37D977313A62.png

A21A94CD-3AAF-4690-9DF5-BDF422702C2F.png

You've got all that stuffed into the title ?

Link to comment
Share on other sites

2 hours ago, Luke said:

You've got all that stuffed into the title ?

Nope, i think its from the meta data fetch, the original ones is looks like this

 

79ABA112-E5FF-4AC9-8CC3-62B1274E5257.png

Link to comment
Share on other sites

Just now, Luke said:

Yea but it looks like you do have it all in the title, no?

I think yes, its auto filled from meta data either from anilist / myanimelist 😅

is there a way to make it elipsis (xxxxx.....) when the title is reach certain treeshold, than overide them manual one by one? 🫠

Link to comment
Share on other sites

Yea I guess there will have to be some kind of sanity check there, because that value is certainly not sane.

Link to comment
Share on other sites

2 minutes ago, Luke said:

Yea I guess there will have to be some kind of sanity check there, because that value is certainly not sane.

I suggest, make them elipsis when its reach 100% of width the device (or over 100%) so it should be keep in 1 line 😅

also luke, how the progress of investigation of this original post? (Video playback) found the cause of it?

Link to comment
Share on other sites

  • 1 month later...
  • Solution
4 minutes ago, Luke said:

@Riezel are you still seeing the stuttering with Emby Server 4.7.8?

i think it's fixed now, although i got another bug.. like for example getting this after full scan the library, and idk if this emby fault or trakt plugins, 

 

wsl_opP7rdHXJ5.png

Link to comment
Share on other sites

That has nothing to do with Trakt. Please attach the complete emby server log. Thanks.

Link to comment
Share on other sites

6 minutes ago, Luke said:

That has nothing to do with Trakt. Please attach the complete emby server log. Thanks.

i already attached the emby server log in that post (for that double scrobble) as for the error watch directory i'll produce it first and attached it in here later

Link to comment
Share on other sites

Just now, Riezel said:

i already attached the emby server log in that post (for that double scrobble) as for the error watch directory i'll produce it first and attached it in here later

This is your issue:

2022-10-08 13:42:39.808 Error LibraryMonitor: Error watching path: /volume1/media/Movies/Box Office Movies
	*** Error Report ***
	Version: 4.7.8.0
	Command line: /volume1/@appstore/EmbyServer/system/EmbyServer.dll -programdata /var/packages/EmbyServer/var -ffdetect /var/packages/EmbyServer/target/bin/ffdetect -ffmpeg /var/packages/EmbyServer/target/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/bin/ffprobe -nolocalportconfig -ignore_vaapi_enabled_flag -pidfile /var/packages/EmbyServer/var/EmbyServer.pid -defaultdirectory /volume1/Public -updatepackage emby-server-synology7_{version}_x86_64.spk -noautorunwebapp
	Operating system: Linux version 4.4.180+ (root@build2) (gcc version 8.5.0 (GCC) ) #42661 SMP Mon Jun 27 15:07:20 CST 2022
	Framework: .NET 6.0.8
	OS/Process: x64/x64
	Runtime: volume1/@appstore/EmbyServer/system/System.Private.CoreLib.dll
	Processor count: 3
	Data path: /var/packages/EmbyServer/var
	Application path: /volume1/@appstore/EmbyServer/system
	System.IO.IOException: System.IO.IOException: The configured user limit (128) on the number of inotify instances has been reached, or the per-process limit on the number of open file descriptors has been reached.
	   at System.IO.FileSystemWatcher.StartRaisingEvents()
	   at System.IO.FileSystemWatcher.StartRaisingEventsIfNotDisposed()
	   at System.IO.FileSystemWatcher.set_EnableRaisingEvents(Boolean value)
	   at Emby.Server.Implementations.IO.LibraryMonitor.<>c__DisplayClass37_0.<StartWatchingPath>b__0()
	Source: System.IO.FileSystem.Watcher
	TargetSite: Void StartRaisingEvents()

I think @FrostByte will have some tips on this for Synology. Thanks.

Link to comment
Share on other sites

2 minutes ago, Luke said:

This is your issue:

2022-10-08 13:42:39.808 Error LibraryMonitor: Error watching path: /volume1/media/Movies/Box Office Movies
	*** Error Report ***
	Version: 4.7.8.0
	Command line: /volume1/@appstore/EmbyServer/system/EmbyServer.dll -programdata /var/packages/EmbyServer/var -ffdetect /var/packages/EmbyServer/target/bin/ffdetect -ffmpeg /var/packages/EmbyServer/target/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/bin/ffprobe -nolocalportconfig -ignore_vaapi_enabled_flag -pidfile /var/packages/EmbyServer/var/EmbyServer.pid -defaultdirectory /volume1/Public -updatepackage emby-server-synology7_{version}_x86_64.spk -noautorunwebapp
	Operating system: Linux version 4.4.180+ (root@build2) (gcc version 8.5.0 (GCC) ) #42661 SMP Mon Jun 27 15:07:20 CST 2022
	Framework: .NET 6.0.8
	OS/Process: x64/x64
	Runtime: volume1/@appstore/EmbyServer/system/System.Private.CoreLib.dll
	Processor count: 3
	Data path: /var/packages/EmbyServer/var
	Application path: /volume1/@appstore/EmbyServer/system
	System.IO.IOException: System.IO.IOException: The configured user limit (128) on the number of inotify instances has been reached, or the per-process limit on the number of open file descriptors has been reached.
	   at System.IO.FileSystemWatcher.StartRaisingEvents()
	   at System.IO.FileSystemWatcher.StartRaisingEventsIfNotDisposed()
	   at System.IO.FileSystemWatcher.set_EnableRaisingEvents(Boolean value)
	   at Emby.Server.Implementations.IO.LibraryMonitor.<>c__DisplayClass37_0.<StartWatchingPath>b__0()
	Source: System.IO.FileSystem.Watcher
	TargetSite: Void StartRaisingEvents()

I think @FrostByte will have some tips on this for Synology. Thanks.

ah yes, this is the issue, i'll wait for the advice then

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...