Jump to content

DLNA server is not found


MrMackey
 Share

Recommended Posts

MrMackey

Hey,

I am using Emby in Unraid as Docker. I run Emby in a subnet 172.18.x.x to make it reachable from outside via reverse proxy.

My other devices TV, AVR ... are in my normal ip address range 192.168.x.x

Unfortunately my devices do not find the Emby DLNA Server when I run the Docker in the subnet.

Is there a way to force the DLNA Server to be found in the 192.168.x.x address range?

Link to comment
Share on other sites

Hi, have you enabled the Dlna Server in Dlna settings?

Link to comment
Share on other sites

MrMackey

Yes, it works when I use the emby server in the 192.168.x.x address range.
But not when I run Emby in the 172.18.x.x. subnet.
Therefore my question if it is possible to force the DLNA server to transmit in the 192.168.x.x. address range?

Link to comment
Share on other sites

Happy2Play

@MrMackey Can you post a server log after a restart to show network detection.

  • Agree 1
Link to comment
Share on other sites

Happy2Play

@Luke would adding both networks to LAN Networks help here?

2022-07-11 08:29:27.457 Info NetworkManager: networkInterface: Ethernet eth0, Speed: 10000000000, Description: eth0
2022-07-11 08:29:27.458 Info NetworkManager: GatewayAddresses: 172.18.0.1
2022-07-11 08:29:27.459 Info NetworkManager: UnicastAddresses: 172.18.0.3

 

  • Like 1
Link to comment
Share on other sites

It would be the bind to address field, but the UI doesn't let you enter mulitple, so you'd have to do it via the server config file.

However I think it would be better to leave it alone and look at the configuration of the Docker container so that hopefully it will just work automatically in Emby Server.

Are you using host networking mode?

Link to comment
Share on other sites

MrMackey

@Luke No, I use a kind of bridge mode.
In host mode the DLNA server is found immediately, but this is unfortunately not an option for me because I run the reverse proxy in the subnet.

4 hours ago, Luke said:

the UI doesn't let you enter mulitple, so you'd have to do it via the server config file.

Could you please tell me how to set this?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...