Jump to content

MKV with TrueHD audio not playing on LG B6


MarkCranness
 Share

Recommended Posts

MarkCranness
Posted (edited)

I have a UHD 2160P MKV file with TrueHD audio that is not playing on an LG OLED B6 (2016).

Behaviour is that the TV screen goes black, while the server dashboard shows transcoding of TrueHD into AC3.

Server dashboard shows playing 0 seconds, up thru 8 seconds (in 2 second increments), then repeats again from 0 to 8 and repeats same in a loop.
TV only ever shows black screen (spinning wait?)

WebOS 3.4.0-5709 (dreadlocks-digya)
Emby App 1.0.35
Emby Server version: 4.7.1.0

Logs attached.

If I disable transcoding the file will not play on the LG, with error message something like (sorry) "Can't find compatible streams"

The MKV contains both TrueHD and also AC3.
If I remux the file (mkvtoolnix-gui.exe) to remove the TrueHD stream (leaving only the AC3 audio stream), it plays fine on the LG.

(Edit: Emby app on LG does not show multiple audio streams, and no way to manually choose the AC3 stream prior to playback.)

ffmpeg-remux-636829c9-2520-4df1-acfb-60c1182f5afb_1.txt

Edited by MarkCranness
Extra info
Link to comment
Share on other sites

Hi, that's interesting. I think it's trying to play in a way that I'm not sure LG supports. So that will require an LG app update. Thanks 

Link to comment
Share on other sites

It actually sounds like it's doing what I expect.  It's possible that your server is struggling to transcode/convert the file for playback as TrueHD isn't supported (which is why you get an error if you disable transcoding)

What happens if you select the AC3 audio track from the details screen before you start playback?

Link to comment
Share on other sites

MarkCranness
8 hours ago, SamES said:

What happens if you select the AC3 audio track from the details screen before you start playback?

I looked in the usual place, but there was no dropdown on the TV to select which audio stream to play.
(I have seen that dropdown before and selected it for other media, but it was not there for this MKV.)

After creating this thread, I noted that the remuxed (without the TrueHD stream) MKV had video errors every several seconds (a 1 second pause in the video on the TV).

I then tested both the remuxed MKV and also the original MKV with VideoLan on the server PC, and it also had video errors (blocks/breakup) at the same places:
SO I think that a corrupt MKV (badly encoded, it passed SabNZBD checks) must have confused either the re-encoding or the TV App.

I downloaded a different release, which ALSO had a TrueHD stream, and this time the LG App played it OK.

So I guess summary: Not a serious problem, and root cause is a corrupted MKV file, so please close this issue, thanks!
(Unless further examination might allow more graceful error handling?)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...