Jump to content

NVIDIA 750 ti - Emby not able to offload transcoding to HW


LeTiver
 Share

Recommended Posts

Hi folks,

I am new to this forum and Emby.  Here the gist of a question/problem that I have not been able to resolve:

Environment:

Host

Ubuntu Server (18.04) 
QEMU/KVM configuration
50TB (3 ZFS Pools) | Multiple VMs
Passthrough NVIDIA 750ti to VM (Guest A)

Guest A Ubuntu 20.04
 - Passthrough NVIDIA 750ti (nvidia-smi -> OK)
 - Docker 
Docker  Emby Server

Questions:

Although I have spent a good 2 days configuring things, reading posts, articles -- etc.  I have not been able to find clear answers to the following basic questions.  I kindly ask for your insight and/or specific links with specific answers to these questions:

  • Quote

    Some logs attached (Playing a movie I encoded to mpeg2 to ensure 750ti supports it. -- Log #2)

    1. hardware_detection
    2. Mpeg2 Movie: ffmpeg-transcode-7a1f
    3. HVEC LDMovie:ffmpeg-transcode-LDMOVIE_4k 

In short:

  • Is emby not using HW to transcode content because of configuration or GPU capability issues?

Other questions:

1. How do I know when/if emby is leveraging the video card for transcoding?
    The log is confusing to me (just learning about all this).  Some sections show UseHWcodecs=true -> Then it uses a SW encoder

    >>>>>>  FindVideoEncoder - Media: h264, UseHardwareCodecs: True, Mode: Custom
    Info    Checking: 'libx264 Software Encoder'
   Info    Check successful - selecting 'libx264 Software Encoder'

2. It appears emby recognized that HW is available/capable but then it is not used (lack of HW codecs)?

3. How do I know what is SW vs HW in the following lines?
16:51:30.397 Stream mapping:
16:51:30.397   Stream #0:0 -> #0:0 (mpeg2video (native) -> h264 (libx264))
16:51:30.397   Stream #0:1 -> #0:1 (copy)

 

I truly appreciate your help,

 

hardware_detection-63777948584.txt ffmpeg-transcode-7a1f26b1-5881-4197-9360-8e3cca20a4f5_1.txt ffmpeg-transcode-LDMOVIE_4k_a18a5662-fe1b-4052-88ef-216c28ab7742_1.txt

Edited by LeTiver
Link to comment
Share on other sites

I see.  No, I don't have a Premiere subscription.   Thanks for the quick response, let me see if I can sort that out.

 

 

Link to comment
Share on other sites

3 minutes ago, softworkz said:

@LeTiver - do you have an active Emby Premiere subscription? hw acceleration doesn't work without it.

No, I don't.  I will look into it.

Link to comment
Share on other sites

We should really display a message about this in the config UI, to avoid letting users work with the configuration and wondering why it doesn't work.

Sorry for the inconvenience.

Link to comment
Share on other sites

Happy2Play
1 minute ago, softworkz said:

We should really display a message about this in the config UI, to avoid letting users work with the configuration and wondering why it doesn't work.

Sorry for the inconvenience.

The page does have this.

image.png.71ca74e554af877949f048f56d6d5387.png

But may need a bigger note and color or a different position.

image.png.627268bea6c8b92c2eb4d289a811e30d.png

Link to comment
Share on other sites

16 minutes ago, softworkz said:

We should really display a message about this in the config UI, to avoid letting users work with the configuration and wondering why it doesn't work.

Sorry for the inconvenience.

Frankly, it is a must.  Also, although the logs are helpful, it takes time for someone new to understand what is relevant.  either a one pager explaining how to read the logs or adjusting logging entries.  I would have rather spend more time on other areas I am working on instead of guessing on matrix configurations...

Edited by LeTiver
Link to comment
Share on other sites

2 minutes ago, Happy2Play said:

The page does have this.

image.png.71ca74e554af877949f048f56d6d5387.png

Yes, but it's static and never changes.

 

2 minutes ago, Happy2Play said:

But may need a bigger note and color or a different position.

image.png.627268bea6c8b92c2eb4d289a811e30d.png

No, I think it should not even allow you to save a configuration with hwa when you don't have Premiere.

(or show a warning message on save at least)

Link to comment
Share on other sites

3 minutes ago, LeTiver said:

Frankly, it is a must.  Also, although the logs are helpful, it takes time for someone new to understand what is relevant.  either a one pager explaining how to read the logs or adjusting logging entries.  I would have rather spend more time on other areas I am working on instead on guessing sometimes...

We have added appropriate log output for this a while ago, so the beta has it meanwhile....

  • Like 1
Link to comment
Share on other sites

2 minutes ago, Happy2Play said:

The page does have this.

image.png.71ca74e554af877949f048f56d6d5387.png

But may need a bigger note and color or a different position.

image.png.627268bea6c8b92c2eb4d289a811e30d.png

This might be just my perspective, but it seems a 'small print attempt' for something quite important.  I suggest adding that line at the very top, no need of a red disclaimer but merely a good attempt to pinpoint a basic check.

Link to comment
Share on other sites

Happy2Play
3 minutes ago, softworkz said:

Yes, but it's static and never changes.

 

No, I think it should not even allow you to save a configuration with hwa when you don't have Premiere.

(or show a warning message on save at least)

True since the server knows one's status it should not be that hard to enable/disable or hide options per server status.

image.png.ea4128c8710a42a976d984fa9123f5e0.png

Link to comment
Share on other sites

Happy2Play
20 minutes ago, softworkz said:

We have added appropriate log output for this a while ago, so the beta has it meanwhile....

Thought this was logged but appears to only be in 4.7

Warning: Hardware acceleration is not available as it requires a valid Premiere Subscription

 

Edited by Happy2Play
Link to comment
Share on other sites

Happy2Play
Just now, softworkz said:

Yes, it's in the beta since October 21

True our longest split release beta cycle as some when into 4.6.7.0 and some did not.

Link to comment
Share on other sites

The next beta will provide an even more clear overview of available and chosen codecs:

image.png.d9ad69539e615ecbe0020d80aee298dd.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...