Jump to content

app crashes every second time i open the app (non Android TV device)


eeeeeesy
 Share

Recommended Posts

eeeeeesy

emby for android tv on pure android beelnk gtking box is crashing on first open but opens and works on the second try but crashes every second time i open the app.

embyserver.txt crashing at 4:29am eastern standard time/new york time

 

pure android box: beelink gtking 

Edited by eeeeeesy
Link to comment
Share on other sites

eeeeeesy
8 minutes ago, ebr said:

Can you please reproduce this problem and then follow the instructions to send a log from the app?

 

i enabled debug but the app crashes when i exit the settings menu. then i open the app and theres no send logs option on the home screen. so i checked to see if debug is still enabled and i see that it is still enabled.

Link to comment
Share on other sites

4 minutes ago, eeeeeesy said:

theres no send logs option on the home screen

The option is in the user menu at the top.

Quote

Now there will be a new option on the user menu at the top of your app home page labelled "Send Log".  

 

Link to comment
Share on other sites

3 minutes ago, eeeeeesy said:

ok logs sent. thanks

Okay, you are not running the current version of the app.  Please update it from the Play store.

Link to comment
Share on other sites

eeeeeesy
6 minutes ago, ebr said:

Okay, you are not running the current version of the app.  Please update it from the Play store.

the playstore only installs the regular android version. i installed the tv version from the direct link instead.

Link to comment
Share on other sites

Just now, eeeeeesy said:

the playstore only installs the regular android version

Okay, that's because this is not an approved Google Android TV device.  Re-install from either the APK on the web site or in our beta release notes thread out here.

Link to comment
Share on other sites

eeeeeesy
7 minutes ago, ebr said:

Okay, that's because this is not an approved Google Android TV device.  Re-install from either the APK on the web site or in our beta release notes thread out here.

from where? if you send me a link that would be easier. just now i have updated to 2.0.55g and its still crashing so i have sent you the logs again. 

Link to comment
Share on other sites

Okay the issue is that this is not an Android TV device and so a function the app is expecting isn't there.  We try to trap this case for non-standard devices but I guess this one is still a problem.  I'll have to see if there is a workaround for a future version.

Link to comment
Share on other sites

eeeeeesy
38 minutes ago, ebr said:

Okay the issue is that this is not an Android TV device and so a function the app is expecting isn't there.  We try to trap this case for non-standard devices but I guess this one is still a problem.  I'll have to see if there is a workaround for a future version.

that would be awesome. thanks. a workaround would be adding all the same features to the TV display option in the regular android version though since the regular android version does not crash.

Edited by eeeeeesy
Link to comment
Share on other sites

14 minutes ago, eeeeeesy said:

the regular android version does not crash.

Because it does not have the Android TV specific features this app is trying to use.

Link to comment
Share on other sites

eeeeeesy
8 hours ago, ebr said:

Because it does not have the Android TV specific features this app is trying to use.

all that needs to be carried over is

quick view tv guide when pressing the up button

fit more channels in the tv guide quick view (use compact layout)

Edited by eeeeeesy
Link to comment
Share on other sites

eeeeeesy
On 12/2/2021 at 9:18 AM, ebr said:

Please try the latest beta version of the TV app and see if it solves your crash.

but the live tv channels are delayed starting up and the guide takes too long to load. i have even restarted the server and cleared server cache. 

 

edited:

fixed by uninstalling server wmc plugin

Edited by eeeeeesy
Link to comment
Share on other sites

7 hours ago, eeeeeesy said:

but the live tv channels are delayed starting up and the guide takes too long to load. i have even restarted the server and cleared server cache. 

Re: 

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...