Jump to content

Weird connection problem (slow to load tracks)


bogdansrb
 Share

Recommended Posts

bogdansrb

I have an emby server at home which runs on a linux machine. I'm behind a PPPoE connection so I created forwards and a duckdns domain to connect to my server (with nginx for redirects and https). I have no issues connecting from any device outside the network except for the android head unit on my car, which hangs when starting a track (even up to a minute or more) or stops loading in the middle of it. I also received an error "no compatible streams are currently available". This doesn't happen all the time though, usually the first few tracks load up just fine. 

Now the internet connection on the head unit isn't that great, but other streaming services (even plex that runs on the same server) work fine. 

I also did a test - when it was trying to load a track I tried playing something from my phone and it worked immediately, so it's not a server issue. The weird thing is that this only happens with emby...

Link to comment
Share on other sites

bogdansrb

Logs are attached below.

I managed to reproduce the issue:

- load a selection of tracks

- the first few tracks start playing just fine, but after a while they stop loading (the cover art and tags appear but the actual track doesn't load and doesn't start playing) - easy to reproduce if I shuffle through a few tracks without letting them load

- no matter what track I try to play, none of them start loading/playing (even though, again, the cover and tags load just fine)

- open up plex (same server, same connection), tracks load fine OR re-open emby and that usually fixes the problem (until it starts doing it again)

I also made a video if it explains things better: 

 

logs.zip

Link to comment
Share on other sites

bogdansrb
12 hours ago, Luke said:

Hi @bogdansrb are you still seeing this with the latest app update, 3.2.14+?

Yes I still get it 

Link to comment
Share on other sites

Is this on a remote connection or inside your local network?

Link to comment
Share on other sites

bogdansrb
51 minutes ago, Luke said:

Is this on a remote connection or inside your local network?

Remote connection

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...