Jump to content

Issue with m3u - works fine in VLC but no compatible streams in Emby


kyleh195
 Share

Recommended Posts

kyleh195

I am trying to load a m3u source of publicly available PBS stations from https://i.mjh.nz/PBS/all.m3u8 . I am able to load that url directly in VLC and it resolves and displays fine. When I loaded into VLC as an m3u tuner and loaded guide data from https://i.mjh.nz/PBS/all.xml it found the channels and related guide fine. However when I try to open the channel in emby it gives the following error "Playback Error - No compatible streams are currently available. Please try again later or contact your system administrator for details." 

I have logs of the activity but I can't fully make sense of what is failing. It seems like when loading the channel it tries to open the specific stream and ffprobe suceeds (ProcessRun 'ffprobe' Process exited with code 0) but then something fails further in the process of trancoding/streaming.

To torubleshoot I loaded up xTeVe on the server and loaded the https://i.mjh.nz/PBS/all.m3u8 and same xml guide successfully there. The resulting xTeVe m3u stream loads fine in VLC but still fails in Emby. 

Link to comment
Share on other sites

That channel plays fine for me

image.png.c68dd44c793600e3f1a6c81d4e2c3465.png

What I'd suggest is removing xteve from the setup and add the channel and epg directly in Emby and try again.

Link to comment
Share on other sites

kyleh195

Tried loading directly the first time, but it failed so I added in xTeVe to see if limiting the number of available channels would fix. Here are logs and info from trying to do it directly. It is still erroring out.

I'm not sure if its relevant, but after clicking to play the channel once I see 3 ffmpeg logs, which are all attached. Not sure if there is a transcoding issue that is causing the multiple tries and ultimately the failure? Like I said it is processing in both scenarios in VLC, so the computer is able to handle the stream just not Emby.

error try2.PNG

Try2.PNG

Try 2 log snapshot.PNG

ffmpeg-transcode-5a761ef0-4ef5-4ef0-84c1-5254b7a0eed0_1.txt ffmpeg-transcode-2e4ac23e-73a3-4727-bf95-9a73735f9723_1.txt ffmpeg-directstream-141b491d-dfc8-4c5c-a7d3-86cafab7220e_1.txt embyserver - direct try.txt

Link to comment
Share on other sites

@Luke Can you take a look at this and tell us what you think is going on?

Looks like it's trying to cycle through the streams in the M3U.

Edited by cayars
Link to comment
Share on other sites

Hi, yes I'm not quite sure of the problem as it's happening within ffmpeg. The upcoming Emby Server 4.7 will be updating to a newer ffmpeg build so there's a decent chance that will help with this.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...