Jump to content

Seeing errors on the Image extraction process.


OurfamilySpot
Go to solution Solved by OurfamilySpot,

Recommended Posts

OurfamilySpot

Help, I am seeing a lot of these suddenly.    I noticed that after I chose to rebuild metadata and replace images I lost a lot of the prior images.  I checked the server log and see the following.  I don't know what I am looking at but it seems consistent.  

I see an error showing (output file not found), but I don't know how that would even be possible?   My entire media library is on one volume and images are able to be generated for other files without issue.  There are NO special characters in these file names and there are NO permissions on the drive.

 

2021-08-31 09:27:55.584 Debug App: Running FFProbeProvider for /Volumes/Media HD/Clips/Video 01.mp4
2021-08-31 09:27:55.588 Info MediaProbeManager: ProcessRun 'ffprobe' Execute: /Applications/EmbyServer.app/Contents/MacOS/ffprobe -i file:"/Volumes/Media HD/Clips/Video 01.mp4" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2021-08-31 09:27:55.631 Debug MediaProbeManager: ProcessRun 'ffprobe' Started.
2021-08-31 09:27:55.660 Info MediaProbeManager: ProcessRun 'ffprobe' Process exited with code 0
2021-08-31 09:27:55.708 Debug App: Running VideoNfoProvider for /Volumes/Media HD/Clips/Video 01.mp4
2021-08-31 09:27:55.733 Debug App: Running VideoImageProvider for /Volumes/Media HD/Clips/Video 01.mp4
2021-08-31 09:27:55.740 Info App: ProcessRun 'extract-image' Execute: /Applications/EmbyServer.app/Contents/MacOS/ffmpeg -f mp4 -threads 1 -i file:"/Volumes/Media HD/Clips/Video 01.mp4" -map 0:2 -threads 0 -vframes 1 -vf "scale=trunc(min(max(iw\,ih*dar)\,min(600\,0*dar))/2)*2:trunc(min(max(iw/dar\,ih)\,min(600/dar\,0))/2)*2,thumbnail=24" -f image2 "/Users/dave/.config/emby-server/cache/temp/23235d83-fac2-4bb6-afba-3b4297ebc75d.jpg"
2021-08-31 09:27:55.778 Debug App: ProcessRun 'extract-image' Started.
2021-08-31 09:27:55.809 Info App: ProcessRun 'extract-image' Process exited with code 1
2021-08-31 09:27:56.299 Error ImageExtraction: ffmpeg image extraction failed for file:"/Volumes/Media HD/Clips/Video 01.mp4" (output file not found)
2021-08-31 09:27:56.311 Error ImageExtraction: Thumbnail-Filter extraction failed, will attempt standard way. Input: file:"/Volumes/Media HD/Clips/Video 01.mp4"
2021-08-31 09:27:56.328 Info App: ProcessRun 'extract-image' Execute: /Applications/EmbyServer.app/Contents/MacOS/ffmpeg -f mp4 -threads 1 -i file:"/Volumes/Media HD/Clips/Video 01.mp4" -map 0:2 -threads 0 -vframes 1 -vf "scale=trunc(min(max(iw\,ih*dar)\,min(600\,0*dar))/2)*2:trunc(min(max(iw/dar\,ih)\,min(600/dar\,0))/2)*2" -f image2 "/Users/dave/.config/emby-server/cache/temp/33b872ba-9009-41f1-9afa-2d7b8abadfdb.jpg"
2021-08-31 09:27:56.375 Debug App: ProcessRun 'extract-image' Started.
2021-08-31 09:27:56.401 Info App: ProcessRun 'extract-image' Process exited with code 1
2021-08-31 09:27:56.893 Error ImageExtraction: ffmpeg image extraction failed for file:"/Volumes/Media HD/Clips/Video 01.mp4" (output file not found)
2021-08-31 09:27:56.936 Error App: Error in Screen Grabber
    *** Error Report ***
    Version: 4.6.4.0
    Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll
    Operating system: Darwin 21.0.0 Darwin Kernel Version 21.0.0: Mon Aug  2 00:18:13 PDT 2021; root:xnu-8019.30.9~9/RELEASE_ARM64_T8101
    Framework: .NET Core 3.1.8
    OS/Process: x64/x64
    Runtime: Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
    Processor count: 8
    Data path: /Users/dave/.config/emby-server
    Application path: /Applications/EmbyServer.app/Contents/MacOS
    System.Exception: System.Exception: ffmpeg image extraction failed for file:"/Volumes/Media HD/Clips/Video 01.mp4" (output file not found)
       at Emby.Server.MediaEncoding.ImageExtraction.ImageExtractionManager.ExtractImageInternal(ReadOnlyMemory`1 inputPath, ReadOnlyMemory`1 container, MediaStream videoStream, Nullable`1 streamIndex, Nullable`1 threedFormat, Nullable`1 offset, Boolean useThumbNailFilter, CancellationToken cancellationToken)
       at Emby.Server.MediaEncoding.ImageExtraction.ImageExtractionManager.ExtractImage(ReadOnlyMemory`1 inputPath, ReadOnlyMemory`1 container, MediaStream videoStream, Nullable`1 streamIndex, MediaProtocol protocol, Boolean isAudio, Nullable`1 threedFormat, Nullable`1 offset, CancellationToken cancellationToken)
       at MediaBrowser.Providers.MediaInfo.VideoImageProvider.GetVideoImage(Video item, CancellationToken cancellationToken)
       at MediaBrowser.Providers.Manager.ItemImageProvider.RefreshFromProvider(BaseItem item, IDynamicImageProvider provider, Boolean providerReportsChanges, ImageRefreshOptions refreshOptions, TypeOptions savedOptions, LibraryOptions libraryOptions, List`1 downloadedImages, RefreshResult result, CancellationToken cancellationToken)
    Source: Emby.Server.MediaEncoding
    TargetSite: Void MoveNext()
    
2021-08-31 09:27:56.987 Debug App: Saving nfo metadata for /Volumes/Media HD/Clips/Video 01.mp4 to /Volumes/Media HD/Clips/Video 01.nfo.
2021-08-31 09:27:57.004 Debug App: InfuseSync received updated item 'Video 01' of type 'Video' Guid 'f323265d-9da3-33e6-9a36-6beee09f0067' ItemID '18701'
    Framework: .NET Core 3.1.8
    OS/Process: x64/x64
    Runtime: Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
    Processor count: 8
    Data path: /Users/dave/.config/emby-server
    Application path: /Applications/EmbyServer.app/Contents/MacOS
    System.Exception: System.Exception: ffmpeg image extraction failed for file:"/Volumes/Media HD/Clips/Video01.mp4" (output file not found)
       at Emby.Server.MediaEncoding.ImageExtraction.ImageExtractionManager.ExtractImageInternal(ReadOnlyMemory`1 inputPath, ReadOnlyMemory`1 container, MediaStream videoStream, Nullable`1 streamIndex, Nullable`1 threedFormat, Nullable`1 offset, Boolean useThumbNailFilter, CancellationToken cancellationToken)
       at Emby.Server.MediaEncoding.ImageExtraction.ImageExtractionManager.ExtractImage(ReadOnlyMemory`1 inputPath, ReadOnlyMemory`1 container, MediaStream videoStream, Nullable`1 streamIndex, MediaProtocol protocol, Boolean isAudio, Nullable`1 threedFormat, Nullable`1 offset, CancellationToken cancellationToken)
       at MediaBrowser.Providers.MediaInfo.VideoImageProvider.GetVideoImage(Video item, CancellationToken cancellationToken)
       at MediaBrowser.Providers.Manager.ItemImageProvider.RefreshFromProvider(BaseItem item, IDynamicImageProvider provider, Boolean providerReportsChanges, ImageRefreshOptions refreshOptions, TypeOptions savedOptions, LibraryOptions libraryOptions, List`1 downloadedImages, RefreshResult result, CancellationToken cancellationToken)
    Source: Emby.Server.MediaEncoding
    TargetSite: Void MoveNext()
    
2021-08-31 09:27:56.987 Debug App: Saving nfo metadata for /Volumes/Media HD/Clips/Video01.mp4 to /Volumes/Media HD/Clips/Video01.nfo.
2021-08-31 09:27:57.004 Debug App: InfuseSync received updated item 'Video01' of type 'Video' Guid 'f323265d-9da3-33e6-9a36-6beee09f0067' ItemID '18701'

Link to post
Share on other sites
Luke

Hi there, please attach the complete emby server log file. thanks.

Link to post
Share on other sites
  • 2 weeks later...
  • Solution
OurfamilySpot

so, this seemed to clear itself up without me doing anything.   I don't know what caused it, but its working perfectly now.

 

Link to post
Share on other sites
Luke

Hi, my guess would be that it's related to certain video files. The server won't keep trying over and over again so that could be why those errors are gone from your log now.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...