Jump to content

About the Genres Page - EmbyServer 4.6.4.0


CarlosLima
 Share

Recommended Posts

CarlosLima

Hi,
I have this CSS code that I use to remove the text below the gender image, as I prefer the text in the image itself, but it looks like it broke in the new version as it's applied but the text is still there.
Thanks for a tip.

 

/* #35 - Remove o texto sob a imagem dos gêneros - Happy2Play-280420 */
[data-type="Genre"] div.cardText {display: none;}

 

generosf.png

Link to comment
Share on other sites

Happy2Play

These are getting harder to remove a "data-type=" has been removed and each library has a different data-index for the tab.  It there were a unified data- index then this wouldn't be a issue.

It is a little bit of a pain if you have a lot of libraries but you could do data-index per parent-id.

Example for my Movie and TV Shows library

div.tabContent[data-index="9"] [data-parentid="26ca8e4674122bc3f4e29538c93b7f7c"] div.cardText {display: none;}
div.tabContent[data-index="4"] [data-parentid="7c59a598afef455d09ded8af12fa503d"] div.cardText {display: none;}

tab.thumb.jpg.9b8fc14c76ebc9a66ada680ff4fd9aa5.jpg

Link to comment
Share on other sites

CarlosLima

Hi,
This is complex to explain, but I'll try.
I have EmbyServer Beta testing installed on a local pc.
In it, your code worked perfectly.

I have EmbyServer Stable installed on a VPS.
In it, the same code did not work.

I leave the images to try to help solve this mystery.
Thank you from now on.

download.png

download44.png

Link to comment
Share on other sites

Happy2Play
4 minutes ago, CarlosLima said:

Hi,
This is complex to explain, but I'll try.
I have EmbyServer Beta testing installed on a local pc.
In it, your code worked perfectly.

I have EmbyServer Stable installed on a VPS.
In it, the same code did not work.

I leave the images to try to help solve this mystery.
Thank you from now on.

Did you change the "data-parentid=xxxxxxxxxxx" on the VPS server as the library id is unique per server?

Link to comment
Share on other sites

CarlosLima

Yes, of course.

Link to comment
Share on other sites

Happy2Play
4 minutes ago, CarlosLima said:

Yes, of course.

Minus code errors it is hard to say.  What does the console show?

console.thumb.jpg.513f7a7e4b038ec0579ded2ff0b0f27a.jpg

Link to comment
Share on other sites

CarlosLima

Now it got more sinister.
See the elements of my server on the VPS, greatly reduced compared to yours.

Captura de tela 2021-07-26 185941.jpg

Link to comment
Share on other sites

CarlosLima
Posted (edited)

And more curious now.
When logging into vps and opening Emby, the code works.
If I log into Emby remotely from my local pc, the code doesn't work.
I cleaned only navigation data on the VPS and on the local pc and the same result.

Edited by CarlosLima
Link to comment
Share on other sites

Happy2Play
3 minutes ago, CarlosLima said:

Now it got more sinister.
See the elements of my server on the VPS, greatly reduced compared to yours.

Captura de tela 2021-07-26 185941.jpg

You just haven't selected a specific element as I did.  I am in the expanded "mainAnimationPages" section vs you just opening the console.

image.thumb.png.6969a7498fbed102c7b994d6d6b74c72.png

Don't know anything about VPS but would not think it is any different then a any other server.  

Link to comment
Share on other sites

CarlosLima

Is this expanded area you referred to?

Captura de tela 2021-07-26 193330.jpg

Link to comment
Share on other sites

Happy2Play
10 minutes ago, CarlosLima said:

Is this expanded area you referred to?

Captura de tela 2021-07-26 193330.jpg

Yes that would tell me data-index=4 with a data-parentid= 73a784e72cb318e2fdaaf86447fc673d, but you need to go down a little further to the cardtext section.

Link to comment
Share on other sites

CarlosLima

Hey,
Thanks for all the support you always offer.
I couldn't understand the part of the card text that is needed, but I think it's best not to go ahead with this feature. The code is correct because when accessing Emby in vps it works perfect. So I'll prefer to forget about the mystery.
Thank you very much.

Link to comment
Share on other sites

CarlosLima

SORTED OUT. Perfect now.
I simply forgot that I use Cloudflare and just clear the cache and everything is perfect now.
Thanks for all your patience and help.

  • Like 1
Link to comment
Share on other sites

Spaceboy

cloudflare cache is more trouble than its worth IMO

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...