Jump to content

I cannot access the ddns of the WAN


Go to solution Solved by Q-Droid,

Recommended Posts

zushl

sometimes i can access the ddns,but sometimes i can't.(The same setting)

I turned off upnp, but turned on port forwarding.(Tried local http and network http port forwarding)

I tested that the port prompt is closed,But the same settings qb and tr can be used normally

How can i solve the problem?

I did not use ssl certificate,And The ddns I use is DYNU

Maybe this is related to multiple dialing?

Link to post
Share on other sites
cayars

Forgetting about dns for the initial test, if you go to cannyouseeme.org and test your server using the correct port (ie 8096) does it work or fail?

Link to post
Share on other sites
zushl
20 hours ago, cayars said:

Forgetting about dns for the initial test, if you go to cannyouseeme.org and test your server using the correct port (ie 8096) does it work or fail?

sorry,i can't access the url

i always use tool.chinaz.com/port.

When I remove ddns and only use ip, it can be accessed normally

Link to post
Share on other sites
rbjtech

ddns is simply a dns entry on the internet dynamically updated from your home network as it changes  - so can you resolve the DNS name outside emby ?

use 'nslookup <yourDNSname>'

does it resolve correctly to your WAN IP address ?

If not, then the issue is your Dynamic DNS update process (this has nothing to do with Emby) - As your WAN IP changes (from your ISP) - it may not be updating the entry quickly enough and thus you see the old entry until it is updated.

The issue may also be the time it takes for the update to replicate to all the DNS servers - this may take hours. 

If your IP changes often then getting a static IP may be a better option if one is available.

  • Like 1
Link to post
Share on other sites
pwhodges

The DDNS is merely a lookup for the IP.  Are you sure that the DDNS service is updating in a timely manner?

Paul

  • Like 1
Link to post
Share on other sites
zushl
On 7/19/2021 at 7:09 PM, cayars said:

Sorry got an extra "n" in there.  It should have been

https://canyouseeme.org/

ok, i test

An interesting thing happened. When i test qb's port, it's opening, but when i test emby's port, it's closing.

and i can't open the webpage again.But I did not change any settings.The only possible change is the redial of the isp

Link to post
Share on other sites
zushl
On 7/19/2021 at 6:06 PM, rbjtech said:

ddns is simply a dns entry on the internet dynamically updated from your home network as it changes  - so can you resolve the DNS name outside emby ?

use 'nslookup <yourDNSname>'

does it resolve correctly to your WAN IP address ?

If not, then the issue is your Dynamic DNS update process (this has nothing to do with Emby) - As your WAN IP changes (from your ISP) - it may not be updating the entry quickly enough and thus you see the old entry until it is updated.

The issue may also be the time it takes for the update to replicate to all the DNS servers - this may take hours. 

If your IP changes often then getting a static IP may be a better option if one is available.

thx for u reply

i tried, and I manually modified my ip,it shows non-authoritative answer

Link to post
Share on other sites
zushl
On 7/19/2021 at 6:22 PM, pwhodges said:

The DDNS is merely a lookup for the IP.  Are you sure that the DDNS service is updating in a timely manner?

Paul

I manually modified my ip, but i still can't access. i think the reason is my port is closed. But I have done port forwarding

under the same setting qb and tr can work

Link to post
Share on other sites
rbjtech
4 hours ago, zushl said:

thx for u reply

i tried, and I manually modified my ip,it shows non-authoritative answer

You will always get a non-authoritative answer when using the public DNS system (unless you own the root DNS servers lol) 

So the key question is does the IP returned match your WAN IP address ?

If yes, then we know DNS is working and it's likely just a port forwarding issue.

Is emby 'listening' on the correct port - on the Remote (WAN) Access on the Emby Dashboard - does it list your FQDN OR IP with the correct port after it - ie http:\\1.2.3.4:8920 or https:\\1.2.3.4:8920

If using Windows - try 

netstat -a | find "8920"

from a command prompt.  It should return something like this -

  TCP    0.0.0.0:8920           MEDIA:0                LISTENING
  TCP    [::]:8920              MEDIA:0                LISTENING

 

4 hours ago, zushl said:

I manually modified my ip, but i still can't access. i think the reason is my port is closed. But I have done port forwarding

under the same setting qb and tr can work

What is qb/tr ?

If that port forward works, then as long as it's using a different port and/or different IP - then you should be good.

Link to post
Share on other sites
zushl
21 hours ago, rbjtech said:

You will always get a non-authoritative answer when using the public DNS system (unless you own the root DNS servers lol) 

So the key question is does the IP returned match your WAN IP address ?

If yes, then we know DNS is working and it's likely just a port forwarding issue.

The returned address is correct,so it's must be port forwarding issue

21 hours ago, rbjtech said:

Is emby 'listening' on the correct port - on the Remote (WAN) Access on the Emby Dashboard - does it list your FQDN OR IP with the correct port after it - ie http:\\1.2.3.4:8920 or https:\\1.2.3.4:8920

If using Windows - try 


netstat -a | find "8920"

from a command prompt.  It should return something like this -


  TCP    0.0.0.0:8920           MEDIA:0                LISTENING
  TCP    [::]:8920              MEDIA:0                LISTENING

 

will, i find these two

tcp      0.0.0.0:my port      name:0      listening

  TCP    [::]:my prot            name:0                LISTENING

 

21 hours ago, rbjtech said:

What is qb/tr ?

If that port forward works, then as long as it's using a different port and/or different IP - then you should be good.

qbitorrent 4.2.1

transmission 2.9.4

These two software's ports are normally open

Link to post
Share on other sites
rbjtech

ok - so emby is listening on the correct port (TCP 8920). 👍

So all that is left is the Port Forward and firewall rule(s) for the inbound connectivity.

I'm not sure what equipment you are using, but on an typical ISP provided router - when you set a 'Port Forward' - ie WAN(Any:Any) > Emby Host IP on TCP 8920 - the associated f/w rule is also set for you - but worth checking.   Lastly,  when you install emby, it creates the Windows Incoming f/w rules for you - but again, worth checking.

 

Link to post
Share on other sites
zushl
On 2021/7/22 at PM5点58分, rbjtech said:

好的 - 所以 emby 正在侦听正确的端口(TCP 8920)。 👍

所以剩下的就是用于入站连接的端口转发和防火墙规则。

我不确定您使用的是什么设备,但是在典型的 ISP 提供的路由器上 - 当您设置 “端口转发” 时 - 即WAN (Any:Any) > TCP 8920 上的 Emby Host IP - 相关的 f/w 规则是也为您设置 - 但值得检查。最后,当您安装 emby 时,它会为您创建 Windows Incoming f/w 规则 - 但同样值得检查。

 

ok,i'll check windows firewall

but why sometimes i can access ,After a period of time, I can't access it.

Link to post
Share on other sites
On 7/22/2021 at 5:58 PM, rbjtech said:

ok - so emby is listening on the correct port (TCP 8920). 👍

So all that is left is the Port Forward and firewall rule(s) for the inbound connectivity.

I'm not sure what equipment you are using, but on an typical ISP provided router - when you set a 'Port Forward' - ie WAN(Any:Any) > Emby Host IP on TCP 8920 - the associated f/w rule is also set for you - but worth checking.   Lastly,  when you install emby, it creates the Windows Incoming f/w rules for you - but again, worth checking.

 

my firewall software is ESET Internet Security, i add a custom rule in my firewall

I allow both inbound and out bound,protocol is any, and I entered emby's http connection port in local and internet.But i still can't access the wan.

I check the prot,it's still closed.

 

eset.PNG

Link to post
Share on other sites
  • Solution

Make sure that you're using port forwarding and not port triggering. Bittorrent is a p2p protocol with outbound and inbound connections. Emby is not and might explain why your access stops working after some time since the triggered ports will expire.

 

  • Like 2
Link to post
Share on other sites
On 7/26/2021 at 11:03 AM, Q-Droid said:

Make sure that you're using port forwarding and not port triggering. Bittorrent is a p2p protocol with outbound and inbound connections. Emby is not and might explain why your access stops working after some time since the triggered ports will expire.

 

Should be the reason

I know why this problem occurred.  If i just set port forwading,it must be port triggering mode. so I need to set forwarding in the firewall' area section as the second step

Edited by zushl
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...