Jump to content

Live TV not working - Error: No compatible streams


linuxabuser
 Share

Go to solution Solved by linuxabuser,

Recommended Posts

linuxabuser

This seems to be a problem with DVBLink. It was working up until a few months ago. This is the log snippet that makes me think there's an issue with DVBLink. The full log is attached.

2021-07-17 11:41:19.936 Info Server: http/1.1 Response 200 to 10.0.0.232. Time: 8166ms. http://10.0.0.112:8096/emby/Users/d1c887f41f77448c87a111aacea191a2/Items/57127?X-Emby-Client=Emby Web&X-Emby-Device-Name=Chrome&X-Emby-Device-Id=413161b5-a5c3-49b2-ba2c-631d31b74b48&X-Emby-Client-Version=4.6.4.0
2021-07-17 11:41:19.969 Info Server: http/1.1 GET http://10.0.0.112:8096/emby/LiveTv/Programs?ChannelIds=57127&UserId=d1c887f41f77448c87a111aacea191a2&HasAired=false&SortBy=StartDate&ImageTypeLimit=1&EnableUserData=false&Fields=PrimaryImageAspectRatio,Overview&Limit=30&X-Emby-Client=Emby Web&X-Emby-Device-Name=Chrome&X-Emby-Device-Id=413161b5-a5c3-49b2-ba2c-631d31b74b48&X-Emby-Client-Version=4.6.4.0. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36 Edg/91.0.864.67
2021-07-17 11:41:19.983 Info App: [DVBLink] - Get Timers
2021-07-17 11:41:19.983 Info App: [DVBLink] - Connecting to server : http://localhost:8100/mobile/
2021-07-17 11:41:24.083 Error HttpClient: Error getting response from http://localhost:8100/mobile/
	*** Error Report ***
	Version: 4.6.4.0
	Command line: C:\Users\Home\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows 10.0.19043
	Framework: .NET Core 3.1.13
	OS/Process: x64/x64
	Runtime: C:/Users/Home/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	Processor count: 4
	Data path: C:\Users\Home\AppData\Roaming\Emby-Server\programdata
	Application path: C:\Users\Home\AppData\Roaming\Emby-Server\system
	System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: No connection could be made because the target machine actively refused it.
	 ---> System.Net.Sockets.SocketException (10061): No connection could be made because the target machine actively refused it.
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   --- End of inner exception stack trace ---
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	Source: System.Net.Http
	TargetSite: Void MoveNext()
	InnerException: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it.
	Source: System.Private.CoreLib
	TargetSite: Void Throw()
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	
2021-07-17 11:41:24.083 Error App: [DVBLink] - It's not possible to Ensure a connection to the Server
	*** Error Report ***
	Version: 4.6.4.0
	Command line: C:\Users\Home\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows 10.0.19043
	Framework: .NET Core 3.1.13
	OS/Process: x64/x64
	Runtime: C:/Users/Home/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	Processor count: 4
	Data path: C:\Users\Home\AppData\Roaming\Emby-Server\programdata
	Application path: C:\Users\Home\AppData\Roaming\Emby-Server\system
	System.FormatException: System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
	   at System.Text.StringBuilder.AppendFormatHelper(IFormatProvider provider, String format, ParamsArray args)
	   at System.String.FormatHelper(IFormatProvider provider, String format, ParamsArray args)
	   at System.String.Format(String format, Object[] args)
	   at Emby.Plugins.DVBLogic.Helpers.PluginLogger.ErrorException(String message, Exception exception, Object[] paramList)
	   at TSoft.TVServer.HttpClientBase.GetResponseObjectAsync[T,R](R request_object, CancellationToken cancellationToken, Boolean includeResponse, Boolean includeRequest)
	   at TSoft.TVServer.TVServerClient.EnsureConnectionAsync(CancellationToken cancellationToken)
	Source: System.Private.CoreLib
	TargetSite: System.Text.StringBuilder AppendFormatHelper(System.IFormatProvider, System.String, System.ParamsArray)

 

embyserver (1).txt

Link to comment
Share on other sites

Hi, From a browser if you try to open http://localhost:8100/mobile/ 

do you get any response back?  If not that sounds like you may need to see what stopped working or changed outside of Emby.

Edited by cayars
Link to comment
Share on other sites

linuxabuser
3 hours ago, cayars said:

Hi, From a browser if you try to open http://localhost:8100/mobile/ 

do you get any response back?  If not that sounds like you may need to see what stopped working or changed outside of Emby.

"Refused to connect"

Link to comment
Share on other sites

linuxabuser

Uhhh... sure. This is just a plugin I installed, I don't know why it refuses to function. It used to, now it doesn't. 

Link to comment
Share on other sites

18 hours ago, cayars said:

Is http://localhost:8100/mobile/  the DVBLink Server that doesn't seem to be functioning???

Yes it is:

[DVBLink] - Connecting to server : http://localhost:8100/mobile/

So if the DVBLink server is not functioning, then the DVBLink plugin in Emby will not be able to communicate with it.

@linuxabuser is your DVBLink application still functioning on it's own outside of Emby?

  • Thanks 1
Link to comment
Share on other sites

linuxabuser

You know, DVBLink may just be a red herring. I've never had anything DVB-link related installed except the plugin. The full log was attached, not sure where else to look in there regarding no Live TV playback.

Link to comment
Share on other sites

On 7/19/2021 at 1:49 AM, Luke said:

Yes it is:


[DVBLink] - Connecting to server : http://localhost:8100/mobile/

 

I don't think so, isn't that just a status message telling us it's about to connect?  The next line in the log when it tries to connect fails.
At least that's the way I'd read it, having never used this plugin.

Link to comment
Share on other sites

18 hours ago, linuxabuser said:

You know, DVBLink may just be a red herring. I've never had anything DVB-link related installed except the plugin. The full log was attached, not sure where else to look in there regarding no Live TV playback.

@linuxabuser, try removing the dvblink plugin, then restart emby server, run a refresh of the guide data in live tv setup, and those error messages should go away.

Please let us know if this helps. Thanks.

Link to comment
Share on other sites

linuxabuser

Hi @Luke, thank you for the advice. I did remove all Live TV related plugins, and have restarted Emby Server. I think we're closer to the root of the playback issue now. Still the same issue as before, but a more precise error. Log attached.

2021-07-27 21:03:34.023 Info Server: http/1.1 Response 500 to 10.0.0.211. Time: 2ms. http://10.0.0.112:8096/emby/videos/57127/live.m3u8?DeviceId=B28A89D5-9B07-43C1-BEFF-8ACE8E806F19&MediaSourceId=native_756a6fbc233db16242193767bb1783fb_e344645dc21e103c61537e9ef7cf9037&PlaySessionId=b533cd317e914e7bb621f0903595775b&LiveStreamId=06044cf0e6f93cdae5f285c9ecfaaeb4_01413a525b3a9622ce6fdf19f7dde354_native_756a6fbc233db16242193767bb1783fb_e344645dc21e103c61537e9ef7cf9037&VideoCodec=h264,hevc,mpeg2video&AudioCodec=ac3,mp3,aac&VideoBitrate=139808000&AudioBitrate=192000&TranscodingMaxAudioChannels=6&SegmentContainer=ts&SegmentLength=3&MinSegments=1&BreakOnNonKeyFrames=True&hevc-profile=Main,Main10&TranscodeReasons=DirectPlayError&allowVideoStreamCopy=false
2021-07-27 21:03:34.035 Info Server: http/1.1 GET http://10.0.0.112:8096/emby/videos/57127/live.m3u8?DeviceId=B28A89D5-9B07-43C1-BEFF-8ACE8E806F19&MediaSourceId=native_756a6fbc233db16242193767bb1783fb_e344645dc21e103c61537e9ef7cf9037&PlaySessionId=b533cd317e914e7bb621f0903595775b&LiveStreamId=06044cf0e6f93cdae5f285c9ecfaaeb4_01413a525b3a9622ce6fdf19f7dde354_native_756a6fbc233db16242193767bb1783fb_e344645dc21e103c61537e9ef7cf9037&VideoCodec=h264,hevc,mpeg2video&AudioCodec=ac3,mp3,aac&VideoBitrate=139808000&AudioBitrate=192000&TranscodingMaxAudioChannels=6&SegmentContainer=ts&SegmentLength=3&MinSegments=1&BreakOnNonKeyFrames=True&hevc-profile=Main,Main10&TranscodeReasons=DirectPlayError&allowVideoStreamCopy=false. Connection=close, Accept=*/*, Host=10.0.0.112:8096, Range=bytes=0-, User-Agent=libmpv, Icy-MetaData=1
2021-07-27 21:03:34.036 Error Server: Error processing request
	*** Error Report ***
	Version: 4.6.4.0
	Command line: C:\Users\Home\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows 10.0.19043
	Framework: .NET Core 3.1.13
	OS/Process: x64/x64
	Runtime: C:/Users/Home/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	Processor count: 4
	Data path: C:\Users\Home\AppData\Roaming\Emby-Server\programdata
	Application path: C:\Users\Home\AppData\Roaming\Emby-Server\system
	System.Exception: System.Exception: GetVideoEncoder: Unknown codec specified: ''
	   at Emby.Server.MediaEncoding.Encoder.Demands.DemandsBuilder.BuildVideoInputDemand(MediaStream mediaStream)
	   at Emby.Server.MediaEncoding.Encoder.Demands.DemandsBuilder.BuildVideoInputDemand(EncodingJobInfo state)
	   at Emby.Server.MediaEncoding.Encoder.Demands.DemandsBuilder.BuildDemands(EncodingJobInfo state, EncodingDiagnosticOptions diagnosticOptions)
	   at Emby.Server.MediaEncoding.Encoder.TranscodingCommandBuilder.BuildDemands(EncodingJobInfo state)
	   at Emby.Server.MediaEncoding.Encoder.TranscodingCommandBuilder.HlsGetCommandLineArguments(String outputPath, StreamState state, Int32 startNumber, Boolean createSubtitleParameters, Boolean isForTv, String segmentFileExtension)
	   at Emby.Server.MediaEncoding.Api.Hls.VideoHlsService.GetCommandLineArguments(String outputPath, StreamState state)
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.StartFfMpeg(StreamState state, String outputPath, CancellationTokenSource cancellationTokenSource, Boolean acquireResources)
	   at Emby.Server.MediaEncoding.Api.Hls.BaseHlsService.ProcessRequest(StreamRequest request)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: Emby.Server.MediaEncoding
	TargetSite: Emby.Server.MediaEncoding.Encoder.Demands.Output.VideoInputDemand BuildVideoInputDemand(MediaBrowser.Model.Entities.MediaStream)

 

embyserver.txt

Link to comment
Share on other sites

  • Solution
linuxabuser

Ah. Well - this was the issue: live TV/DVR no longer working after upgrade - Fixed! - Live TV - Emby Community

I had to adjust the buffer in Hauppauge WinTV v10 to something >0 minutes. I need to monitor the buffer path (pointed to temp SSD drive) to make sure it doesn't record crap for hours on end when no one is watching.

Do I still need WinTV v10 software with this latest version of Emby, I'm asking because that thread mentions some other things, but it's been over 2 years.

Edited by linuxabuser
Link to comment
Share on other sites

Yes WinTV is still needed for now.  The work in progress version of the next generation Live TV can communicate directly with your hardware and that version will not need WinTV. 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...